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Macintosh General
Information

What’s Covered
TrueType Fonts vs. PostScript Fonts
Display and Printing
Hinting
Resources

The following is a brief overview of TrueType fonts and their features, including a comparison
with PostScript fonts.

TrueType Fonts vs. PostScript Fonts
TrueType fonts are composed in the TrueImage page description language and are described
using quadratic splines, while PostScript fonts are composed in the PostScript page description
language and are described using Bezier curves. Quadratic splines draw more quickly, but Bezier
curves print more defined curves.

A TrueType font is composed of a single file that is used for both display and printing. TrueType
fonts icons display in the Finder as a dog-eared page with three letter “A”s in progressively larger
sizes, and their filenames do not include a point size.

A PostScript Type 1 font has two components: a bitmap (screen) font file and an outline
(printer) font file. PostScript bitmap font icons appear in the Finder as a dog-eared page with
the letter “A,” and their filenames include a point size (e.g., Times 10, Geneva 14). Adobe
PostScript outline font icons appear in the Finder as a letter “A” in front of horizontal lines.
Outline fonts created by other companies may have different icons.

On the Macintosh, both TrueType and PostScript Type 1 bitmap font files are stored in suit-
cases. PostScript Type 1 outline font files are stored loose in the same folder you store your
suitcases in.

To install a TrueType font in the default location, copy the font file or suitcase from the original
disk to the Fonts folder in the System Folder. You can also install font files in other locations
using a font manager (e.g., Adobe Type Manager 4.0, Symantec Suitcase).

Display and Printing
TrueType fonts are designed to display and print clearly at any point size. When you print
TrueType fonts to a QuickDraw printer (e.g., Apple StyleWriter, Hewlett Packard DeskJet), the
QuickDraw information used by the Macintosh for display is sent directly to the printer. When
you print TrueType fonts to a PostScript printer, the printer driver usually converts them to
PostScript-compatible fonts (e.g., Type 1). During this conversion some font information may
be lost or altered slightly, including font hinting and stroke widths. However, when you print to
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a TrueImage PostScript printer, which uses native TrueType information, or to a printer contain-
ing a TrueType rasterizer (e.g., Apple LaserWriter Pro 600 and 630, Apple Personal LaserWriter
NTR), the driver does not convert the fonts, enabling them to print with no alteration.

If both the TrueType and PostScript version of the same font are installed, you may get unex-
pected display and printing results (e.g., unexpected character spacing, unexpected line and
page breaks) because a PostScript font’s character spacing may not be identical to an equivalent
TrueType font’s character spacing. If you will be printing to a QuickDraw or TrueImage device,
TrueType fonts provide the most accurate representation on screen of the printed output. If you
will be printing to a PostScript device, composing and viewing a document using the PostScript
font and ATM will provide the most accurate representation on screen of the printed output.

Hinting
Hints are instructions built into outline fonts that enable character shapes, especially subtle
curves printed at small point sizes and low resolutions, to print as close to the designed charac-
ter shape as possible. TrueType fonts contain complex hinting information: they can hint each
character, different sizes of a character, and rotated text.

Resources
Every Macintosh file contains resources, which are components of the file that contain program-
ming information. TrueType fonts have an SFNT resource and a FOND resource. The SFNT
resource contains scaleable outline data and advanced typographic functions (e.g., automatic
glyph substitution for fractions and ligatures, alternate character styles, kerning and tracking,
optical alignment, multiple design styles, and variable width and weight). The FOND resource
specifies fractional character widths, pair kern information, and the font’s name.

TrueType Fonts on the Macintosh General Information continued
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TrueType Version Font

If you have both the PostScript and the TrueType version of the same font installed, an applica-
tion may compose a file using one version of the font, but print using the other version of the
font. The PostScript and the TrueType version of a font may have different character spacing, so
having both font versions installed can cause an application to display or print the font with
unexpected character spacing, line breaks, or page breaks. Some applications (e.g., Adobe
Illustrator 5.x and later) cannot display a font correctly when you have both versions of the font
installed.

If you are printing a file containing a PostScript font to a PostScript device, and you are using
Adobe Type Manager (ATM), formatting text using PostScript fonts gives you the closest on-
screen representation of the printed output. If you are printing to a QuickDraw or TrueImage
device, formatting text using a TrueType font gives you the closest on-screen representation of
the printed output.

PostScript Font Files
Each PostScript font is composed of two files: a bitmap (screen) font and an outline (printer)
font. In the System 7 Finder, PostScript bitmap fonts are the Kind “font” and appear as a dog-
eared page with the letter “A” icon. Their filenames always include a point size (e.g., Times 10,
Geneva 14). In System 7.1 or later, you install bitmap fonts in font suitcases in the Fonts folder
in the System Folder. In System 7.0.x, you install bitmap fonts in the System suitcase in the
System Folder. Double-clicking on a PostScript bitmap font file opens a window that displays
sample text in an installed screen font size.

Adobe PostScript outline fonts in the Finder are the Kind “PostScript font” and appear as a letter
“A” in front of horizontal lines icon. Fonts from other vendors may have different icons. Most
PostScript font file names are composed of the first five characters of the font’s name followed
by the first three characters of the font’s style (e.g., HelveBol, CouriObl, Symbo, TimesBolIta).
Outline font file names do not include a point size. In System 7.1 or later, you install outline
fonts in the Fonts folder in the System Folder. In System 7.0.x, you install outline fonts in the
Extensions folder in the System Folder.

TrueType Font Files
Unlike PostScript fonts, each TrueType font is a single font file used for both display and print-
ing. TrueType fonts icons appear in the Finder as a dog-eared page with three letter “A’s” in
progressively larger sizes, and their filenames do not include a point size. In System 7.1 or later,
you install TrueType fonts in the Fonts folder in the System Folder. Double-clicking on a
TrueType font file opens a window that displays sample text  in 9 point, 12 point, and 18 point
sizes.
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Removing Font Files

To remove a PostScript font in System 7.1 or later:
1. Quit all applications.
2. Open the font suitcase in the Fonts folder in the System Folder.
3. Remove font files that include a point size in their filename from the font suitcase.
4. Close the font suitcase.
5. Remove the font’s outline file or files from the Fonts folder.

To remove a TrueType font in System 7.1 or later:
1. Quit all applications.
2. Open the font suitcase in the Fonts folder in the System Folder.
3. Remove font files that do not include a point size in their filename from the font suitcase.
4. Close the font suitcase.

Removing Either PostScript or TrueType Version Font continued
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in System 7.1 and Later

What’s Covered
Disabling Extensions Overview
Disabling Extensions
Isolating Extension Conflicts
Resolving Extension Conflicts

Extensions enable you to customize your Macintosh by extending or enhancing your system
software. In System 7.x, the term “extensions” refers to both system extension files (e.g.,
AppleShare, File Sharing Extension) and control panel files (e.g., Macintosh Easy Open, Moni-
tors). When you start your Macintosh, the system software loads extensions in alphabetical
order. The system searches first for system extension files in the Extensions folder, then control
panel files in the Control Panels folder, and finally both system extension and control panel files
in the System Folder. After your system loads extensions, they’re enabled, unless you have
disabled them by selecting this option in their control panel windows.

When an extension is damaged or conflicts with one or more of your other installed extensions,
the application you are running, or your system software, one or more of the following symp-
toms occurs:

- system error (e.g., dialog box displaying an error message, freeze, endless processing)
- slow performance
- unexpected behavior
- unsuccessful software installation

When troubleshooting these symptoms, you can eliminate the greatest number of variables, and
the most likely cause, by disabling your extensions. For example, if you receive a system error
while working in an application, and you have customized your system software by adding four
control panel files and four system extension files, you have ten variables to troubleshoot. If your
symptoms reoccur after disabling your added extensions, you know that these eight variables are
not the cause. When your symptoms do not reoccur after disabling your added extensions, you
know that these extensions are the cause of your problem, and you can begin isolating the
damaged or conflicting extension, or combination of extensions.

Disabling Extensions Overview
When troubleshooting damaged or conflicting extensions, the method you choose to disable
added or suspect extensions will depend on your troubleshooting needs. For example, when
troubleshooting a system error that occurs only in a single application, you’ll need to disable all
added extensions except those required by the application (e.g., QuickTime).

To disable added extensions, you can:

- Restart your Macintosh with the Shift key held down.
You can disable extensions in System 7.0 and later by restarting while holding down the Shift
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key. Because this method of disabling extensions does not enable you to select which extensions
you want to disable, use this method for troubleshooting extension conflicts when you don’t
require a specific extension installed (e.g., CD-ROM driver, QuickTime). Keyboards manufac-
tured by a company other than Apple may use a different method for restarting with extensions
disabled.

- Use an extensions manager.
An extensions manager (e.g., Apple Extensions Manager, Casady & Greene Conflict Catcher,
Now Startup Manager) enables you to selectively disable extensions, but any extension you use
to disable other extensions is suspect itself. Most extensions managers support the same features
as Apple Extensions Manager, included with System 7.5 and later, and they may also support
additional features.

- Manually move extensions out of the System Folder.
Disabling extensions by manually moving them out of the System Folder enables you to selec-
tively choose which extensions you want to disable. This method of disabling extensions takes
time and requires you to be familiar with the contents of your System Folder, but does give you
complete control over the extensions you disable.

Disabling Extensions
To quickly determine if a damaged or conflicting extension is the cause of your problem, disable
added or nonessential extensions by restarting with the Shift key held down or by using an
extensions manager. Disabling extensions by restarting with the Shift key held down or by using
an extensions manager may not disable all added or nonessential extensions, so if your problem
reoccurs after using either method, you can make sure extensions are not the cause of your
problem by manually disabling them before troubleshooting other causes.

Restarting with the Shift Key Down
Restarting with the Shift key held down in System 7.0 and later disables added or nonessential
extensions, including some extensions installed with your system software (e.g., Apple CD-
ROM).

To disable extensions by restarting with the Shift key held down, restart your Macintosh by
choosing Special > Restart, then hold down the Shift key. Keep the Shift key held down until
your system displays the message “Welcome to Macintosh. Extensions off.” To re-enable your
extensions, restart without holding down the Shift key.

Using Extensions Manager
The Extensions Manager control panel, included with System 7.5 and later, enables you to select
which extensions, or set of extensions, you want to disable. To enable or disable extensions in the
Extensions Manager control panel, click to the left of the extension’s name to display or remove
the “x” or check mark, or enable a set of extensions using the Selected Set (System 7.6) or Sets
(System 7.5.x) pop-up menu. After you restart your Macintosh, Extensions Manager enables an
extension only when it has a check next to its name, and moves disabled extensions into the
Extensions (Disabled) or Control Panels (Disabled) folder it creates.

Isolating Extension Conflicts in System 7.1 and Later continued
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To disable extensions using the Extensions Manager control panel:
1. In the Extensions Manager control panel, select the extensions you want to disable:

In System 7.6, select Mac OS 7.6 Base from the Selected Set pop-up menu to disable all
extensions except the essentials included with your system software.

OR: In System 7.5.x, select System 7.5.x or System 7.5 Only from the Sets pop-up menu to
disable all extensions except those included with your system software.

OR: In System 7.5.x, select All Off from the Sets pop-up menu to disable all extensions that
Extensions Manager can disable.

OR: Selectively disable extensions by clicking to the left of an extension’s name to remove
the “x” or check mark.

2. Close the Extensions Manager control panel.
3. Restart your Macintosh.

Manually Disabling Extensions in System 7.1 and Later
When manually disabling your added or nonessential extensions, you can remove the Exten-
sions and Control Panels folders, including the extension files they contain, from the System
Folder to make sure these folders are not damaged and are not the cause of your problem. When
you remove the Extensions and Control Panel folders, you can also remove the Fonts and
Preferences folders, including the files they contain, to make sure these folders are not damaged
and the cause of your problem. You can also make sure the Fonts and Preferences folders are not
damaged later when you troubleshoot damaged application or system software.

To manually disable extensions:
1. Move the Control Panels and Extensions folders, and, if desired, the Fonts and Preferences

folders, from the System Folder to a new location (e.g., desktop).
2. Restart your Macintosh. The system searches for system preferences files and the Control

Panels, Extensions, Fonts, and Preferences folders in the System Folder. When your system
cannot find the folders or system preferences files it needs in the System Folder, it creates
new ones.

3. When your problem occurs when working in a single application, enable only those exten-
sions that application requires to launch or run (e.g., QuickTime) by moving them from
your previous Control Panels or Extensions folders into your new, empty Control Panels or
Extensions folders in the System Folder.

4. Restart your Macintosh.

Isolating Extension Conflicts
After disabling extensions, try to recreate your problem. If your problem reoccurs, your problem
is caused by other software or hardware causes. If your problem does not reoccur, it was caused
by a damaged or conflicting extension, and you’ll need to determine which extension is the
culprit by selectively re-enabling your extensions. You can re-enable them by using Extensions
Manager or by manually moving them back into your System Folder. If you disabled your
extensions by restarting with the Shift key held down, you’ll need to disable them manually or
by using an extension manager before isolating which extension is the cause of your problem.

Isolating Extension Conflicts in System 7.1 and Later continued
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To isolate which extension is the cause of your problem, re-enable them one or a few at a time,
then try to recreate your problem. For example, you can re-enable them beginning with those
included with your system software followed by your favorites, or you can add two at time in
alphabetical order. While re-enabling extensions, keep track of which extensions files you just added.
You can use label colors to keep track of which extension files you have added back. For example, you
can assign the color orange to all extensions files before you begin adding them back into your
System Folder, then change the label color of each extension file after you add it back.

When the problem reoccurs after adding an extension, leave it in the System Folder, then
remove all other extensions so that your system and application are running with only that
extension installed. If, after you restart, the problem reoccurs, you’ve found the culprit. If the
problem doesn’t reoccur, you’ll know it is caused by a combination of extensions, and not that
single extension. You can further determine which combination of extensions is the cause of
your problem.

When your problem does not occur after re-enabling all your extensions, and you have manually
disabled extensions by removing the Control Panels and Extensions folder, and perhaps the
Fonts and Preferences folders, your problem may have been caused by a damaged folder, or by a
damaged font or preferences file. If you’ve removed your Fonts and Preferences folders, you’ll
need to move back your font files from the previous Fonts folder into the newly created Fonts
folder, and your preferences files from the previous Preferences folder into the newly created
Preferences folder, one or a few at a time, trying to recreate the problem after each move. Only
move font files or preference files that do not already exist in the newly created Fonts or Prefer-
ences folder. If your problem occurs after you move a font or preferences file back, the cause of
your problem is most likely a damaged file, so you’ll need to reinstall the file. To reinstall a
damaged preference file, either launch the application that uses the file to force it to recreate its
preferences file, or reinstall the application that uses the preferences file.

Resolving Extension Conflicts
You have several choices to resolve problems caused by a damaged or conflicting extension.
Which solution you choose depends on your needs and which extension is causing the problem.

To resolve extension conflicts, do one or more of the following:

A. Modify the extension.
A setting in a control panel may be causing a conflict. Try changing current settings to see if
they’re the cause of your problem.

B. Replace the extension.
Rule out a damaged extension by deleting the extension, then reinstalling a new copy from the
original installation disks. When deleting the extension, make sure you also delete its support
files (e.g., preferences file).

C. Reinstall files used by the extension.
The conflict may not be caused by the extension, but by a damaged file it uses. For example, font
management extensions (e.g., Suitcase, MasterJuggler) read font suitcases. The cause of your
problem may be a damaged font suitcase, or a font file contained in the suitcase. In this example,
you can prevent the font management extension from reading all font suitcases to determine if

Isolating Extension Conflicts in System 7.1 and Later continued
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this prevents your problem from reoccurring. If it does, you’ll need to isolate which font suit-
case, or font file in a suitcase, is the cause, then reinstall that file.

D. Change the loading order of your extensions.
The order in which your extensions load may be the cause of your conflict. When you start up
your Mac, the system loads, in alphabetical order, first your system extension files located in the
Extensions folder, then control panel files located in the Control panel folder, and finally both
system extension and control panel files located in the System Folder. To change the order in
which your system loads an extension, change its name (e.g., add a character at the beginning of
an extension’s filename). Extensions files whose names begin with a non-Roman character (e.g.,
dash, tilde, pound sign) load either first or last, depending on the character.

E. Update the conflicting extension.
Check with the extension’s developer to see if there is an updated version available, or if they
have other information that may help you resolve your problem.

F. Run without the conflicting extension.
Until an update is available, you may have to run without an extension when it doesn’t support,
or conflicts with, newer software you’re running.

Isolating Extension Conflicts in System 7.1 and Later continued
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Without Disabling an Apple
CD-ROM

When you turn off extensions on your Macintosh by pressing the Shift key while restarting, all
added extensions and many system extensions are disabled, included those needed by your
Apple CD-ROM drive. Without these extensions, the drive cannot load or read CD-ROM discs.
To turn off extensions without disabling those needed by your Apple CD-ROM drive, use an
extensions manager, or manually remove extensions and control panels from the System Folder.

The Apple CD-ROM drive uses the Apple CD-ROM, Apple Photo Access, Audio CD Access,
Foreign File Access, High Sierra File Access, and ISO 9660 File Access extensions. Your System
Folder may not contain all of these extensions, but it should contain the Apple CD-ROM and
Foreign File Access extensions.

To disable added extensions except for the Apple CD-ROM extensions using Extensions Man-
ager in System 7.6.x:
1. Open the Extensions Manager control panel.
2. Save your existing extension set by choosing File > New Set and naming the set.
3. Create a new set by choosing File > New Set and naming it “All Off.”
4. Choose Edit > All Off. Each box in the On/Off column should be empty (i.e., do not contain

a plus or minus sign).
5. Select only the CD-ROM extensions (e.g., Apple CD-ROM, Foreign File Access) in the scroll

box.
6. Close the Extensions Manager control panel and then restart the Macintosh.
7. To enable your original extension set, select the set you saved in step 2 from the Selected Set

pop-up menu and then restart the Macintosh.

To disable added extensions except for the Apple CD-ROM extensions using Extensions Man-
ager in System 7.5.x:
1. Open the Extensions Manager control panel.
2. Save your existing extension set by selecting Save Set from the Sets pop-up menu and

naming the set.
3. Select the All Off option from the Sets pop-up menu.
4. Select only the CD-ROM extensions (e.g., Apple CD-ROM, Foreign File Access) in the scroll

box.
5. Close the Extensions Manager control panel and then restart the Macintosh.
6. To enable your original extension set, select the set you saved in step 2 from the Sets pop-up

menu and then restart the Macintosh.

To manually disable all extensions except the Apple CD-ROM extensions:
1. Create a new folder on the desktop and name it “Disabled Extensions.”
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2. Move all extensions except for the CD-ROM extensions (e.g., Apple CD-ROM, Foreign File
Access) from the Extensions folder in the System Folder to the Disabled Extensions folder
on the desktop.

3. Create a new folder on the desktop and name it “Disabled Control Panels.”
4. Move all control panels from the Control Panels folder in the System Folder to the Disabled

Control Panels folder on the desktop.
5. Restart the Macintosh.

The Apple CD-ROM extensions perform these functions:
- The Apple CD-ROM extension reads Macintosh CD-ROM discs.
- The Foreign File Access extension reads non-Macintosh CD-ROM discs.
- The Audio CD Access extension plays Audio CD-ROM discs.
- The Apple Photo Access extension reads Kodak PhotoCDs.
- The High Sierra File Access extension reads High Sierra-formatted CD-ROM discs.

Turning Off Extensions Without Disabling an Apple CD-ROM continued
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Errors on the Macintosh

What’s Covered
A Quick Overview of Your Macintosh Software
Defining the Problem
Check These Common Causes First
Rule Out Damaged or Conflicting Extensions
Rule Out Damaged Application Software
Reinstall System Software
Hardware, the Last Resort
Minimizing System Errors
Emergency Tactics

Bombs and crashes are going to happen on the Macintosh. No software is error-free—neither
the system software itself, nor your favorite application, utility, or font. While hardware prob-
lems can cause system errors, with the Macintosh they’re the exception rather than the rule. The
most likely cause of a system error is damaged or incompatible software.

Solving the problems that plague your computer doesn’t require a degree in computer science.
All you really need is time and patience. First make sure the symptoms of your problem are
really indicative of a system error. Then eliminate the most common causes. If the error persists,
continue the process of elimination, first by ruling out damaged or conflicting extensions, then
damaged application software, and finally damaged system software.

A Quick Overview of Your Macintosh Software
You should be familiar with the three basic types of software that run on your Macintosh. The
first is system software (e.g., System 7.5). System software is the most important software on
your Macintosh—it’s what makes your Macintosh a Macintosh. Your CPU, disk drive, monitor,
and the software you install all depend on the system software to perform their basic functions.

The second type of software is application software. You spend most of your day laying out
pages, word-processing, illustrating, or number crunching in applications like Adobe
PageMaker, Microsoft Word, Adobe Illustrator, and Microsoft Excel.

And finally there are extensions. The term “extensions,” introduced with System 7, describes file
that extend or enhance your system software. Extensions include control panel documents (e.g.,
Adobe Type Manager) and system extension documents that start, or initialize, when you
startup your Macintosh (e.g., Adobe Type Reunion).

Defining the Problem
The system software, application software, and extensions running on your Macintosh must all
get along with each other at any given time. When they don’t, your Macintosh lets you know by
returning a system error.
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You can recognize a system error by:

- The error message or error code number it displays.
System errors fall into two categories: bombs and alerts. System bombs are the most serious.
These include a bomb icon in their dialog box and signal a low-level, or basic operating routine,
problem. The message (e.g., “Sorry, a system error occurred,” “Application ‘unknown’ has
unexpectedly quit.”) and identifying error code number (e.g., “Type 1,” “-36”) in system bomb
dialog boxes vary depending on the system error that occurred and the version of your system
software. System alerts, which include the exclamation point in a triangle icon, can be equally
disabling, but they are not as serious: your system just wants to make you aware of something.
The content of the alert message generally points you to the source of the problem. Typical
problems range from a full disk to an AppleTalk error.

- The symptom of your problem.
If your Macintosh freezes or displays an incomplete or flickering dialog box, or if your system is
endlessly processing, chances are a system error occurred. Your Macintosh is unable to properly
display a system error dialog box when the cause of the system error prevents it from doing so.

When a system error occurs, write down the exact message or symptom and note the circum-
stances of the error. When does the error occur? Only in this file or in others, too? If the error
occurs only in one file, then the file is most likely causing the problem. Does it occur only in this
application or others? If the error occurs in more than one application, including the desktop
(i.e., the Finder application), you can bet it’s a system error, and not an application error. If
system errors occur randomly, this is also important. But you will want to verify that they do
occur randomly, so taking good notes is especially helpful.

Check These Common Causes First
If you’ve determined that the problem you’re experiencing is indeed a system error, begin
troubleshooting the cause of your system error by checking your setup against these common
causes.

What’s New?
Determine if anything new has been added to your Macintosh prior to the system error. For
example, if you’ve added a new control panel document to your system, move it out of the
System Folder, then restart your Macintosh. Repeat the actions that triggered the system error. If
everything works, you’ve found the cause of the error.

What’s Changed?
Perhaps during spring cleaning you accidentally moved or deleted an important file or two. Is
everything where it belongs?

Are There Any Duplicate Files?
Duplicate files, programs, and application resources are easily created when you update software
or install a new system. The updated application may not be able to use the older version’s file of
the same name. Did you follow the installation instructions for the software update? If not, the
system, your application, or an extension may be reading the wrong file by mistake.

Troubleshooting System Errors on the Macintosh continued
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Is Your Older Application Compatible With Your Newer System Software?
New variables enter the picture when a new version of system software or new hardware is
introduced. System 7 and Power Macintosh models introduce many new features. You can bet
the extensions your system software installs are compatible with these new features, but is
everything else? Older applications or extensions may not be.

How’s Your Memory?
Low memory errors, or system errors caused by insufficient memory, can be harder to resolve
than other kinds of errors because they seem more random. They can be caused by a variety of
things—too many windows open at the same time, extensions and fonts taking up memory your
system or applications need for other tasks, or damaged software.

If your application doesn’t have enough memory, increasing the amount of memory allocated to
your application should solve the problem. How much memory you allocate depends on the
amount of memory you have available and the number of other applications you want to open
at the same time. Start by increasing memory allocation by 50 percent or so and see what
happens.

To change an application’s allocated memory:
1. Quit the application.
2. Select the application’s icon in the Finder. Make sure you don’t select an alias of the applica-

tion or the folder containing the application.
3. Choose File > Get Info.
4. In the application’s Get Info dialog box, enter a higher value in the Preferred Size (System

7.1 and later) or the Current Size (System 7.0.x) text box.

Rule Out Damaged or Conflicting Extensions
When you install Macintosh system software, you also install the extensions included with it
(e.g., General, Keyboards, Monitors, Mouse, Sound). The installer puts control panel documents
in the Control Panels folder in the System Folder, and system extension documents in the
Extensions folder in the System Folder. You can also customize your Macintosh with extensions
created by other companies (e.g., Adobe Type Manager, Now Utilities). If these added extensions
conflict with other software or with each other, or if they’re damaged, system errors are likely to
occur. You can rule out the greatest number of variables—and the most likely cause of a system
error—by isolating added or nonessential extensions first.

To determine if a damaged or conflicting extension is causing your system error, first disable all
your added or nonessential extensions, then try to recreate the error. If the system error doesn’t
reoccur, you can isolate which extensions are the cause and resolve the conflict. If the problem
persists, then you know these extensions are not the cause of your system error, and you have
two variables left to tackle: the active application and the system software itself. Keep your added
extensions out of the picture (turned off) until you find the cause of your system error so they
don’t interfere when you reinstall your application or system software.

Disabling Added Extensions
You can disable extensions several different ways in System 7: you can restart the Macintosh
while holding down the Shift key, use the Extensions Manager control panel included with

Troubleshooting System Errors on the Macintosh continued
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System 7.5 and later, or manually remove extensions from the System Folder. The method you
choose to disable added or suspect extensions will depend on your troubleshooting needs. For
example, when troubleshooting a system error that occurs only in a single application, you’ll
need to disable all added extensions except those required by the application (e.g., QuickTime).

To quickly determine if a damaged or conflicting extension is the cause of your problem, disable
added or nonessential extensions by restarting with the Shift key held down or by using an
extensions manager. Disabling extensions by restarting with the Shift key held down or by using
an extensions manager may not disable all added or nonessential extensions, so if your problem
reoccurs after using either method, you can make sure extensions are not the cause of your
problem by manually disabling them before troubleshooting other causes.

To disable extensions by holding the Shift key while restarting:
Hold down the Shift key and choose Special > Restart. Keep the Shift key held down until the
system displays the message “Welcome to Macintosh. Extensions off.” Non-Apple keyboards may
not support disabling extensions by restarting with the Shift key held down. Extensions may not
be disabled if an extension conflict is preventing the system from disabling extensions.

To use the Extensions Manager control panel:
1. Open the Extensions Manager control panel.
2. Either individually select the extensions you want to disable, or select the System 7.5 Only or

System 7.5.3 option from the Sets pop-up menu.
3. Restart your Macintosh.

To manually disable extensions and force the system to create a new Control Panels and Exten-
sions folder:
When manually disabling your added or nonessential extensions, you can remove the Exten-
sions and Control Panels folders, including the extension files they contain, from the System
Folder to make sure these folders are not damaged and are not the cause of your problem.

To manually disable extensions:
1. Move the Control Panels and Extensions folders, and, if desired, the Fonts and Preferences

folders, from the System Folder to a new location (e.g., desktop).
2. Restart your Macintosh. The system searches for system preferences files and the Control

Panels, Extensions, Fonts, and Preferences folders in the System Folder. When your system
cannot find the folders or system preferences files it needs in the System Folder, it creates
new ones.

3. When your problem occurs when working in a single application, enable only those exten-
sions that application requires to launch or run (e.g., QuickTime) by moving them from
your previous Control Panels or Extensions folders into your new, empty Control Panels or
Extensions folders in the System Folder.

4. Restart your Macintosh.

Isolating Conflicting Extensions
After disabling your added extensions, try to recreate the system error. If it doesn’t reoccur, it’s
time to isolate which extensions are causing the problem. If the error does reoccur, you can
move on to testing your application and system software.

Troubleshooting System Errors on the Macintosh continued
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To isolate which extensions are damaged or conflicting, re-enable one or several at a time,
starting with your favorites. You can re-enable them using Extension Manager or by manually
moving them back into your System Folder. If you disabled your extensions by restarting with
the Shift key held down, you’ll need to disable your extensions either manually or by using the
Extensions Manager control panel to isolate the offending extension. When moving files back
into the System Folder, you can drag their icon onto the System Folder icon in the Finder to let
System 7 automatically return them to their proper location in the System Folder.

After each move, restart the Macintosh and try to recreate the system error. If your system error
doesn’t reoccur, add another extension. Once the error occurs after adding an extension, leave it
in the System Folder then remove all other added extensions so that your system and application
are running with only that extension installed. If, after you restart, the system error reoccurs,
you’ve found the culprit. If the error does not reoccur, you’ll know your system error is caused
by a combination of extensions, and not that single extension.

Resolving Extension Conflicts
You have several choices to resolve problems caused by a damaged or conflicting extension, or
combination of extensions. Which solution you choose depends on your needs and which
extension is causing the problem.

To resolve extension conflicts, do one or more of the following:
A. Modify the extension.
A setting in a control panel may be causing a conflict. Try changing current settings to see if
they’re the cause of your problem.

B. Replace the extension.
Rule out a damaged extension by deleting the extension, then reinstalling a new copy from the
original installation disks. When deleting the extension, make sure you also delete its support
files (e.g., preferences file).

C. Reinstall files used by the extension.
The conflict may not be caused by the extension, but by a damaged file it uses. For example, font
management extensions (e.g., Suitcase, MasterJuggler) read font suitcases. The cause of your
problem may be a damaged font suitcase, or a font file contained in the suitcase. In this example,
you can prevent the font management extension from reading all font suitcases to determine if
this prevents your problem from reoccurring. If it does, you’ll need to isolate which font suit-
case, or font file in a suitcase, is the cause, then reinstall that file.

D. Change the loading order of your extensions.
The order in which your extensions load may be the cause of your conflict. When you start up
your Macintosh, the system loads, in alphabetical order, first your system extension files located
in the Extensions folder, then control panel files located in the Control panel folder, and finally
both system extension and control panel files located in the System Folder. To change the order
in which your system loads an extension, change its name (e.g., add a character at the beginning
of an extension’s filename). Extensions files whose names begin with a non-Roman character
(e.g., dash, tilde, pound sign) load either first or last, depending on the character.

Troubleshooting System Errors on the Macintosh continued
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E. Update the conflicting extension.
Check with the extension’s developer to see if there is an updated version available, or if they
have other information that may help you resolve your problem.

F. Run without the conflicting extension.
Until an update is available, you may have to run without an extension when it doesn’t support,
or conflicts with, newer software you’re running.

Rule Out Damaged Application Software
If your system error occurs in a single application, the next step is to make sure the application
itself is not damaged by reinstalling it. To guarantee a successful installation and brand new
application software, remove your application and its support files, then reinstall it while
keeping your added extensions disabled.

First check inside the application’s folder and move personal documents you want to save to
another location. Next, throw away the application’s folder and its contents, which should
include only the application and its support files. Also throw away any of its support files located
in the System Folder. Then, with all your added extensions disabled, reinstall your application.
Use your application’s original installation disks to reinstall, when possible, to ensure backup
disks aren’t the problem.

After you reinstall your application, you can assume your application is not damaged and is now
above suspicion. So if, after you launch the reinstalled application, you can still recreate the
system error, move on to the last software variable, the system software itself.

Reinstall System Software
Reinstalling system software is the only surefire way to know if damaged system software is
causing your system error. If your system error does not reoccur after you reinstall the system
software, you know damaged system software was the culprit.

As when reinstalling an application, you want to ensure you do a clean install or install 100%
new system software. System 7.5.x’s installer includes the Clean Install option, which makes
installing new system software easy. When you reinstall System 7.1.x and 7.0.x you’ll need to do
a clean install manually.

After reinstalling your new system software, but before moving back customizing files (e.g.,
application support files, added extensions) into the System Folder, try to recreate your system
error. When your system error occurs in a single application, you’ll need to move the files that
application needs in the System Folder back into the System Folder before trying to recreate the
system error. If the system error does not reoccur at this point, you know your newly-installed
system software, and any application support files you moved back into the System Folder to test
for the error, are not the cause. Continue troubleshooting by moving the rest of you customizing
files back into your System Folder, then trying to recreate the error. If your system reoccurs at
this point, you’ll need to isolate which of these files is damaged or incompatible and causing
your system error.

Reinstalling System 7
You’ll need your Macintosh system CD-ROM or installation disks to reinstall your system

Troubleshooting System Errors on the Macintosh continued
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software. While the process of reinstalling your system software consists of simple steps, pay atten-
tion when moving your files around, both before and after you reinstall your system software.

To reinstall System 7.5.x:
1. Disable your current system by moving the Finder file from your System Folder to another

location (e.g., desktop), then restart your Macintosh. A disk icon with a blinking question
mark should appear in the middle of your screen, indicating your Macintosh cannot find
system software (an active system), which is expected.

NOTE: If your Macintosh starts up as normally after you’ve disabled your system, you may
have another system installed. Search for and remove any duplicate System or Finder files,
then move the remaining System or Finder file to the desktop and restart again.

2. Insert your system CD-ROM or installation disk containing the system’s Installer.
3. Open the Installer by double-clicking it.
4. In the Installer’s welcome screen, click Continue.
5. In the System 7.5 Installer window, select the Easy installation option, or select the Custom

installation option and the items you want to install, then press Command + Shift + K.
6. In the Select Type of Installation dialog box, select Install New System Folder, then click OK.
7. In the System 7.5 Installer window, the Install button is now the Clean Install button. Click

Clean Install, then continue with the installation by following the on-screen instructions.
8. When you’re done installing new system software, you’ll find the contents of your original

System Folder in the new folder named Previous System Folder.

To reinstall System 7.1.x or 7.0.x:
1. Disable your current system by moving the Finder file from your System Folder to another

location (e.g., desktop).
2. Rename your System Folder (e.g., “Old Folder”) to keep the installer from finding it.
3. Restart your Macintosh by choosing Special > Restart. While restarting, your Macintosh

ejects the startup disk then displays a disk icon with a blinking question in the middle of
your screen, indicating it cannot find system software (an active system), which is expected.

NOTE: If your Macintosh starts up normally after you’ve disabled your system, you may
have another system installed. Search for and remove any duplicate System or Finder files,
then move the remaining System or Finder file to the desktop and restart again.

4. Insert your system CD-ROM or installation disk containing the system’s Installer.
5. Follow the on-screen instructions to reinstall your system software.
6. When reinstallation is complete, restart your Macintosh. Your Macintosh ejects the system

installation disk while restarting. After restarting, a new System Folder containing new
system files, and your renamed System Folder with its contents intact, are installed on your
Macintosh.

Moving Application Files to Your New System Folder
After reinstalling your system software, test whether reinstalling the system software solved your
problem. When your system error only occurs when you run a single application, move only

Troubleshooting System Errors on the Macintosh continued
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that application’s support files from your original System Folder (e.g., Previous System Folder)
to your new System Folder before you try recreating your system error.

If your system error does not reoccur at this point, your newly-installed system software, and
perhaps an application’s support files, is above suspicion. Continue troubleshooting by moving your
remaining customizing files (e.g., fonts, control panels, system extensions, application support files)
from your original System Folder (e.g., Previous System Folder, Old Folder) to your new System
Folder, trying to recreate your system error after you move each set of files. If your system error
reoccurs at this point, you’ll need to isolate the damaged or incompatible file causing the problem.

When moving your customizing files from your original System Folder to your new System
Folder, open and compare the files, and the contents of folders in your old and new System
Folders. Move only those items that were not installed by the system software, and for which
there is no duplicate in the new System Folder. This ensures you don’t replace your newly installed
system files with your old system files, which may be damaged. If you’re using System 7.1 or later,
copy into the new System suitcase file only those sounds that aren’t already there. If you’re using
System 7.0.x, copy only those bitmap (screen) fonts and sounds that aren’t already there.

If, when you move items into your new System Folder, you get a message telling you an item
with that name already exists and asking whether you want to replace it with the item you’re
moving, click Cancel. Then go back and review the names of the files or contents of the folder
you are moving to see if they duplicate items already in your new System Folder.

After moving the files you need into your new System Folder, delete your original System Folder
containing duplicate or unwanted items by dragging it to the Trash, then emptying the Trash.

Hardware, the Last Resort
If you’ve made it this far, you’ve got a healthy system on your Macintosh, and neither your
application nor your extensions are conflicting with each other or with the system, so there’s not
much software troubleshooting left that you can do on your own. To leave no stone unturned
before calling Technical Support for your hardware or software problem, try these last tests.

You can check your hard disk’s formatting, defragment and optimize the files on your hard disk,
and check for damaged sectors on your hard disk using a Macintosh disk utility. To check your
startup volume (i.e., the hard disk containing your system software), restart your Macintosh
from a disk containing system software, then open the Macintosh disk utility.

Run Disk First Aid, a disk checking utility provided by Apple on the system CD-ROM or Disk
Tools disk, which can tell you if it encounters any minor formatting problems on your disk. To
run Disk First Aid, open the utility and click Verify. When using a hard disk manufactured by a
company other than Apple, you may need to use a utility supplied by your disk manufacturer to
check formatting problems. You can test your disk for damage and update your driver using
Drive Setup or HD SCSI Setup, which are also included with your system software.

You can use other Macintosh disk utilities, such as MacTools or Norton Utilities for the
Macintosh, to defragment and optimize your hard disk, check for damaged sectors, and check
for other formatting problems that the Macintosh disk utilities included with your system
software don’t check for. Other Macintosh disk utilities can find damaged sectors on your disk,
and prevent other files from being written to the damaged sectors they find.

Troubleshooting System Errors on the Macintosh continued
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If you suspect you have a SCSI device connection problem, turn off your Macintosh and all
connected SCSI devices, disconnect all your SCSI devices, then restart your Macintosh and try to
recreate your system error. If your system error doesn’t reoccur, your connected SCSI devices are
the cause. You can try connecting each device individually and reconnecting your SCSI chain by
trying to recreate the error after you connect each new device, to isolate the problem. Remember
to turn off both your Macintosh and SCSI devices before connecting or reconnecting them. For
instructions on connecting SCSI devices to your Macintosh, see the User Guide included with
your Macintosh and your SCSI device.

If your system error occurs after you’ve ruled out software causes and the hardware causes that
you can, it’s time to call for expert help. Tell the support technician about the systematic trouble-
shooting you’ve completed. The work you’ve done will enable them to concentrate on other
ways to resolve your system errors.

Minimizing System Errors
You can’t prevent all system errors, but you can be ready for them. Here are some maintenance
chores and emergency tools that can help you minimize system errors on your Macintosh.

- Always create backup copies of your system software, applications, extensions, and fonts,
just as you do with your personal files.

- Always have a complete set of your system installation disks nearby, including a disk you can
use as a startup disk (i.e., a disk containing system software).

- Defragment and optimize your hard disk using software designed for this, such as MacTools
or Norton Utilities for the Macintosh.

- Rebuild your desktop file often.
- Run virus detection software regularly.
- Make sure you know what’s installed on your computer and what’s in your System Folder.

Learn what each item is for—not all the new options and files of the system software are
essential. A little more hard disk space may be handy, and your Macintosh will be faster.

- Read about how the Macintosh thinks and works. Read the user manuals included with your
Macintosh and system software. There are also many good books available that explain the
inside workings of the Macintosh. Manuals and books can help you understand why differ-
ent kinds of errors occur. The wise Macintosh troubleshooter takes advantage of all re-
sources.

Emergency Tactics
The guidelines above are designed to help get to the cause of a system error. But the same logic
can also help you to work around a system error until you have time to systematically trouble-
shoot it properly.

For example, if you desperately need to print your publication, but a system error prevents the
print job whose deadline was two hours ago, try printing without extensions. If you can now print,
print away—but first make sure your fonts are installed in the System Folder. You can go back later to
find the extension or combination of extensions that are the culprit. Use these tactics to get past the
message, but remember, you will eventually have to go back and find the cause.

Troubleshooting System Errors on the Macintosh continued
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7.1.x, or 7.0.x Software

Reinstalling system software is the only sure-fire way to know if damaged system software is
causing a system error. If your system error does not reoccur after you reinstall the system
software, you know damaged system software was the cause. The System 7.5.x installer includes
a Clean Install option, which makes installing 100% new system software easy. When you
reinstall System 7.1.x and 7.0.x, you’ll need to do a clean install manually.

You’ll need your Macintosh system CD-ROM or software disks to reinstall your system software.
While the process of reinstalling your system software consists of simple steps, pay attention
when moving your files around, both before and after you reinstall your system software.

DISCLAIMER: This procedure is not supported by Adobe Systems Incorporated and is only
provided as a guideline. For instructions or support, refer to your Apple System 7 User Guide or
contact Apple technical support.

To reinstall System 7.5.x:
1. Insert your system CD-ROM or software disk containing the system’s Installer.
2. Open the System 7.5 Installer by double-clicking it.
3. In the Installer’s welcome screen, click Continue.
4. In the System 7.5 Installer window, select Easy Install, or select Custom Install and the items

you want to install, then press Command + Shift + K to display the Select Type of Installa-
tion dialog box.

5. In the Select Type of Installation dialog box, select the Install New System Folder option,
then click OK. The System 7.5 Installer window now displays the Install button as the Clean
Install button.

6. Click Clean Install, then continue with the installation by following the on-screen instruc-
tions. When you’re done installing new system software, you’ll find the contents of your
original System Folder in a new folder named “Previous System Folder.”

To reinstall System 7.1.x or 7.0.x:
1. Disable your current system by moving the Finder file from your System Folder to another

location (e.g., desktop).
2. Rename the System Folder (e.g., name it “Old Folder”) to keep the system software installer

from finding it.
3. Restart your Macintosh by choosing Special > Restart. While restarting, your Macintosh

ejects any inserted disk and then displays a disk icon with a blinking question mark in the
middle of your screen, indicating it cannot find system software (an active system), which is
expected.

NOTE: If your Macintosh starts up normally after you’ve disabled your system, you may
have another system (i.e., System file and Finder file in the same folder) installed . Search for
and remove duplicate System or Finder files, then restart your Macintosh again.
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4. Insert your system CD-ROM or software disk containing the system’s Installer and start the
Installer.

5. Follow the on-screen instructions to reinstall your system software.
6. When reinstallation is complete, restart your Macintosh. If you installed from a software

disk, your Macintosh ejects the disk while restarting. After you restart your Macintosh, both
a new System Folder containing new system files and your renamed System Folder with its
contents intact are installed on your Macintosh.

Moving Application Files to Your New System Folder
When you install system software, the installer automatically creates many files (e.g., system
preferences, system extensions). Many of the files it creates are duplicates of the ones you have in
your old System Folder, so you only need to move other files that customize your system (e.g.,
application preferences, non-Apple extensions) from your previous System Folder to your new
System Folder. When you move your customizing files from your original System Folder to your new
System Folder, open each folder in the original System Folder and compare its contents with those of
the same folder in the new System Folder. Move only those items that were not installed by the
system software, and for which there is no duplicate in the new System Folder, from the old System
Folder to the new System Folder. Moving only your customizing files ensures you don’t replace your
newly installed system files with your old system files, which may be damaged.

If you’re copying sound files in System 7.1 or later, copy only those files that are not already
installed into the new system suitcase. If you’re copying sound or bitmap (screen) font files in
System 7.0.x, copy only those files that are not already installed into the new system suitcase.

If, when you move items into your new System Folder or system suitcase, you get a message
telling you an item with that name already exists and asking whether you want to replace it with
the item you’re moving, click Cancel. Then, go back and review the names of the files or con-
tents of the folder you are moving to see if there are duplicate items already installed in your
new System Folder.

After you reinstall your system software to solve a system error problem, you can test whether
reinstalling the system software solved your problem. If your system error occurs only when you
run a single application, move only that application’s support files (e.g. preferences files) from
your original System Folder (e.g., Previous System Folder) to your new System Folder and then
try to recreate the system error.

If your system error does not reoccur at this point, your newly-installed system software, and
perhaps an application’s support files, are not the cause of your error. Continue troubleshooting
by moving your remaining customizing files (e.g., fonts, control panels, extensions, application
support files) from your old System Folder (e.g., Previous System Folder) to your new System
Folder, trying to recreate your system error after you move each set of files. If your system error
reoccurs at this point, you’ll need to isolate the damaged or incompatible file causing the
problem. For instructions on isolating extensions conflicts in System 7.1x or later, see document
200409.

After you move the files you need into your new System Folder, you may want to keep your old
System Folder around for a couple of days just in case a file your system or application needs
wasn’t copied into the new System Folder. After you’re sure your system has all the files it needs,
delete your old System Folder.

Reinstalling System 7.5.x, 7.1.x, or 7.0.x Software continued
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Problems in System 7.1 and
Later Troubleshooting Guide

What’s Covered
Printing Overview
Fonts Print Jagged or Substituted to PostScript Printer
PostScript Fonts Print Jagged to QuickDraw Printer
Characters Print Clipped to QuickDraw Printer

PostScript fonts may not print as expected for a variety of reasons, including:
- A non-Adobe PostScript font interpreter is unable to print the font.
- A font’s outline font file is damaged or unavailable (e.g., not installed, not in the expected

location).
- The printer driver is damaged.
- When printing to a QuickDraw printer, Adobe Type Manager (ATM) may be damaged or

unable to locate one of its support files.

To determine what’s preventing your PostScript fonts from printing, use the troubleshooting
steps below.

Printing Overview
Applications for the Macintosh can use either the PostScript or QuickDraw language to print.
PostScript is a page description language that describes the characteristics of objects, including
text and pictures, on a page. QuickDraw is the language the Macintosh uses to draw text and
graphics on screen.

PostScript Printers and Interpreters
When you print to a PostScript printer, the printer driver reads the PostScript code generated by
the printing application, or it converts on screen QuickDraw information into PostScript code,
then sends the PostScript code to the printer. The printer then converts, or rasterizes, the
PostScript code into a bitmap to print the page.

PostScript-compatible interpreters, or clones, interpret PostScript code using a modified version
of the PostScript language instead of using the Adobe PostScript language. Because these
printers support interpreting PostScript code, but do not use an Adobe PostScript interpreter,
they may generate unexpected printing results (e.g., font substitution, PostScript errors).
Manufacturers of PostScript-compatible interpreters include Everex, Imagen, GCC, Harlequin,
LaserMaster, Lexmark, Newgen, Pacific Page, QMS, and Xante. If you have problems printing
PostScript fonts to a PostScript-compatible interpreter, print to a printer that uses an Adobe
Postscript interpreter to determine if the PostScript fonts print to any PostScript printer before
contacting your printer’s manufacturer for possible solutions.
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QuickDraw Printers
When you print to a QuickDraw printer, its printer driver sends on-screen QuickDraw informa-
tion directly to the printer. QuickDraw printers are designed to print text and objects described
in the QuickDraw language (e.g., PICT graphics, bitmap fonts, applications designed to print to
QuickDraw printers) at the highest possible resolution. QuickDraw printer drivers, which
generate QuickDraw information for QuickDraw printers, may be unable to convert, or accu-
rately convert, the PostScript information contained in PostScript fonts, since many features
supported by the PostScript language are not supported by the QuickDraw language (e.g.,
fractional point sizes). To enable QuickDraw printers to print PostScript fonts smoothly, ATM
rasterizes PostScript outline fonts (i.e., converts outline font information into a scaleable bitmap
image) for smooth on-screen display, and the QuickDraw printer driver sends this rasterized
font information to the QuickDraw printer.

Fonts Print Jagged or Substituted to PostScript Printer
When a PostScript font prints jagged or as a substitute font (e.g., Courier) to a PostScript
printer, the printer driver is unable to locate the font’s outline file to download it to the printer.
When only some of your PostScript fonts print jagged or substituted, those fonts are most likely
damaged or their outline font files are unavailable (e.g., not installed, installed in an unexpected
location). When all your PostScript fonts print jagged or substituted, your printer driver is most
likely damaged or not installed correctly (e.g., installed in an unexpected location).

To prevent a PostScript font from printing jagged or substituted, remove and then reinstall the
PostScript font (i.e., bitmap and outline font files) or printer driver from its original installation
disks. When all your PostScript fonts do not print as expected, you can also print by using
another printer driver. When using a font management utility (e.g., Suitcase, MasterJuggler),
install the font into the Fonts folder in the System Folder to determine if the printer driver is
unable to find the outline font files when installed using the font management utility.

To reinstall a PostScript font:
1. Quit all applications.
2. Remove the PostScript font’s outline and bitmap font files from the Fonts folder in the

System Folder.
3. Reinstall the PostScript font’s outline and bitmap font files from the original installation

disks into the Fonts folder in the System Folder.

To reinstall the Apple LaserWriter 8.x or Adobe PSPrinter 8.x printer driver:
1. Quit all applications.
2. Remove the LaserWriter Chooser extension or the PSPrinter Chooser extension from the

Extensions folder in the System Folder.
3. Reinstall the LaserWriter or PSPrinter Chooser extension from the original installation disks

into the Extensions folder in the System Folder.

Fonts Print Jagged to QuickDraw Printer
When a PostScript font prints jagged to a QuickDraw printer, ATM is unable to locate the font’s
outline file to smooth font edges or ATM is damaged. When only some of your PostScript fonts
print jagged, the most likely cause is a missing or damaged outline font file. When all your
PostScript fonts print jagged, the ATM control panel is most likely damaged.

PostScript Font Printing Problems in System 7.1 and Later Troubleshooting Guide
continued
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To prevent PostScript fonts from printing jagged to a QuickDraw printer, remove the PostScript
font’s installed font files (i.e., bitmap and outline font files) and the ATM control panel, then
reinstall them from their original installation disks. When using a font management utility (e.g.,
Suitcase, MasterJuggler), install the font into the Fonts folder in the System Folder to
determine if the printer driver is unable to find the outline font files when installed using
the font management utility.

To reinstall ATM:
1. Quit all applications.
2. Remove the ~ATM control panel from the Control Panels folder in the System Folder.
3. Reinstall ATM from the original installation disks into the Control Panels folder in the

System Folder.
4. Restart the Macintosh.

Characters Print Clipped to QuickDraw Printer
When a font’s character strokes extend past the character’s bounding box (i.e., the height
allotted for the character at a certain point size), a font’s ascenders and descenders may print
clipped, or cut off, to a QuickDraw printer. Enabling ATM’s Preserve Character Shapes option or
increasing the leading applied to the text may enable the QuickDraw printer to print the font as
expected. Changing ATM’s Preserve Character Shapes option may cause word and letter spacing
to change, causing different line breaks.

To enable ATM’s Preserve Character Shapes option:
1. In the ATM control panel, select Preserve Character Shapes, then close the control panel.
2. Restart the Macintosh.

PostScript Font Printing Problems in System 7.1 and Later Troubleshooting Guide
continued
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Type On Call Deinstalling QuickDraw GX

General Information

To deinstall QuickDraw GX, remove QuickDraw GX system files, restore Type 1 fonts, and setup
a PostScript printer.

Removing QuickDraw GX System Files
To remove QuickDraw GX and restore standard Macintosh printing for all applications:

1. Start the Apple Installer on the QuickDraw GX Install disk by double-clicking on the Install
QuickDraw GX installer control file.

2. Choose Custom Remove from the pop-up menu in the installer dialog box.
3. Select the Base QuickDraw GX Software for this Macintosh, Base QuickDraw GX Software

for any Macintosh, QuickDraw GX Utilities, ATM for QuickDraw GX, All QuickDraw GX
Drivers for Apple Printers options for Custom Remove.

4. Set the Destination Disk to the disk containing the System software; use the Switch Disk
button to select another disk, if your System is on another attached hard disk.

5. Click the Remove button. When complete, restart the Macintosh.

Restoring PostScript Type 1 Fonts

To restore PostScript Type 1 fonts:
1. Move all enabled font suitcases, located in the Fonts folder in the System Folder by default,

to a different location. Enabled suitcases contain converted TrueType versions of the
PostScript Type 1 fonts in addition to the bitmap (screen) fonts.

2. Move fonts contained in the Archived Type 1 Fonts folder, located in the System Folder, into
the Fonts folder, and delete the empty Archived Type 1 Fonts folder.

3. Move other fonts enabled using the Type 1 Enabler application to another folder not
accessed by any font management utility (e.g., Suitcase). Move the original archived copy of
the Type 1 font back to the desired folder to make it available to the font management
utility.

4. Reinstall Adobe Type Manager versions other than ATM/GX 3.7.

Setting up a PostScript Printer

To set up a PostScript printer in the Chooser:
1. Choose the Chooser from the Apple menu, then click the LaserWriter 8.x driver icon.
2. Select a PostScript printer from the Select a PostScript Printer list and click Setup.
3. Set up the PostScript printer by clicking Setup, clicking Auto Setup in the Current Printer

Description File (PPD) Selected dialog box then clicking OK. An icon appears to the left of
the printer’s name in the Chooser indicating it is set up using the LaserWriter 8 printer
driver.

NOTE: When you click Auto Setup, the LaserWriter 8.x printer driver locates the PostScript
Printer Description (PPD) file for the printer. If the LaserWriter 8.x printer driver is unable
to locate a corresponding PPD file, click Select PPD and choose another appropriate PPD
file, or click Use Generic in the Select a PostScript Printer Description File dialog box.
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To disable the QuickDraw GX and PrinterShare GX system extensions, use the Extensions
Manager:
1. Choose Control Panels from the Apple menu and double-click the Extensions Manager

control panel.
2. Deselect the QuickDraw GX and PrinterShare GX system extensions and restart.

OR: Manually remove the QuickDraw GX and PrinterShare GX system.

Deinstalling QuickDraw GX General Information continued
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Type On Call Alert “Substitution fonts...”

After Installing ATM or
QuickDraw GX

Issue
During startup with QuickDraw GX 1.x and SuperATM or Adobe Acrobat Reader or Adobe
Acrobat Exchange installed, Adobe Type Manager (ATM) returns the message “The substitution
fonts necessary for Acrobat and SuperATM are missing. Please re-install either software pack-
age.” or “The installed substitution fonts are designed for use with standard QuickDraw. Please
remove them and install the QuickDraw GX versions.”

Solutions
Install SuperATM 3.8.x or 3.9 while QuickDraw GX is active (i.e., extensions are on).

OR: Install Acrobat Reader 2.0.1 or later or Acrobat Exchange 2.0.1 or later while QuickDraw
GX is active (i.e., extensions are on).

OR: Remove the ATM Font Database file located in the System Folder and the multiple master
substitution fonts located in the Fonts folder in the System Folder. Multiple master substitution
fonts include:
- AdobeSansMM
- AdobeSanXMM
- AdobeSerMM
- Adobe Sans MM
- Adobe Sans X MM
- Adobe Serif MM

Additional Information
When QuickDraw is inactive or is not installed, the SuperATM, Acrobat Reader, or Acrobat
Exchange installers automatically install the standard QuickDraw versions of the multiple
master substitution fonts (i.e., fonts not enabled for use in QuickDraw GX). When you reacti-
vate or install QuickDraw GX, ATM, which tries to locate the multiple master substitution fonts
when the ATM Font Database File in installed in the System Folder, is unable to use the standard
QuickDraw versions of the multiple master substitution fonts, so it returns an alert.

After you install SuperATM 3.8.x, Acrobat Reader, or Acrobat Exchange with QuickDraw GX
inactive, the alert “The substitution fonts necessary for Acrobat and SuperATM are missing.
Please re-install either software package.” appears during startup. When you install QuickDraw
GX 1.x after installing SuperATM 3.8.x, Acrobat Reader, or Acrobat Exchange, the alert “The
installed substitution fonts are designed for use with standard QuickDraw. Please remove them
and installed the QuickDraw GX versions.” appears during startup. Installing SuperATM,
Acrobat Reader, or Acrobat Exchange while QuickDraw GX is active enables the SuperATM or
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Type On Call Alert “Substitution fonts...” After Installing ATM or QuickDraw GX continued

Acrobat installer to install the QuickDraw GX-compatible versions of the multiple master
substitution fonts.

When you remove both the ATM Font Database file and the multiple master substitution fonts,
the Macintosh does not try to load the substitution fonts, bypassing the alert message. However,
because these files are required for SuperATM and Acrobat font substitution, you cannot run
SuperATM, Acrobat Reader, or Acrobat Exchange after removing them.
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application resources for Type
Reunion to unite the fonts”

Issue
While you work in an application, Adobe Type Reunion 2.0 Deluxe returns the alert, “There are
not enough application resources for Adobe Type Reunion to unite the fonts for [application].”

Solutions

Do one or more of the following:
A. When using QuarkXPress, disable Xtensions (e.g., Extensis QX Tools 2.0 FindChange

XTension).
B. Reduce the number of active fonts.

Additional Information
The Macintosh operating system allots 255 resources to each open application to generate pop-
up menus. Type Reunion uses these resources to unite font families. When the resources are
being used by other extensions (e.g., QuarkXPress Xtensions) or the application, Type Reunion
may not have enough resources to unite font families and returns the alert, “There are not
enough application resources for Adobe Type Reunion to unite the fonts.”

Type Reunion will also display the alert when many (e.g., 50) fonts are active and it has insuffi-
cient resources to unite all the font families. The number of font families Type Reunion can
unite will vary by application depending on the available resources in each application.

Type Reunion 1.x does not display an alert if it has insufficient resources, and simply fails to
unite font families. Unlike Type Reunion 1.x, Type Reunion 2.0 repeatedly displays an alert
when it has insufficient resources.
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Type On Call TrueType Fonts in Windows

General Information

What’s Covered
TrueType vs. PostScript
Display and Printing
Hinting
Win.ini File
System Performance
RAM Cache
The following is a brief overview of TrueType fonts and their features, including comparison
with PostScript fonts.

TrueType vs. PostScript
TrueType fonts are composed in the TrueImage page description language and are described
using quadratic splines. PostScript fonts are composed in the PostScript page description
language and are described using Bezier curves. Quadratic splines draw more quickly, but Bezier
curves print more defined curves.

A TrueType font is composed of a *.ttf file (the actual font file) and a *.fot file. The *.fot file
points to the location of the *.ttf file and contains the font’s hinting information. The font files
are usually stored in the Fonts directory in the Windows directory (Windows 95) or in the
Windows\System directory (Windows 3.1x).

A PostScript Type 1 font is composed of a *.pfm (screen) font file and a *.pfb (printer) font file.
PostScript Type 1 font files are installed in the Psfonts directory by default, but you can store
them in another location using a font manager (e.g., Adobe Type Manager, FontMinder).

To install a TrueType font in Windows 95:
1. Open the Fonts Control Panel.
2. Choose File > Install New Font.
3. In the Add Fonts dialog box, specify the drive and directory where the fonts you want to add

are located.
4. Select the fonts you want to install from the List of Fonts, then click OK.

To install a TrueType font in Windows 3.1x:
1. Open the Fonts Control Panel.
2. Click Add.
3. Specify the drive and directory where the fonts you want to add are located.
4. Select the fonts you want to install from the list of available fonts, then click OK.

Display and Printing
TrueType fonts are designed to display and print clearly at any point size. When you print
TrueType fonts to a PostScript printer, the printer driver usually converts them to PostScript-
compatible fonts (e.g., Type 1). When the driver converts the fonts from the TrueImage language
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to the PostScript language, some font information may be lost or altered slightly, including font
hinting and stroke widths. However, when you print to a TrueImage PostScript printer, which
uses native TrueType information, or to a printer containing a TrueType rasterizer (e.g., Apple
LaserWriter Pro 600 and 630, Apple Personal LaserWriter NTR), the driver does not convert the
fonts, enabling them to print with no alteration.

PCL printer drivers send TrueType font information directly to the printer. Some PCL printer
drivers (e.g., LaserJet II & III, LaserJet 4) enable you to send TrueType fonts to the printer as
bitmapped images instead. Consult your printer driver documentation for instructions.

When both the TrueType and PostScript version of the same font are installed, you may get
unexpected display and printing results (e.g., unexpected character spacing, unexpected line and
page breaks) because a PostScript font’s character spacing may not be identical to an equivalent
TrueType font’s character spacing. When you will be printing to a non-PostScript (e.g., PCL) or
TrueImage device, TrueType fonts provide the most accurate on-screen representation of the
printed output. When you will be printing to a PostScript device, composing and viewing a
document using the PostScript font and ATM will provide the most accurate on-screen repre-
sentation of the printed output.

Hinting
Hints are instructions built into outline fonts that enable character shapes, especially subtle
curves printed at small point sizes and low resolutions, to print as close to the designed charac-
ter shape as possible. TrueType fonts contain complex hinting information. TrueType fonts can
hint each character, different sizes of a character, and rotated text.

Win.ini File
When you add a font, the Fonts Control Panel adds a line to the [fonts] section of the Win.ini
file that references the TrueType font name and the corresponding *.fot file. For example:

[fonts]

Arial (TrueType)=ARIAL.FOT

Windows uses the *.fot file to locate the *.ttf file. Both the *.fot file and its corresponding *.ttf
file must be installed for each entry in the [fonts] section for Windows to display or print the
font as expected.

System Performance
Generally, the more fonts you install on your system, the longer it will take to start applications
and perform commands (e.g., Open, Print). Also, since each added font requires a reference in
the Win.ini file, a large number of fonts can cause the Win.ini file to grow too large. The Win.ini
file has a maximum allowable file size of 64K, but keeping it 32K or smaller enables your system
to run more efficiently and may prevent errors. When the size of the Win.ini file exceeds 32K,
Windows or applications running in Windows may behave unpredictably.

RAM Cache
Windows creates a RAM cache (i.e., memory reserved for screen font display) to store TrueType
font glyphs as they are used, which requires less memory than storing an entire font.

TrueType Fonts in Windows General Information continued
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Type On Call TrueType Fonts Installed by

Windows 95

During a typical installation, Windows 95 installs the following TrueType fonts into the
Windows\Fonts directory. Because Windows 95 or other applications may require one or more
of these fonts to run and to display dialog boxes as expected, Adobe recommends you do not
delete them or remove them from the Fonts directory.

Windows 95 also installs several hidden font files (e.g., Marlett.ttf, Dosapp.fon, Vgafix.fon, etc.),
which do not display in Windows Explorer or in the Fonts Control Panel, but may display in
font management utilities (e.g., Ares FontMinder). Windows requires these hidden font files to
run. Do not delete them or remove them from the Fonts directory.

Font (Filename)

Arial (Arial.ttf)

Arial Bold (Arialbd.ttf)

Arial Bold Italic (Arialbi.ttf)

Arial Italic (Ariali.ttf)

Courier 10,12,15 (Courf.fon)

Courier New (Cour.ttf)

Courier New Bold (Courbd.ttf)

Courier New Bold Italic (Courbi.ttf)

Courier New Italic (Couri.ttf)

Modern (Modern.fon)

MS Sans Serif 8,10,12,14,18,24 (Sseriff.fon)

MS Serif 8,10,12,14,18,24 (Seriff.fon)

Small Fonts (Smallf.fon)

Symbol (Symbol.ttf)

Symbol 8,10,12,14,18,24 (Symbolf.fon)

Times New Roman (Times.ttf)

Times New Roman Bold (Timesbd.ttf)

Times New Roman Bold Italic (Timesbi.ttf)

Times New Roman Italic (Timesi.ttf)

WingDings (Wingding.ttf)
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Type On Call Specifying the Windows

Standard VGA Driver in
Windows 95

To specify the Windows Standard VGA driver in Windows 95:
1. Right-click on the desktop, then select Properties from the pop-up menu.
2. In the Display Properties dialog box, click on the Settings tab, then click the Change Display

Type button.
3. Note the selected Adapter Type, then click Change.
4. In the Select Device dialog box, select the Show All Devices option.
5. Select the Standard Display Types option from the top of the Manufacturers scroll box.
6. Select the Standard Display Adapter (VGA) option from the Models scroll box, then click

OK.

NOTE:  Standard Display Adapter (VGA) video drivers display only 16 colors. Switch to
Super VGA for applications that require a minimum of 256 colors (e.g., Adobe Photoshop
3.0.x).

7. Note the selected Monitor Type, then click Change.
8. In the Select Device dialog box, select the Show All Devices option.
9. Select the Standard Monitor Types option from the top of the Manufacturers scroll box.
10. Select the Standard VGA 640x480 option from the Models scroll box, then click OK.
11. Restart Windows 95.
When the Windows 95 Standard Display Adapter (VGA) driver or the Super VGA driver is
damaged or is not installed, reinstall the driver from the Windows 95 CD-ROM.

To install the VGA driver:
Copy the VGA.DRV file (size 50.8K, date 7/11/95) from the DRIVERS\DISPLAY\VGA directory
on the Windows 95 CD-ROM to the WINDOWS\SYSTEM directory on your startup disk, then
restart Windows 95.

To install the Super VGA driver:
1. Insert the Windows 95 CD-ROM in the CD-ROM drive.
2. Restart the computer in MS-DOS mode.
3. At the DOS prompt, type the following text:

EXTRACT E:\WIN95\WIN95_04CAB FRAMEBUF.DRV/L C:\WINDOWS\SYSTEM

where “E:” is the CD-ROM drive indicator.

4. Restart the computer.
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Video Driver in Windows 3.1x

To specify the Windows Standard VGA driver in Windows 3.1x:
1. Make sure your Windows installation disks are available.
2 Create a backup copy of the System.ini file, which is located in the Windows directory.
3. Double-click the Windows Setup icon in the Main group of Program Manager.
4. In Windows Setup, choose Options > Change System Settings.
5. In the Change System Settings dialog box, select VGA from the Display pop-up menu, then

click OK.
6. Follow the on-screen instructions to install the VGA video driver, inserting Windows

installation disks if prompted.
7. Restart Windows.
You can restore the original video driver in DOS using the DOS version of Windows Setup, or
by replacing the existing System.ini file with a backup of the System.ini file (e.g., System.bak). In
Windows, you can restore the original video driver by restoring the backup copy of the
System.ini file in File Manager. When Windows displays the desktop incorrectly (e.g., distorted),
you can use key commands in Windows to change the video driver selected in Windows Setup.

To change video drivers from the DOS version of Windows Setup:
1. At the C:\ prompt, type “cd windows” to change to the Windows directory.
2. Type “setup” and press Enter.
3. In Windows Setup, press the up or down arrow keys to select the Display option and press

Enter.
4. Press the up or down arrow keys to select the desired video driver and press Enter.
5. Select Complete Changes and press Enter.
6. Follow the prompts to install the selected video driver, then start Windows.

To restore the backup copy of the System.ini file in DOS:

1. From the DOS prompt, type “cd windows” to change to the Windows directory.

2. Rename the existing System.ini file in the Windows directory by typing “ren System.ini
system.abc” (where System.abc is the new name of the System.ini file. Do not rename the
existing System.ini file with the same name as your backup copy of the System.ini file) and
pressing Enter.

3. Copy the backup System.ini file into the Windows directory and rename it System.ini by
typing “ren A:\System.bak C:\Windows\System.ini”

(where A:\ System.bak is the driver letter, path name, and filename of the backup copy) and
pressing Enter:

4. Restart Windows.

To replace the updated System.ini file with the backup System.ini file in Windows:
1. Double-click the File Manager icon in the Main group of Program Manager.
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2. Select the backup System.ini file (e.g., System.bak), then choose File > Copy.
3. In the Copy dialog box, type “C:\Windows\System.ini in the To text box, then click OK.
4. When the Confirm File Replace dialog box appears, click Yes to replace the System.ini file

with the backup System.ini file.
5. Exit File Manager and restart Windows.

To change the video driver selected in the Windows version of Windows Setup using keyboard
commands:
1. Start Windows, then press Alt + F to choose the File menu.
2. Press R to open the Run dialog box.
3. In the Run dialog box, type “setup” and press Enter.
4. In Windows Setup, press Alt + O to choose the Options menu, then press C to select Change

System Settings.
5. In the Change System Settings dialog box, type V to select VGA from the Display pop-up

menu, then press Enter.
6. Press the Spacebar to select the currently installed driver.
7. Press the spacebar to restart Windows.

Specifying the Standard VGA Video Driver in Windows 3.1x continued
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Type On Call Copying Windows Font Files

to a Network Server or Disk

You can transfer font files from one Windows workstation to another by first copying them to a
network server or a disk. After you have copied the files, you can install the font on another
workstation using Adobe Type Manager (ATM). Make sure you adhere to your font
manufacturer’s licensing agreement when copying font files to other locations.

To copy Windows font files, you first need to know the name of the PostScript font files. Font
filename prefixes often do not resemble the font’s actual name (e.g., Akzidenz Grotesk font files
begin with GF, Centaur font files begin with NR). PostScript font filenames have eight-character
prefixes. Font filenames consist of one to five characters, followed by underscore characters to
make a total of eight characters. For example, the complete filename prefix for the Helvetica font
file is “Hv______.”

PostScript font filename information for all Adobe fonts is listed in the document Fntnames.pdf,
available on the Type On Call CD-ROM. You can download the same document from Adobe’s
World Wide Web site at http://www.adobe.com (document number 5090). Additionally, if a font
is installed in ATM on the workstation from which you are copying, you can open ATM’s
Atm.ini file, located in the Windows directory, to view its filename.

Make sure to copy all a font’s components. A single master PostScript font is composed of a
PFM file and a PFB file (e.g., Com_____.pfm and Com_____.pfb). A multiple master base font
is composed of a PFM file, a PFB file, and an MMM file (e.g., Zjrg____.pfm, Zjrg____.pfb, and
Zjrg____.mmm). A multiple master instance is composed of a PFM file and a PSS file (e.g.,
Zjrg_iyc.pfm and Zjrg_iyc.pss).

To copy font files from a Windows 95 workstation to a network server or floppy disk:
1. Identify the names of your font files.
2. Choose Start > Programs > Windows Explorer.
3. In Windows Explorer, navigate to your fonts directory (e.g., C:\Psfonts). The fonts directory

usually contains a subdirectory that holds other font files (e.g., C:\Psfonts\Pfm).
4. To copy font files to a network server, select the desired font files from the fonts directory

and from any subdirectory inside the fonts subdirectory, then copy them to the desired
location on the network server. For example, copy the file Com_____.pfb from the Psfonts
directory and the file Com_____.pfm from the Psfonts\Pfm subdirectory.

OR: Select the desired font files from the fonts directory and from any subdirectory inside
the fonts subdirectory, then copy them onto a disk.

5. Choose File > Close to exit Explorer.

To copy font files from a Windows 3.1x workstation to a network server or floppy disk:
1. Identify the names of your font files.
2. Open File Manager.
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[Application] Copying Windows Font Files to a Network Server or Disk continued

3. In File Manager, navigate to your fonts directory (e.g., C:\Psfonts). The fonts directory
usually contains a subdirectory that holds other font files (e.g., C:\Psfonts\Pfm).

4. To copy font files to a network server, select the desired font files from the fonts directory
and from any subdirectory inside the fonts subdirectory, then copy them to the desired
location on the network server. For example, copy the file Com_____.pfb from the Psfonts
directory and the file Com_____.pfm from the Psfonts\Pfm subdirectory.

OR: Select the desired font files from the fonts directory and from any subdirectory inside
the fonts subdirectory, then copy them onto a disk.

5. Choose File > Exit to exit File Manager.
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Type On Call Error “Maximum of 999

orders” When Starting
Purchaser in Windows NT 4.0

Issue
When you start the Adobe Purchaser after installing Adobe Type On Call in Windows NT 4.0,
the Purchaser returns the error, “There is a maximum of 999 orders. Contact Adobe for assis-
tance.”

Solution
Create a file named “Pend.000” in the Toc4/Pend directory or one named “Prev.000” in the Toc4/
Prev directory:

1. Open the Pend or Prev subdirectory in the Toc4 directory.
2. Choose View > Options.
3. Click the View tab in the Options dialog box.
4. Deselect Hide File Extensions For Known File Types, then click OK.
5. Choose File > New > Text Document. The new file has a text document icon.
6. Name the file “Pend.000” or “Prev.000”.
7. Click Yes when the Rename dialog box appears with the alert, “If you change a filename

extension, the file may become unusable.” The file should now have a Windows document
icon (i.e., a dog-eared page with the Windows symbol). If the icon still appears as a text
document icon, rename the file and make sure the name does not include the “.txt” exten-
sion.

Additional Information
When you start the Purchaser, it looks for Pend.* and Prev.* (e.g., Pend.001, Prev.001) files in
the Pend and Prev subdirectories in the Toc4 directory to determine the number of the last
order. When the Purchaser cannot locate either of these files, it returns the error, “There is a
maximum of 999 orders.” When you add a Pend.000 file to the Pend directory or a Prev.000 file
to the Prev directory, the Purchaser starts without returning the error and creates a sequential
pending order (i.e., Pend.001 or Prev001). Creating a Pend.000 file or a Prev.000 file will not
affect future font orders (e.g., 30 free fonts included with Type On Call).
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Type On Call Type On Call CD-ROM Does

Not Mount General
Troubleshooting

Issue
The Adobe Type On Call CD-ROM does not mount (i.e., no Type On Call icon appears on the
desktop) when you insert it into the CD-ROM drive.

Solutions
Do one or more of the following:

A. Examine the Type On Call CD-ROM for dirt, dust, fingerprints or scratches. Wipe the
bottom of the CD-ROM gently, from the center outward, with a soft, lint-free cloth. Exam-
ine the CD-ROM caddy or loading tray for your CD-ROM drive. If it is dirty, wipe it with a
clean, lint-free cloth. If the CD-ROM is scratched, contact Adobe Customer Services for a
replacement disc.

B. Make sure your CD-ROM drive can read other CD-ROM discs (e.g., Adobe PageMaker 6.0).
If your CD-ROM drive won’t read any CD-ROM, refer to the documentation included with
the drive or contact the CD-ROM drive manufacturer.

C. Before inserting the Type On Call CD-ROM, restart the Macintosh without unnecessary
extensions:

Move all extensions not required to access your CD-ROM drive from the Extensions Folder
in the System Folder to a new folder on the Desktop.

OR: Use Extensions Manager to turn off all extensions except those your system requires to
access your CD-ROM drive (e.g., Apple CD-ROM).

D. Mount the Type On Call CD-ROM on another Macintosh.

Additional Information
Dirt, dust, fingerprints or scratches on the Adobe Type On Call CD-ROM may interfere with the
CD-ROM drive’s ability to read the disk. Cleaning the CD-ROM may allow it to mount.

Installed extensions or control panels other than the CD-ROM extensions may interfere with the
CD-ROM drive’s ability to read the disc. Run the CD-ROM drive with all extensions off except
the CD-ROM extensions to make sure that added extensions or control panels are not the cause.

When Type On Call will mount on one Macintosh but not another, the Type On Call CD-ROM
is working as expected. Use the CD-ROM on which the Macintosh Type On Call mounts, or
refer to the documentation or the manufacturer for the CD-ROM drive on the Macintosh on
which the CD-ROM does not mount.



44

T
e

c
h

n
i c

a
l  

S
u

p
p

o
r

t
Type On Call Accessing Type on Call 4.x for

Windows on a Workstation
Without a CD-ROM Drive

You can access Adobe Type On Call 4.x on a Windows workstation without a CD-ROM drive by
using the FWB CD Toolkit to mount Type On Call on a Macintosh with a CD-ROM drive. The
Type On Call CD-ROM contains both an HFS (Macintosh) partition and an ISO 9660 (Win-
dows) partition, which can be mounted simultaneously on a Macintosh using the FWB CD
Toolkit control panel. After you mount the ISO 9660 partition, you can enable sharing for the
mounted volume and then connect to the Type On Call CD-ROM from the Windows worksta-
tion via a network.

To mount Type On Call’s ISO 9660 partition using FWB CD Toolkit:

DISCLAIMER:  This procedure is not supported by Adobe Systems Incorporated and is only
provided as a guideline. Experience using the FWB CD Toolkit is highly recommended.

1. On the Macintosh, move any CD-ROM extensions in the Extensions folder in the System
Folder (e.g., Apple CD-ROM) to another location (e.g., desktop).

2. If it is not already installed, install the CD-ROM Toolkit control panel in the Control Panels
folder in the System Folder, then restart the Macintosh.

3. In the CD-ROM Toolkit control panel, click Options.
4. Select the “Allow Mounting of Any ISO 9660 Volumes on Dual-Format Apple HFS CD-

ROMs” option, then click OK.
5. Restart the Macintosh.
6. Insert the Type On Call CD-ROM disc. The HFS partition and the ISO 9660 partition

should mount. Both partitions will have the same name (e.g., “Disc 1”), but the HFS
(Macintosh) partition displays a CD icon, while the ISO 9660 (Windows) partition displays
the Toolkit’s hammer and wrench icon.

The FWB CD Toolkit is available from:
FWB Software, Inc.
1555 Adams Drive
Menlo Park, CA 94025-1439
Phone: 415-325-4392



45

T
e

c
h

n
i c

a
l  

S
u

p
p

o
r

t
Type On Call Can’t Install Type On Call in

SoftWindows or Other
Windows Emulation Software

Issue
In Windows emulation software (e.g., SoftWindows) for the Macintosh, the File Manager does
not display the Adobe Type On Call 4.0 or later Windows files (e.g., Installer, free fonts, docu-
ments), preventing you from installing Type On Call. The Macintosh Finder displays the Type
On Call 4.0 and later Macintosh files (e.g., Installer, free fonts, documents) as expected.

Solution

Install Type On Call 4.0 and later on a workstation using Microsoft Windows 3.1 or later, copy
ATM and the fonts to a network server or disks, then install them on the Macintosh running
Windows emulation software:
1. Install Type On Call 4.0 and later on a workstation using Microsoft Windows 3.1 or later.
2. In the Adobe Purchaser, unlock the Type On Call registration and order any fonts you want

to install, then click Copy Unlocked Products in the Order window.
3. In the All Orders window, select package “601-00 PC Type Utilities” and any font packages

you want to copy, then click Copy. Do not click Install Application or Exit (Type On Call
4.0x) or Close (Type On Call 4.1 or later) when the prompt “The product ‘Adobe Type
Manager (PC Font Utilities)’ has been copied... You may now install the application.”
appears.

4. With the Software Successfully Copied dialog box still on screen, choose Start > Programs >
Windows Explorer (Windows 95) or press Alt + Tab to switch to Program Manager and
start File Manager from the Main group (Windows 3.1x).

5. In Windows Explorer (Windows 95) or File Manager (Windows 3.1x), locate the ATM
subdirectory in the Toc4\Data\Pc (Type On Call 4.0x) or Toc4\data (Type On Call 4.1 or
later) directory. The ATM directory contains the ATM 3.0x installation files and the Psfonts
directory containing Type 1 fonts included with ATM.

6. To install ATM from a network server, copy the ATM directory to the desired location on the
network server.

OR: To install ATM from two 1.4 MB disks, copy the ATM directory contents, except the
Psfonts directory, onto the first disk, then copy the Psfonts directory onto the second disk.

7. Choose File > Close to exit Explorer (Windows 95) or choose File > Exit to exit File Man-
ager, then press Alt + Tab (Windows 3.1x) to switch back to the Adobe Purchaser.

8. In Adobe Purchaser’s Software Successfully Copied dialog box, click Exit (Type On Call
4.0x) or Close (Type On Call 4.1 or later). After you exit or close, the Adobe Purchaser
automatically deletes the ATM installation files from the Toc4\Data\Pc\Atm (Type On Call
4.0x) or Toc4\Data\Atm (Type On Call 4.1 or later) directory on your hard drive.
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Type On Call

9. Copy any additional font files (e.g., other fonts you copied from the Type On Call CD-
ROM) from the Psfonts and Psfonts\Pfm directories to a network server or disks.

10. To install ATM in Windows emulation software from a network server, in Program Manager
choose File > Run, locate the Install.exe file in the directory on the network server to which
you copied the ATM files, then click OK

OR: To install ATM in Windows emulation software from a two-disk ATM installation disk
set, in File Manager, create a directory named ATM at the root level of the hard drive (i.e.,
C:\Atm), then copy the contents of both disks into the new ATM directory. The new ATM
directory should contain the ATM installation files and the Psfonts directory. In Program
Manager, choose File > Run, type “C:\Atm\Install.exe” in the Command Line text box, then
click OK.

11. Install fonts in ATM from the network server or from disks.

Additional Information
The Type On Call 4.0 and later CD-ROM contains both Macintosh and Windows partitions.
Because the Macintosh system software recognizes only the Macintosh resources located on the
Type On Call CD-ROM, Windows emulation software (e.g., SoftWindows) on the Macintosh
cannot access the Windows files on the CD-ROM. Installing Type On Call 4.0 and later on a
workstation using Microsoft Windows 3.1 or later, then copying ATM and fonts to a network
server or disks, enables you to install ATM and fonts on the Macintosh running Windows
emulation software.

For information about Windows font filenames, see the Fntnames.pdf file in the document
directory on the Type On Call CD-ROM. For instructions on using ATM, see the Usrguide.pdf
file in the document directory on the Type On Call CD-ROM. Access PDF files from the Type
On Call CD-ROM using the Macintosh Finder, or copy them to a network server or disk, then
open them on the Macintosh running Windows emulation software.

Can’t Install Type On Call in SoftWindows or Other Windows Emulation Software
continued
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Type On Call Alert “Sorry: You appear to

have re-installed Type On
Call” When Unlocking Fonts

Issue
After you enter previously valid access keys to unlock fonts, the Adobe Purchaser returns the
alerts, “Sorry: You appear to have re-installed Type On Call on your machine. Re-installs are
currently not supported through this interface.” and “Please contact your local Type On Call
Unlocking Center or Distributor for further Assistance.”

Solution
Obtain new unlocking keys for your unlocked fonts:

1. Create a new order in the Purchaser that includes all your previously unlocked fonts. Even if
you don’t know all the fonts you’ve unlocked, you must still create an order containing at
least one font so that the Purchaser generates your Customer Key.

2. Click Place Order.
3. Call the Type on Call Unlocking Center phone number for your area, as listed in the upper

right corner of the Pending Order window.
4. Explain to the Unlocking Center representative that you need to obtain new access keys after

reinstalling Type On Call. The representative will ask you for the Customer Key number
displayed in the Pending Order window, then will provide you with access keys for all the
fonts previously unlocked from that Type On Call CD-ROM.

Additional Information
When you reinstall Type On Call, your Customer Key changes and previous access keys no
longer work. You must use Purchaser to generate a new Customer Key, then obtain new access
keys generated specifically for that new Customer Key.

To avoid having to obtain new access keys when you reinstall, first back up Type On Call using
the Backup/Uninstall utility on the Type On Call CD-ROM. You can then restore Type On Call
from the backup file. For information about backing up and restoring Type On Call, see the
UsrGuide.pdf file in the Documentation folder on the Type on Call CD-ROM.
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Type On Call Error “Invalid Customer Key”

Installing Type On Call

Issue
After an Adobe Customer Services representative enters your Customer Key in the Type On Call
unlocking database, the Type On Call Installer returns the error “Invalid Customer Key.”

Solution
Remove Type On Call, select another video driver (e.g., Standard VGA), reinstall Type On Call,
then obtain new access codes for previously unlocked fonts:

1. Insert the Type On Call CD-ROM into the CD-ROM drive.
2. Launch the Type On Call Backup/Restore Utility (RESTBKUP.EXE) from the Type On Call

CD-ROM.
3. In the Type On Call Backup/Restore Utility dialog box, click Uninstall.
4. In the TOC Uninstall dialog box, click OK.
5. After successfully removing Type On Call, click OK in the Success window, then click Exit.
6. Right-click on the desktop, then choose Properties from the pop-up menu.
7. In the Display Properties dialog box, click the Settings tab, then click the Change Display

Type button.
8. Note the Adapter Type, then click Change.
9. In the Select Device dialog box, select the Show All Devices option.
10. Select the Standard Display Types option from the top of the Manufacturers scroll box.
11. Select the Standard Display Adapter (VGA) option from the Models scroll box, then click

OK.
12. Note the Monitor Type, then click Change.
13. In the Select Device dialog box, select the Show All Devices option.
14. Select the Standard Monitor Types option from the top of the Manufacturers scroll box.
15. Select another video driver (e.g., Standard VGA 640x480) from the Models scroll box, then

click OK.
16. Restart Windows 95.
17. Reinstall Type On Call, then select your original video driver.
18. Contact Adobe Customer Services to obtain new access keys for previously unlocked fonts.

Additional Information
The Type On Call Installer (Install.exe) is incompatible with some video drivers (e.g., Cirrus
Logic, Trident, Trio, STB) in Windows 95. After unlocking your Type On Call database, the Type
On Call Installer returns the error “Invalid Customer Key” when an incompatible video driver is
installed in Windows 95. Using a compatible video driver (e.g., Standard VGA) enables the Type
On Call Installer to successfully install Type On Call.
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Type On Call Error “File not found...”

Installing Type On Call

Issue
After clicking an install language (e.g., English, French) when installing Type On Call in Win-
dows 95, the Type On Call Installer returns the error “File not found on CD-ROM drive.”

Solution
Remove Type On Call, select another video driver (e.g., Standard VGA), reinstall Type On Call,
then obtain new access codes for previously unlocked fonts:

In Windows 95:
1. Insert the Type On Call CD-ROM into the CD-ROM drive.
2. Launch the Type On Call Backup/Restore Utility (Restbkup.exe) from the Type On Call CD-

ROM.
3. In the Type On Call Backup/Restore Utility dialog box, click Uninstall.
4. In the TOC Uninstall dialog box, click OK.
5. After successfully removing Type On Call, click OK in the Success window, then click Exit.
6. Right-click on the desktop, then choose Properties from the pop-up menu.
7. In the Display Properties dialog box, click the Settings tab, then click the Change Display

Type button.
8. Note the Adapter Type, then click Change.
9. In the Select Device dialog box, select the Show All Devices option.
10. Select the Standard Display Types option from the top of the Manufacturers scroll box.
11. Select the Standard Display Adapter (VGA) option from the Models scroll box, then click

OK.
12. Note the Monitor Type, then click Change.
13. In the Select Device dialog box, select the Show All Devices option.
14. Select the Standard Monitor Types option from the top of the Manufacturers scroll box.
15. Select another video driver (e.g., Standard VGA 640x480) from the Models scroll box, then

click OK.
16. Restart Windows 95.
17. Reinstall Type On Call, then select your original video driver.
18. Contact Adobe Customer Services to obtain new access keys for previously unlocked fonts.

In Windows 3.1x:
1. Insert the Type On Call CD-ROM into the CD-ROM drive.
2. Launch the Type On Call Backup/Restore Utility (Restbkup.exe) from the Type On Call CD-

ROM.
3. In the Type On Call Backup/Restore Utility dialog box, click Uninstall.
4. In the TOC Uninstall dialog box, click OK.
5. After successfully removing Type On Call, click OK in the Success window, then click Exit.
6. Make sure your Windows installation disks are available.
7. Make a backup copy of the System.ini file, located in the Windows directory.



50

T
e

c
h

n
i

c
a

l
 

S
u

p
p

o
r

t
Type On Call

8. In the Main group in Program Manager, double-click Windows Setup.
9. In Windows Setup, choose Options > Change System Settings.
10. In the Change System Settings dialog box, select VGA from the Display pop-up menu, then

click OK.
11. Follow the on-screen instructions to install the VGA video driver, inserting Windows

installation disks if prompted.
12. Restart Windows.
13. Reinstall Type On Call, then select your original video driver.
14. Contact Adobe Customer Services to obtain new access keys for previously unlocked fonts.

Additional Information
The Type On Call Installer (Install.exe) is incompatible with some video drivers (e.g., Cirrus
Logic, Trident, Trio, STB) in Windows 95 and Windows 3.1x. When you install Type On Call on
a computer with an incompatible video driver, the error “File not found on CD-ROM drive”
appears after you click an install language. Using a compatible video driver (e.g., Standard VGA)
enables the Type On Call Installer to successfully install Type On Call.

Error “File not found...” Installing Type On Call continued
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Type On Call Error “...not using your

original CD-ROM” Unlocking
Fonts in Type on Call

Issue
After entering your access key and clicking Unlock in Adobe Purchaser’s Registration Order
window, Type on Call returns the error “You are not using your original CD-ROM.”

Solution
Remove Type On Call, select another video driver (e.g., Standard VGA), reinstall Type On Call,
then obtain new access codes for previously unlocked fonts:

1. Insert the Type On Call CD-ROM into the CD-ROM drive.
2. Launch the Type On Call Backup/Restore Utility (RESTBKUP.EXE) from the Type On Call

CD-ROM.
3. In the Type On Call Backup/Restore Utility dialog box, click Uninstall.
4. In the TOC Uninstall dialog box, click OK.
5. After successfully removing Type On Call, click OK in the Success window, then click Exit.
6. Right-click on the desktop, then choose Properties from the pop-up menu.
7. In the Display Properties dialog box, click the Settings tab, then click the Change Display

Type button.
8. Note the Adapter Type, then click Change.
9. In the Select Device dialog box, select the Show All Devices option.
10. Select the Standard Display Types option from the top of the Manufacturers scroll box.
11. Select the Standard Display Adapter (VGA) option from the Models scroll box, then click

OK.
12. Note the Monitor Type, then click Change.
13. In the Select Device dialog box, select the Show All Devices option.
14. Select the Standard Monitor Types option from the top of the Manufacturers scroll box.
15. Select another video driver (e.g., Standard VGA 640x480) from the Models scroll box, then

click OK.
16. Restart Windows 95.
17. Reinstall Type On Call, then select your original video driver.
18. Contact Adobe Customer Services to obtain new access keys for previously unlocked fonts.

Additional Information
The Type On Call Installer (Install.exe) is incompatible with some video drivers (e.g., Cirrus
Logic, Trident, Trio, STB) in Windows 95. After installing Type On Call in Windows 95, entering
your access key and clicking Unlock in Adobe Purchaser’s Registration Order window causes
Type On Call to return the error “You are not using your original CD-ROM” when an incom-
patible video driver is installed. Temporarily selecting a compatible video driver (e.g., Standard
VGA) enables you to successfully install Type On Call.
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Type On Call Error “Win.ini is Dangerously

Large” Installing Fonts from
Type On Call

Issue
When you try to copy and install unlocked products from the Adobe Purchaser on the Type On
Call CD-ROM, the Purchaser returns the error “Win.ini is Dangerously Large. Files in this
package will only be copied.” The Purchaser copies the font files to the hard disk in the specified
directory (e.g., C:\Psfonts).

Solutions
Use Adobe Type Manager (ATM) to install the fonts copied from Type On Call.

OR: If you have fewer than 200 fonts installed in ATM, make sure the Win.ini “softfonts=xxx”
references correctly reflect the number of installed fonts by removing all your installed fonts
from ATM, removing font references from the Win.ini and Atm.ini files, then re-adding your
fonts in ATM:

In ATM 4.0:
1. Make backup copies of the Win.ini and Atm.ini files.
2. In ATM, export your sets (ATM Deluxe only) and remove all installed fonts. For instruc-

tions, see Additional Information.
3. Open the Win.ini file, located in the Windows directory, in a text editor that can save in text-

only format (e.g., Notepad, WordPad).
4. Delete any lines that begin with “softfont” (e.g., softfonts=20).
5. Delete all lines that refer to an MFD file (e.g., ADMFDFile=C:\Windows\Ad434af1\ Mfd).
6. Save the Win.ini file in text-only format.
7. Open the Atm.ini file, located in the Windows directory, in a text editor that can save in

text-only format (e.g., NotePad, WordPad).
8. Delete any lines in the [Fonts] section (e.g., “Helvetica=C:\Psfonts\Pfm\Hv______.pfm;

C:\Psfonts\Hv______.pfb”).
9. Save the Atm.ini file in text-only format.
10. Delete all Atmfonts.qlc files, then restart Windows.
11. In ATM, re-add the problem fonts. For instructions, see Additional Information.
12. Choose Start > Find > Files or Folders, then locate the Win.ini file in the Windows directory.

Check the size of the Win.ini file in the search results window and make sure it is smaller
than 32K. If the Win.ini file is greater than 32K, make a backup of the file, then open the
original Win.ini in a text editor that can save in text-only format and remove lines or
sections no longer needed.

In ATM 3.0x:
1. Make backup copies of the Win.ini and Atm.ini files.
2. In the ATM Control Panel, select all fonts in the Installed ATM Fonts list and click Remove.
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3. In the Remove Fonts dialog box, select No Confirmation to Remove Fonts if you don’t want
the dialog box to appear for each font you remove, then click Yes or Yes to All. Do not select
Delete Fonts from Disk unless you want to delete the font files from your system.

4. Open the Win.ini file, located in the Windows directory, in a text editor that can save in text-
only format (e.g., NotePad, Windows Write).

5. Delete any lines that begin with “softfont” (e.g., softfonts=200).
6. When using Windows 95, delete all lines that refer to an MFD file (e.g.,

ADMFDFile=c:\windows\ad434af1\mfd).
7. Save the Win.ini file in text-only format.
8. Open the Atm.ini file, located in the Windows directory, in a text editor that can save in

text-only format (e.g., NotePad, Windows Write).
9. Delete any lines in the [Fonts] section (e.g., “Helvetica=c:\psfonts\pfm\HV______.PFM;

c:\psfonts\HV______.PFB”).
10. Save the Atm.ini file in text-only format.
11. Delete all Atmfonts.qlc files, then restart Windows.
12. Open the ATM Control Panel, then click Add.
13. In the Add Fonts dialog box, locate the drive and directory where your fonts are located

(e.g., C:\psfonts\pfm, A:\psfonts).
14. Select the fonts you want to install from the list of available fonts, then click Add.
15. Choose Start > Find > Files or Folders (Windows 95) or open File Manager and choose

Search > Find (Windows 3.1x), then locate the Win.ini file in the Windows directory. Check
the size of the Win.ini file in the search results window and make sure it is smaller than 32K.
If the Win.ini file is larger than 32K, make a backup of the file, then open the original
Win.ini in a text editor that can save in text-only format and remove lines or sections no
longer needed.

Additional Information
The Adobe Purchaser reads each [PostScript, port] section in the Win.ini file to locate any
“softfonts=xxx” references when you try to copy and install font files. Regardless of the actual
size of the Win.ini file, when any “softfonts=xxx” reference specifies a number of 200 or higher,
the Purchaser returns the error “Win.ini is Dangerously Large. Files in this package will only be
copied.” Then the Adobe Purchaser copies unlocked fonts onto the hard disk but does not install
them into ATM or into the Win.ini file. You can install the fonts in ATM after they have been
copied.

When you have Autodownload selected in the Purchaser’s Unlock and Copy dialog box and you
have a Microsoft PostScript printer driver installed, the Purchaser adds a reference to the Win.ini
file indicating the number and location of your font files for the Microsoft driver. A large
number of font references can cause the Win.ini file to grow too large, which can cause a variety
of system problems. The Win.ini file has a maximum allowable file size of 64K, but keeping it
32K or smaller enables your system to run more efficiently and may prevent errors. When the
size of the Win.ini file exceeds 32K or 64K, Windows or applications running in Windows may
behave unpredictably.

To export your sets in ATM Deluxe 4.0:
1. In ATM, click the Sets tab.
2. Select one or more sets to export.

Error “Win.ini is Dangerously Large” Installing Fonts from Type On Call continued
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3. Choose File > Export.
4. In the Export dialog box, specify a filename and location for the AFS file, then click Save.

To remove your fonts in ATM 4.0:
1. In the All Font Sets pane of the Sets tab (ATM Deluxe 4.0) or the Fonts tab (ATM 4.0), select

the fonts you want to remove, then click Remove.
2. In the Remove Font dialog box, select the Remove Fonts from All Set and Master Font List

option, select the Remove Font Files from Disk option if you are reinstalling your fonts from
the original installation disks, then click Yes or Yes to All.

To re-add your fonts in ATM 4.0:
1. Click the Add Fonts tab (ATM Deluxe 4.0) or the Fonts tab (ATM 4.0), then select Browse

for Fonts from the Source pop-up menu.
2. Navigate to the drive and directory where your fonts files are located (e.g., C:\Psfonts\Pfm,

A:\Fontdisk).
3. Select the fonts you want to add from the Source pane scroll box then click Add.

To import your sets in ATM Deluxe 4.0:
1. With Browse for Fonts still selected in the Source pop-up menu, navigate to the drive and

directory where your AFS file is located. ATM lists the sets you exported in the AFS file.
2. Select the sets you want to import, then click Add.
3. Remove any duplicate fonts outside your sets by selecting them and clicking Remove.

Error “Win.ini is Dangerously Large” Installing Fonts from Type On Call continued
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Type On Call Error “-43” or “AFM File Not

on CD-ROM” Copying
Multiple Master Font from
Type On Call

Issue
When you copy a multiple master font from the Type On Call 4.x Purchaser, the Purchaser
returns the error, “Error -43 File Not Found” or “Sorry, but the AFM file for this font is not on
the CD-ROM. Please contact Adobe Systems if you need the AFM file.” Single master fonts copy
without error.

Solution
Disable the Copy AFMs option in the Purchaser, then copy the multiple master font:

1. In the Purchaser, choose Setup > Setup Information (Type On Call 4.1 or later) or Setup >
Software Setup (Type On Call 4.0x).

2. Deselect the Copy AFMs option, then click OK.

Additional Information
AFM files for multiple master fonts, which are available only for the Macintosh, are included on
font disk sets purchased directly from Adobe. Because multiple master fonts on the Type On
Call CD-ROM do not include AFM files, the error “Error -43 File Not Found” or “Sorry, but the
AFM file for this font is not on the CD-ROM. Please contact Adobe Systems if you need the
AFM file.” occurs when you copy multiple master fonts from the Type On Call 4.x Purchaser
with the Copy AFMs option selected.
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Type On Call Error “ATM requires more

memory or additional system
resources” on Startup

Issue
When starting the Macintosh, the error “ATM requires more memory or additional system
resources” appears.

Solutions
Do one or more of the following:

A. If you’re using Adobe Type Manager (ATM) 3.8.x or ATM 3.9 on a Power Macintosh, change
the Virtual Memory and Modern Memory Manager settings in the Memory control panel,
then restart the computer. For example, if the Virtual Memory option is Off and the Mod-
ern Memory Manager is On, set the Virtual Memory option to On and the Modern Memory
option to Off, then restart.

B. If your hard disk has been formatted by FWB Toolkit RTK 1.8, reformat it using the FWB
Toolkit HDT 2.0 or later. For instructions, see the FWB documentation or contact FWB.

C. Reinstall ATM.
If you’re using ATM 3.8.x or ATM 3.9 on a Power Macintosh or a 68000-series (68K)
Macintosh with a Power Macintosh upgrade card, install ATM for the 68K Macintosh:
1. Insert the ATM Program Disk, then launch the ATM & Font Installer.
2. In the ATM & Font Installer window, select Custom Install from the pop-up menu.
3. In the Check Features To Be Installed list, select ATM For 68020/030/040, then click

Install.

NOTE:  Running ATM for the 68K Macintosh on a Power Macintosh causes the alert
“Adobe Type Manager will run much faster if you install a PowerMac version” to occur
on startup, which cannot be disabled.

If you’re using ATM 3.7, reinstall ATM 3.7 or later.

If you’re using ATM 3.6.x, delete the ATM driver files in the System Folder (i.e., ~ATM
68000, 68020/030, 68020/030/040), reinstall ATM 3.6.x, then restart the computer.

If you’re using ATM 3.5 or earlier, upgrade to ATM 3.6 or later.

D. Recreate the ATM Temp.ATM file by doing one or more of the following:
a. Recreate the Preferences folder:
1. Move the Preferences folder from the System Folder to another location (e.g., desktop).
2. Restart the Macintosh. The Finder creates a new Preferences folder and new system

preferences files on startup.
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Type On Call Error “ATM requires more memory or additional system resources” on Startup

continued

3. Move the new system preferences files (e.g., Finder Preferences) from the new Prefer-
ences folder in the System Folder to another location (e.g., new folder on the desktop,
Trash without emptying the Trash).

4. Open the old Preferences folder, choose Edit > Select All, then move the selected prefer-
ences files into the new Preferences folder in the System Folder.

5. Restart your Macintosh.
6. Delete the new system preferences files that you moved to another location.
b. Use Symantec Anti-Virus to locate and remove damaged ATM Temp.ATM files, then

restart the computer to create a new ATM Temp.ATM file.
c. Use ResEdit to change the ATM Temp.ATM file to a visible file, remove the ATM

Temp.ATM file, then restart:
1. In ResEdit, choose File > Get File/Folder Info.
2. In the Get File/Folder Info dialog box, locate the ATM Temp.ATM file in the Preferences

folder in the System Folder, then click Get Info.
3. In the Get Info dialog box, deselect the Invisible option.
4. Choose File > Save, then close ResEdit.
5. Remove the ATM Temp.ATM file from the Preferences file in the System Folder, then

restart the computer.

NOTE: Other extensions or control panels may prevent ATM from loading. Run ATM
with all extensions off by using an extensions manager to disable all extensions and
control panels except ATM or by removing all extensions and control panels from the
System Folder except ATM then restarting the computer to verify that added extensions
or control panels are not the cause.

Additional Information
The error “ATM requires more memory or additional system resources” may occur when you
start a Power Macintosh if ATM 3.8.x or ATM 3.9 is installed. Changing the Virtual Memory and
Modern Memory Manager settings in the Memory control panel, or installing ATM for the 68K
Macintosh, may prevent the error from occurring and enable ATM to load as expected.

FWB Toolkit HDT is compatible with ATM, but FWB Toolkit RTK 1.8 is incompatible with
ATM. Reformatting your hard disk using FWB Toolkit HDT prevents the error “ATM requires
more memory or additional system resources” and enables ATM to load as expected.

The error “ATM requires more memory or additional system resources” occurs on startup when
the ATM Temp.ATM file, the ATM control panel, or the ATM driver file is damaged, or when
there is an extension conflict.

ATM Temp.ATM is an invisible, temporary file that ATM creates and locates in the Preferences
folder in the System Folder. SuperATM and Acrobat use the ATM Temp.ATM file to store font
substitution information. When the ATM Temp.ATM file is damaged, creating a new Preferences
folder or deleting the ATM Temp.ATM file enables ATM to create a new ATM Temp.ATM file on
startup.

ATM 3.5 and earlier are incompatible with DECNet, Dayna DOS Mounter, Norton FileSaver,
Suitcase 1.2.10 or earlier running in System 7.0.x, or Suitcase 2.1.2 running in System 7.1 or
later. Starting a Macintosh with ATM 3.5 or earlier and one of these utilities installed causes the
error “ATM requires more memory or additional system resources.” to occur.
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Type On Call Error “Substitution fonts

necessary for Acrobat or
SuperATM are missing”
During Startup

Issue
Adobe Type Manager (ATM) 3.8.2 or later returns the alert, “The substitution fonts necessary
for Acrobat or SuperATM are missing. Please re-install either software package.” during startup.

Solutions
Install the Adobe Sans MM and Adobe Serif MM font files included with SuperATM 3.8.x or 3.9,
Acrobat Reader 2.0.1 or later, or Acrobat Exchange 2.0.1 or later into the Fonts folder in the
System Folder.

OR: When you are not using SuperATM, Acrobat Reader, or Acrobat Exchange, remove the ATM
Font Database file from the System Folder.

Additional Information
ATM 3.8.2 and later try to locate the Adobe Sans MM and Adobe Serif MM fonts during startup
when the ATM Font Database file is installed in the System Folder. When ATM is unable to
locate the Adobe Sans MM and Adobe Serif MM font files, it returns the error, “The substitution
fonts necessary for Acrobat or SuperATM are missing. Please re-install either software package.”

Both SuperATM and the Adobe Acrobat products install a read-only ATM Font Database file
into the System Folder. SuperATM’s ATM Font Database file contains the font substitution
information for most of Adobe’s typefaces including height, weight, and pair kerning informa-
tion. The file size of SuperATM’s Font Database file is larger than 1 MB, while Acrobat’s ATM
Font Database file size is smaller than 100K, since it contains substitution information for only
the Acrobat applications. SuperATM can generate substitute fonts only for those fonts whose
substitution information is included in its ATM Font Database file.

SuperATM uses the Adobe Sans MM and Adobe Serif MM multiple master fonts to generate
substitute fonts. Because Adobe Sans MM and Adobe Serif MM are used for substitution only,
they do not appear in application font menus.
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Type On Call System Error (Freeze, Type 11)

When ATM Deluxe 4.0 Is
Installed

Issue
After you install Adobe Type Manager (ATM) Deluxe 4.0 and restart the Macintosh, a system
error (e.g., freeze, Type 11) occurs during startup or when you open the ATM Deluxe control
panel.

Solutions
Do one or more of the following:

A. Disable other extensions by doing one or more of the following:
A. Use an extensions manager (e.g., Apple Extensions Manager, Casady & Greene Conflict

Catcher, Now Startup Manager) to disable all extensions except ATM Deluxe.
B. Manually disable extensions by moving them out of the System Folder, then replace

only the ATM control panel. To manually disable extensions:
1. Move the Control Panels and Extensions folders from the System Folder to a

different location (e.g., desktop).
2. Restart the Macintosh. The system searches for the Control Panels and Extensions

folders in the System Folder. When your system cannot find these folders in the
System Folder, it creates new ones.

3. Move the ATM control panel from your previous Control Panels folders into your
new, empty Control Panels folder in the System Folder.

4. Restart your Macintosh.
B. Delete the Adobe Type Manager folder from the Preferences folder in the System Folder,

then restart the Macintosh.
C. Make sure the Fonts folder and the fonts it contains are not damaged:

1. Move the Fonts folder from the System Folder to another location (e.g., desktop), then
restart the Macintosh. The system creates a new, empty Fonts folder during startup.

2. Try to recreate the error. If the error does not reoccur, one or more fonts may be dam-
aged. Move font files from the old Fonts folder to the new Fonts folder one at a time,
and then try to recreate the error after moving each font. If the error reoccurs after you
move a font back, reinstall that font from the original installation disks.

D. Remove and reinstall ATM Deluxe:
1. Start the ATM Deluxe installer on the ATM Deluxe CD-ROM.
2. Select Remove from the pop-up menu, then click Remove.
3. Disable all extensions except those your system requires to access your CD-ROM drive

(e.g., Apple CD-ROM). For instructions, see document 200311.
4. Restart the Macintosh.
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5. Start the ATM Deluxe installer on the ATM Deluxe CD-ROM.
6. Select Custom Install from the pop-up menu, select only the ATM Deluxe for

PowerMacintoshes option, then click Install.
E. Reinstall the system software. For instructions, see document 200407.

Additional Information
A system error can occur when the ATM control panel conflicts with another extension, an ATM
preferences file is damaged, or the ATM control panel loads a damaged font. Damaged or
conflicting system software or hardware can also cause a system error.

If you delete ATM’s preferences files, located in the Adobe Type Manager folder in the Prefer-
ences folder, ATM creates new preferences files the next time you open the ATM control panel.
The Adobe Type Manager folder in the Preferences folder contains the Adobe Type Manager
Preferences file and Adobe Type Manager’s Sets file.

System Error (Freeze, Type 11) When ATM Deluxe 4.0 Is Installed continued
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Type On Call Type 11 Error or Freeze After

Clicking Setup in Chooser
When ATM Lite Is Installed

Issue
When you select the Apple LaserWriter 8.4.x printer driver and then click Setup in the Chooser,
the system returns an error (e.g., “Type 11,” freeze). Adobe Type Manager (ATM) Lite 4.0 is
installed.

Solutions
Use the Apple LaserWriter 8.3.x or the Adobe PSPrinter 8.3.x printer driver.

OR: Upgrade to ATM Deluxe 4.0.

OR: Use ATM 3.9 or earlier.

Additional Information
The LaserWriter 8.4.x printer driver erroneously inserts unexpected information into a resource
file that the system, LaserWriter 8.4.x, and ATM Lite 4.0 share, causing the system to return an
error (e.g., “Type 11,” freeze) when ATM accesses the resource file. Using another printer driver,
ATM Deluxe 4.0, or ATM 3.9 or earlier enables you to click Setup in the Chooser without
receiving the system error. When ATM Lite 4.0 is not installed, the system error occurs if the
system accesses the shared resource file after the LaserWriter 8.4.x printer driver inserts the
unexpected information.
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Type On Call Blue Screen and Error “Fatal

exception error 0D” After
Installing ATM

Issue
After you install Adobe Type Manager (ATM) 3.0.x, ATM Deluxe 4.0, or ATM Lite 4.0 and
restart Windows 95, a blue screen appears and Windows returns the error, “Fatal exception error
0D at 05B7:000000F7.”

Solutions
Do one or more of the following:

A. Run Windows 95 in Safe Mode by restarting Windows, pressing the F8 key when the mes-
sage, “Starting Windows 95” appears, and selecting Safe Mode from the menu.

B. If Symantec pcANYWHERE 7.52 is installed:

Download and install the patch that makes it compatible with ATM. For instructions, see
Additional Information.

OR: Uninstall pcANYWHERE by choosing Start > Programs > PCAnywhere32 > Remove
PCAnywhere, then restart Windows.

C. Change the video driver to the Windows standard VGA driver. For instructions, see docu-
ment 300303. If changing to the standard VGA driver corrects the problem, contact your
video driver’s manufacturer for a new or updated driver.

D. Set the video driver’s Hardware Acceleration setting to Full:
1. Choose Start > Settings > Control Panel, then open the System Control Panel.
2. Click the Performance tab, then click Graphics.
3. Move the Hardware Acceleration slider to Full and click OK.
4. When you’re prompted to restart your computer, click Yes.

E. Remove ATM 4.0. For instructions, see the ATM User Guide or document 7182.

NOTE: Turning off or uninstalling ATM will make PostScript fonts unavailable in your
applications.

F. Install ATM 3.02.

Additional Information
Symantec’s pcANYWHERE 7.52 is incompatible with ATM, causing Windows to display a blue
screen and return the error, “Fatal exception error 0D at 05B7:000000F7.” when both are in-
stalled. The pcANYWHERE patch, available on Symantec’s Web site, FTP site, and BBS, updates
pcANYWHERE so that it is compatible with ATM. Disabling pcANYWHERE enables Windows
95 to start without returning the error.
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The error, “Fatal exception error 0D” can also occur when a video driver is incompatible with
ATM Deluxe 4.0 or ATM Lite 4.0. Video drivers that are incompatible with either ATM Deluxe
4.0 or Lite 4.0 are also incompatible with the other. Video cards whose drivers are known to be
incompatible with ATM 4.0 include the ATI Graphics Pro Turbo PCI Mach64 and the Trident
9440 Linear Acceleration.

The pcANYWHERE patch installs the Awg.dll file, which makes pcANYWHERE 7.52 compat-
ible with ATM. The patch does not change the version of pcANYWHERE or the time of the DLL
files in the pcANYWHERE directory. For information on other files installed by the patch, see
the Update.log file in the pcANYWHERE directory after you install the patch.

To check the version of pcANYWHERE:
1. In Windows Explorer, navigate to the Program Files\Pcanywhere subdirectory.
2. Choose View > Details.
3. Check the time listed for pcANYWHERE’s DLL files in the Modified column. The time

equals the version number (e.g., 7:52 am is version 7.52).

To download and install the pcANYWHERE patch:
1. Download the pcANYWHERE patch from one of these online sources:

- Symantec’s FTP site (ftp://ftp.symantec.com/)
- Symantec’s Web site (http://www.symantec.com/techsupp/ftp/pacftp.html)
- Symantec’s BBS at (541) 484-6669

2. Decompress the patch file (75up_c2.exe).
3. Turn off ATM by following the instructions in the ATM User Guide.
4. Restart Windows.
5. Run the Setup.exe file located in the patch’s Disk 1 directory.
6. Turn ATM back on.

Blue Screen and Error “Fatal exception error 0D” After Installing ATM continued
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Type On Call Copying ATM Installation Files

from Type On Call 4.x to
Network Server or Floppy
Disk

Adobe Type Manager (ATM) 3.0x, or PC Type Utilities, is a free utility included on the Type On
Call 4.x CD-ROM. When you register Type On Call, you can unlock ATM and copy the ATM
installation files to your hard disk by clicking Copy Unlocked Products in the Adobe Purchaser
and then copying the PC Type Utilities. You can also copy the ATM installation files to a net-
work server or a disk set so that you can install ATM on a workstation without a CD-ROM
drive.

For information about Windows font filenames, see the Fntnames.pdf file in the Document
directory on the Type On Call CD-ROM. For instructions on using ATM, see the Usrguide.pdf
file in the Document directory on the Type On Call CD-ROM.

Windows 95

To copy the ATM installation files from Type On Call 4.x to a network server or floppy disk and
then install ATM:
1. Install Type On Call 4.x on a workstation using Windows 95.
2. In the Adobe Purchaser, register Type On Call and order any font you want to install, then

click Copy Unlocked Products in the Order window.
3. In the All Orders window, select 601-00 PC Type Utilities and any other font packages you

want to copy, then click Copy.
4. When Type On Call returns the message “The product ‘Adobe Type Manager (PC Font

Utilities)’ has been copied... You may now install the application.” in the Software Success-
fully Copied dialog box, choose Start > Programs > Windows Explorer. Do not click Install
Application or Close (Type On Call 4.1) or Exit (Type On Call 4.0x) in the Software Suc-
cessfully Copied dialog box.

5. In Windows Explorer, navigate to the ATM subdirectory in the Toc4\Data subdirectory
(Type On Call 4.1) or to the Toc4\Data\Pc subdirectory (Type On Call 4.0x). The ATM
subdirectory contains the ATM 3.0x installation files and the Psfonts subdirectory contain-
ing the PostScript Type 1 fonts included with ATM.

6. To install ATM from a network server, copy the ATM subdirectory to the desired location on
the network server.

OR: To install ATM from two 1.4MB floppy disks, copy the ATM subdirectory contents,
without the Psfonts subdirectory, onto the first disk, then copy the Psfonts subdirectory
onto the second disk.

7. Choose File > Close to exit Explorer.
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8. In Adobe Purchaser’s Software Successfully Copied dialog box, click Close (Type On Call
4.1) or Exit (Type On Call 4.0x). Adobe Purchaser automatically deletes the ATM installa-
tion files from the Toc4\Data\Atm (Type On Call 4.1) or Toc4\Data\Pc\Atm (Type On Call
4.0x) subdirectory on your hard disk.

9. Copy additional font files (e.g., other fonts you copied from the Type On Call CD-ROM)
from the Psfonts and Psfonts\Pfm subdirectories to the network server or floppy disks.

10. To install ATM on another workstation from a network server, choose Start > Run. Click
Browse in the Run dialog box, locate the Install.exe file in the directory on the network
server where you copied the ATM files, then click OK.

OR: To install ATM from floppy disks, in the Explorer create a directory named Atm at the
root level of the hard disk (i.e., C:\Atm), then copy the contents of both floppy disks into the
new Atm directory. The new Atm directory should contain the ATM installation files and
the Psfonts subdirectory. Choose Start > Run, type “c:\atm\install.exe” in the Command
Line text box, then click OK.

11. Install fonts in ATM from the network server or from disks.

Windows 3.1x

To copy the ATM installation files from Type On Call 4.x to a network server or floppy disk and
then install ATM:
1. Install Type On Call 4.x on a workstation using Windows 3.1x.
2. In the Adobe Purchaser, register Type On Call and order any fonts you want to install, then

click Copy Unlocked Products in the Order window.
3. In the All Orders window, select 601-00 PC Type Utilities and any other font packages you

want to copy, then click Copy.
4. When Type On Call returns the message “The product ‘Adobe Type Manager (PC Font

Utilities)’ has been copied... You may now install the application.” in the Software Success-
fully Copied dialog box, press Alt + Tab to switch to Program Manager, then start File
Manager from the Main group. Do not click Install Application or Close (Type On Call 4.1)
or Exit (Type On Call 4.0x) in the Software Successfully Copied dialog box.

5. In File Manager, navigate to the ATM subdirectory in the Toc4\Data subdirectory (Type On
Call 4.1) or to the Toc4\Data\Pc subdirectory (Type On Call 4.0x). The ATM subdirectory
contains the ATM 3.0x installation files and the Psfonts subdirectory containing the
PostScript Type 1 fonts included with ATM.

6. To install ATM from a network server, copy the ATM subdirectory to the desired location on
the network server.

OR: To install ATM from two 1.4MB floppy disks, copy the ATM subdirectory contents,
without the Psfonts subdirectory, onto the first disk, then copy the Psfonts subdirectory
onto the second disk.

7. Choose File > Exit to exit File Manager, then press Alt + Tab to switch back to the Adobe
Purchaser.

Copying ATM Installation Files from Type On Call 4.x to Network Server or Floppy
Disk continued
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8. In the Adobe Purchaser’s Software Successfully Copied dialog box, click Close (Type On Call
4.1) or Exit (Type On Call 4.0x). Adobe Purchaser automatically deletes the ATM installa-
tion files from the Toc4\Data\Atm (Type On Call 4.1) or Toc4\Data\Pc\Atm (Type On Call
4.0x) subdirectory on your hard disk.

9. Copy additional font files (e.g., other fonts you copied from the Type On Call CD-ROM)
from the Psfonts and Psfonts\Pfm subdirectories to the network server or floppy disks.

10. To install ATM on another workstation from a network server, choose File > Run in Pro-
gram Manager, click Browse in the Run dialog box, locate the Install.exe file in the directory
on the network server where you copied the ATM files, and then click OK.

OR: To install ATM from floppy disks, in File Manager create a directory named Atm at the
root level of the hard disk (i.e., C:\Atm), then copy the contents of both floppy disks into the
new Atm directory. The new Atm directory should contain the ATM installation files and
the Psfonts subdirectory. In Program Manager choose File > Run, type “c:\atm\install.exe” in
the Command Line text box, then click OK.

11. Install fonts in ATM from the network server or from disks.

Copying ATM Installation Files from Type On Call 4.x to Network Server or Floppy
Disk continued
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Type On Call ATM Deluxe Installer Fails and

Returns Error When Installing
Over ATM 3.0x

Issue
While installing Adobe Type Manager (ATM) Deluxe 4.0 over ATM 3.0x, the installer fails and
returns the errors, “This program has performed an illegal operation and will be shut down. If
the problem persists contact the program vendor.” and “Install caused a general protection fault
in module Install.exe at 0004:00001c58.”

Symptoms
The status bar shows that a percentage of the installation has been completed.

The ATM 3.0x Control Panel incorrectly displays 4.0 as the version number.

When you deselect the Font Substitution Database option in the installer, a greater percentage of
the installation is completed.

Solutions
Reduce the number of installed fonts, font references, or both, by doing one or more of the
following:

A. Remove earlier versions of ATM. For instructions, see document 341402.
B. Reduce the number of active PostScript Type 1 fonts by doing one or more of the following:

A. Remove all fonts installed in the ATM Control Panel.
B. Turn off the ATM Control Panel.
C. Delete the Atm.ini and the Atmreg.atm files from the Windows directory.

C. Reduce the number of active TrueType fonts by moving font files to another location:
1. Create a directory (e.g., C:\TrueType).
2. Open the Windows\Fonts directory.
3. Move TrueType font files, excluding TrueType fonts installed by Windows 95, from the

Windows\Fonts directory to another location. (For a list of the TrueType fonts installed
by Windows 95, see Additional Information).

NOTE: Windows 95 installs several hidden font files (e.g., Marlett.ttf, Dosapp.fon,
Vgafix.fon) that do not appear in Windows Explorer or in the Fonts Control Panel, but
may appear in font management utilities (e.g., Ares FontMinder). Windows requires
these hidden font files and they should not be deleted or removed from the Fonts
directory.

D: Remove references to downloadable PostScript fonts from the Windows Registry by deleting
printers that use the AdobePostScript printer driver (AdobePS):
1. Choose Start > Settings > Printers.
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2. To determine which printer driver a printer uses, right-click the printer’s icon and select
Properties from the pop-up menu. Click the Paper tab, then click About. The About
dialog box displays the printer driver version.

3. Right-click a printer that uses AdobePS and select Delete from the pop-up menu.
4. Follow the on-screen instructions to delete the printer.
5. Repeat steps 3 and 4 for each printer that uses AdobePS.
6. Restart Windows.

E. Reduce the number of softfont references in the Win.ini file:
1. Make a backup copy of the Win.ini file located in the Windows directory.
2. Open the original Win.ini file in a text editor that can save in text-only format (e.g.,

Notepad, WordPad).
3. Delete all lines that begin with the word “softfont” or refer to an MFD file (e.g.,

Admfdfile=C:\Windows\Ad434af1\Mfd).
4. Save the Win.ini file in text-only format.
5. Restart Windows.

F. Click Ignore when the illegal operation message appears. You may have to click Ignore
repeatedly, depending on how many fonts the installer is still trying to add to the Starter Set.

G. Install ATM Deluxe 4.0 when running Windows in Safe Mode:

NOTE: Safe Mode loads only the mouse, keyboard, and standard VGA device drivers.
Because you cannot access your CD-ROM drive while in Safe Mode, you will install ATM
using files copied to your hard disk.

1. Copy the ATM folder from the ATM Deluxe CD-ROM to your hard disk.
2. Restart Windows. When the message, “Starting Windows 95” appears, press the F8 key,

and then select Safe Mode from the startup menu.
3. Open the ATM folder and double-click the Install.exe file.
4. Follow the on-screen instructions.

Additional Information
The ATM installer creates a Starter Set of fonts, based on fonts already installed in ATM, True
Type fonts located in the Fonts directory, and font references in the Windows Registry and in the
Win.ini file. When there are a large number (e.g., 200 or more) of installed fonts or font refer-
ences, the ATM Deluxe installer is unable to create and activate a Starter Set of Installed fonts
and returns an error message.

Windows 95 installs the following TrueType fonts:
Font (Filename)

Arial (Arial.ttf)

Arial Bold (Arialbd.ttf)

Arial Bold Italic (Arialbi.ttf)

Arial Italic (Ariali.ttf)

Courier 10,12,15 (Courf.fon)

Courier New (Cour.ttf)

Courier New Bold (Courbd.ttf)

ATM Deluxe Installer Fails and Returns Error When Installing Over ATM 3.0x
continued
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Courier New Bold Italic (Courbi.ttf)

Courier New Italic (Couri.ttf)

Modern (Modern.fon)

MS Sans Serif 8,10,12,14,18,24 (Sseriff.fon)

MS Serif 8,10,12,14,18,24 (Seriff.fon)

Small Fonts (Smallf.fon)

Symbol (Symbol.ttf)

Symbol 8,10,12,14,18,24 (Symbolf.fon)

Times New Roman (Times.ttf)

Times New Roman Bold (Timesbd.ttf)

Times New Roman Bold Italic (Timesbi.ttf)

Times New Roman Italic (Timesi.ttf)

WingDings (Wingding.ttf)

ATM Deluxe Installer Fails and Returns Error When Installing Over ATM 3.0x
continued
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Install or Behave as Expected

Issue
Adobe Type Manager (ATM) Deluxe 4.0 does not install (e.g., the installer freezes), or installs
but doesn’t behave as expected.

Symptoms
After you activate a PostScript or TrueType font, it does not list in application font menus.

After you deactivate a PostScript or TrueType font, the deactivated font appears in application
font menus.

When you print to a PostScript printer, it substitutes a PostScript font that appears in font
menus with its default font (e.g., Courier).

TrueType font names spontaneously appear outside of font sets in ATM Deluxe.

ATM Deluxe displays a red “x” next to a TrueType font name.

Fonts do not autoactivate as expected in applications that support autoactivation.

Solution
Uninstall ATM, remove unnecessary fonts and font references, set a printer driver as the default,
then reinstall ATM:

1. Uninstall ATM Deluxe 4.0 by clicking the Settings tab in ATM, clicking Uninstall ATM, then
following the on-screen instructions. After uninstalling ATM, restart Windows.

2. Remove any remaining ATM files. For instructions, see Additional Information.
3. Temporarily move TrueType font files, except for those TrueType fonts installed by Windows

95, from the Windows\Fonts directory to another location. For a list of the TrueType fonts
installed by Windows 95, see Additional Information.

NOTE: Windows 95 installs several hidden font files (e.g., Marlett.ttf, Dosapp.fon,
Vgafix.fon) that do not appear in Windows Explorer or in the Fonts Control Panel, but may
appear in font management utilities (e.g., Ares FontMinder). Windows requires these
hidden font files to run so do not delete them or remove them from the Fonts directory.

4. Remove unnecessary font keys from the Registry in the Registry editor. For instructions, see
Additional Information.

5. Remove unnecessary softfont references from the Win.ini file. For instructions, see Addi-
tional Information.

6. Remove duplicate printers or printers you do not regularly print with by choosing Start >
Settings > Printers, right-clicking the appropriate printer, then selecting Delete from the
pop-up menu.
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7. Select a printer as your default printer by choosing Start > Settings > Printers, right-clicking
the appropriate printer, then selecting Set As Default from the pop-up menu.

8. Reinstall ATM Deluxe.
9. Create a Windows TrueType Fonts set so you can easily determine which fonts you cannot

disable. For instructions, see Additional Information.

Additional Information
ATM enables you to add, remove, activate, and deactivate both PostScript and TrueType fonts in
Windows 95. A variety of causes can prevent ATM from installing, from activating or deactivat-
ing a font, or from listing a font in application font menus. These causes include previously
installed ATM files that prevent ATM’s installation, damaged or missing font files, a damaged
ATM application, or missing ATM support files. Uninstalling ATM, removing unnecessary fonts
and font references, setting a printer driver as the default printer, and then reinstalling ATM
enables ATM to install or activate and deactivate fonts as expected.

ATM cannot deactivate or autoactivate TrueType fonts located in the Windows\Fonts directory.
When you add TrueType fonts in ATM, it creates an Atmfonts subdirectory within the
Windows\Fonts directory, from which it can activate and deactivate these fonts.

Unnecessary or invalid keys (i.e., references) in the Registry can cause fonts to appear in applica-
tion font menus after you deactivated them in ATM. Unnecessary or invalid softfont (i.e.,
PostScript font) references in the Win.ini file can cause fonts to appear in application font
menus after you deactivate them or not to appear after you activate them. Removing these
references enables you to activate, deactivate, and move fonts as expected.

When you activate or deactivate fonts in ATM, the selected default printer can affect which fonts
display in application font menus. If you activate fonts when ATM is set up to download fonts
for one or more Microsoft PostScript printer drivers, ATM adds font references to the Win.ini
file. Each font reference in the Win.ini file increases its file size, which also increases the possibil-
ity of system problems. The Win.ini file has a maximum allowable file size of 64K, but a Win.ini
file size of 32K or smaller enables your system to run more efficiently. To prevent ATM from
adding unnecessary font references, remove duplicate or seldom used Microsoft PostScript
printer drivers, then set up one of your printers as the default printer before you reinstall ATM.

After you reinstall ATM, it creates a Starter Set containing the TrueType fonts installed in the
Windows\Fonts directory and the PostScript fonts included with ATM. You can make a set
containing the TrueType fonts installed by Windows 95 so you can easily recognize which fonts
you cannot deactivate, then remove those fonts from the Starter Set. Use the Add from Font Sets
option, which adds fonts to a new set, but does not copy the font files to another directory, to
make sure ATM does not copy the TrueType font files installed by Windows 95 from the
Windows\Fonts directory to another location.

Windows 95 installs the following TrueType fonts:

Font (Filename)

Arial (Arial.ttf)

Arial Bold (Arialbd.ttf)

Arial Bold Italic (Arialbi.ttf)

Arial Italic (Ariali.ttf)

ATM Deluxe 4.0 Doesn’t Install or Behave as Expected continued
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Courier 10,12,15 (Courf.fon)

Courier New (Cour.ttf)

Courier New Bold (Courbd.ttf)

Courier New Bold Italic (Courbi.ttf)

Courier New Italic (Couri.ttf)

Modern (Modern.fon)

MS Sans Serif 8,10,12,14,18,24 (Sseriff.fon)

MS Serif 8,10,12,14,18,24 (Seriff.fon)

Small Fonts (Smallf.fon)

Symbol (Symbol.ttf)

Symbol 8,10,12,14,18,24 (Symbolf.fon)

Times New Roman (Times.ttf)

Times New Roman Bold (Timesbd.ttf)

Times New Roman Bold Italic (Timesbi.ttf)

Times New Roman Italic (Timesi.ttf)

WingDings (Wingding.ttf)

To remove ATM files:
1. Choose Start > Find > Files or Folders.
2. Enter “atm*.*” in the Named text box, then click Find Now.
3. Delete the following files if they appear in the search results window:

Atmfm.exe
Atmcntrl.exe
Atmsys.drv
Atm.ini
Atm32.dll
Atm16.dll
Atmfonts.qlc

To remove unnecessary font keys from the Registry in the Registry editor:
1. Choose Start > Run.
2. Type “regedit” in the Open text box and then click OK.
3. Make a backup copy of the Registry by choosing Registry > Export Registry File, choosing a

location and name for the backup file in the Export Registry File dialog box, then clicking
Save.

4. Open the Hkey_Local_Machine \Software\Microsoft\Windows\CurrentVersion key (i.e.,
directory), select the PostScriptFonts key, then press the Delete key to delete it.

5. Open the Fonts key, select the keys for all fonts except for the one named “Default” and the
TrueType fonts installed by Windows 95, then press Delete to delete them.

6. Exit the Registry Editor, which automatically saves your changes to the Registry.

To remove unnecessary softfont references from the Win.ini file:
1. Make a backup copy of the Win.ini file located in the Windows directory.
2. Open the original Win.ini file in a text editor that can save in text-only format (e.g.,

Notepad, WordPad).

ATM Deluxe 4.0 Doesn’t Install or Behave as Expected continued
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3. Delete all lines that begin with the word “softfont” or refer to an MFD file (e.g.,
Admfdfile=C:\Windows\Ad434af1\Mfd).

4. Save the Win.ini file in text-only format.
5. Restart Windows.

To create a new set containing only the TrueType fonts installed by Windows 95 in ATM:
1. In ATM, click the Add Fonts tab.
2. In the Add Fonts pane, double-click New Set in the Destination column.
3. In the New Set dialog box, type a name for your new set (e.g., “Windows TT Fonts”), select

the Activate New Set option, then click OK.
4. Select Add From Font Sets from the Source pop-up menu.
5. Double-click the Starter Set in the Source column to display its contents.
6. Add the following fonts from the Starter Set into your new set by dragging them from the

Source column to your new set in the Destination column:
Arial
Arial Bold
Arial Bold Italic
Arial Italic
Courier New
Courier New Bold
Courier New Bold Italic
Courier New Italic
Symbol
Times New Roman
Times New Roman Bold
Times New Roman Bold Italic
Times New Roman Italic
WingDings

7. Remove the fonts you added to your new set from the Starter Set.
8. Add or move your other fonts into sets as desired.

ATM Deluxe 4.0 Doesn’t Install or Behave as Expected continued
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PostScript Fonts General
Information

Adobe Type Manager (ATM) 3.9 and earlier create smooth display of PostScript fonts at any
point size using the PostScript font’s outline (printer) font file. When ATM cannot display a
PostScript font, the font displays bitmapped (i.e., jagged) or text with the font applied does not
display.

Without ATM, the system displays PostScript fonts by scaling the bitmap font file. Resizing a
bitmap font reproduces the general shape of the font, but may cause the font to display with
extreme pixelation (i.e., jagged), depending on the size of available bitmap font files and the
requested display size.

To prevent fonts from displaying with extreme pixelation, ATM rasterizes PostScript outline
fonts (i.e., converts outline font information into a scaleable bitmap image) to enable fonts to
display smoothly at any point size. ATM supports rasterizing PostScript fonts that adhere to the
Adobe Type 1 font specification. ATM does not support rasterizing PostScript Type 3 fonts,
TrueType fonts, and PostScript fonts that do not adhere to the Adobe Type 1 font specification.

PostScript Font Files
PostScript fonts are composed of two files:  a bitmap (screen) font and a PostScript outline
(printer) font file. Bitmap fonts are used to display the font on screen. Outline fonts are used for
printing and for display by ATM.

Bitmap Fonts
Bitmap fonts, also called screen fonts, provide bitmap representations of characters at specific
sizes for screen display, usually 10, 12, 14, 18, and 24 point sizes. They also contain kerning
information and information the system uses to display the font’s name in the font menus.

Bitmap fonts appear in the Finder as a dog-eared page with the letter “A,” and their filenames
include a point size (e.g., Times 10, Geneva 14). In System 7.1 or later, bitmap fonts are installed
in the Fonts folder in the System Folder. In System 7.0.x, bitmap fonts are installed in the System
suitcase in the System Folder.

Outline Fonts
PostScript outline fonts, also called printer fonts, contain mathematical descriptions in the
PostScript page description language for each character designed for the typeface.

Adobe PostScript outline font icons appear in the Finder as a letter “A” in front of horizontal lines.
Most PostScript font files are named using the first five characters of the font followed by the first
three characters of each style (e.g., HelveBol, CouriObl, Symbo, TimesBolIta), and do not include a
point size. In System 7.1 or later, outline fonts are installed in the Fonts folder in the System Folder.
In System 7.0.x, outline fonts are installed in the Extensions folder in the System Folder.
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TrueType Font Files
Unlike PostScript fonts, TrueType fonts consist of only one font file, used for both display and
printing. TrueType fonts icons display in the Finder as a dog-eared page with three letter “A”s in
progressively larger sizes, and their filenames do not include a point size. In System 7.1 or later,
TrueType fonts are installed in the Fonts folder in the System Folder.

When both the TrueType and PostScript version of a font are installed (e.g., Helvetica), ATM
may be unable to locate the PostScript font’s outline font file, causing jagged font display or
problems when printing. To avoid conflicts, remove the TrueType font file or the PostScript font
files from the System Folder.

ATM 3.9 and Earlier and PostScript Fonts General Information continued
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and Re-adding Fonts in ATM
Deluxe 4.0

To troubleshoot font display or printing problems when using ATM Deluxe 4.0, you may need
to remove all your installed fonts and reinstall them. Before you remove fonts, you may want to
export your sets so you can reimport them after re-adding the fonts, rather than recreating the
sets.

When you export sets, Adobe Type Manager (ATM) creates an ATM Font Set (AFS) file, which
contains a list of the fonts included in the sets and their font file locations. An AFS file can
contain information from one set or multiple sets. When you import a set, ATM confirms the
location of the font files. If you have installed your font files in another location or moved them,
you will need to specify the new location when importing a set.

To export your sets:
1. In ATM, click the Sets tab.
2. Select one or more sets to export.
3. Choose File > Export.
4. In the Export dialog box, specify a filename and location for the AFS file, then click Save.

To remove your fonts:
1. In the All Font Sets pane of the Sets tab, select the fonts you want to remove, then click

Remove.
2. In the Remove Font dialog box, select Remove Fonts from All Set and Master Font List,

select Remove Font Files from Disk if you are reinstalling your fonts from the original
installation disks, then click Yes or Yes to All.

To re-add your fonts:
1. Click the Add Fonts tab, then select Browse for Fonts from the Source pop-up menu.
2. Navigate to the drive and directory where your fonts files are located (e.g., C:\Psfonts\Pfm,

A:\Fontdisk).
3. Select the fonts you want to add from the Source pane scrollbox, then click Add.

To import your sets:
1. With Browse for Fonts still selected in the Source pop-up menu, navigate to the drive and

directory where your AFS file is located. ATM lists the sets you exported in the AFS file.
2. Select the sets you want to import, then click Add.
3. Remove any duplicate fonts outside your sets by selecting them and clicking Remove.
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Fonts in ATM Lite 4.0

To troubleshoot font display or printing problems when using Adobe Type Manager (ATM) Lite
4.0, you may need to remove all your installed fonts and reinstall them.

To remove your fonts:
1. In ATM, click the Fonts tab.
2. In the Fonts pane, select the fonts you want to remove, then click Remove.
3. In the Remove Font dialog box, select Remove Font Files from Disk if you are reinstalling

your fonts from the original installation disks, then click Yes or Yes to All.

To re-add your fonts:
1. In ATM, click the Fonts tab.
2. In the Fonts pane, select Browse for Fonts from the Source pop-up menu.
3. Navigate to the drive and directory where your fonts files are located (e.g., C:\Psfonts\Pfm,

A:\Fontdisk).
4. Select the fonts you want to add from the Source pane scroll box, then click Add.
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Fonts in ATM 3.0x

When troubleshooting a font problem with Adobe Type Manager (ATM) 3.0x, remove all your
fonts from ATM, then remove all font references from the Win.ini file and the Atm.ini file. Once
you’ve cleaned up the Win.ini file and the Atm.ini file, you can re-add your fonts to continue
troubleshooting.

To remove fonts from ATM:
1. In the ATM Control Panel, select all the installed fonts from the Installed ATM Fonts list.
2. Click Remove.
3. In the Remove Fonts dialog box, select No Confirmation to Remove Fonts if you don’t want

the dialog box to appear for each font you remove, then click Yes or Yes to All. Do not select
Delete Fonts from Disk unless you want to delete the font files from your system.

To remove font references from the Win.ini file:
1. Open the Win.ini file, located in the Windows directory, in a text editor that can save in text-

only format (e.g., Windows Write, WordPad).
2. Delete all lines that begin “softfont” (e.g., softfonts=20).
3. In Windows 95, delete all lines that refer to an MFD file (e.g.,

ADMFDFile=C:\Windows\Ad434af1.mfd).
4. Save the Win.ini file in text-only format.

To remove font references from the Atm.ini file:
1. Open the Atm.ini file, located in the Windows directory, in a text editor that can save in

text-only format (e.g., Windows Write, WordPad).
2. Delete any lines in the [Fonts] section (e.g., “Helvetica=C:\Psfonts\Pfm\Hv______.pfm;

C:\Psfonts\Hv______.pfb”).
3. Save the Atm.ini file in text-only format, then restart Windows.

To re-add fonts in ATM:
1. In the ATM Control Panel, click Add.
2. In the Add Fonts dialog box, locate the drive and directory where your fonts are located

(e.g., C:\Psfonts\Pfm, A:\Psfonts).
3. Select the fonts you want to install from the list of available fonts, then click Add.
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PostScript Font Display on the
Macintosh

What’s Covered
Overview of PostScript Fonts and ATM
Defining the Problem
Single or Several PostScript Fonts Display Jagged
All PostScript Fonts Display Jagged
Display Limitations

Adobe Type Manager (ATM) creates smooth display of PostScript fonts at any point size using
PostScript outline (printer) fonts. When ATM cannot display a PostScript font, the font displays
bitmapped (i.e., jagged) or text formatted with the font does not display.

A variety of causes can prevent ATM from displaying a PostScript font—the outline font file
may be damaged or unavailable (e.g., not installed, not in the expected location), or ATM may
be damaged or unable to locate one of its support files. To determine what’s preventing your
fonts from displaying smoothly, use the troubleshooting steps below.

Overview of PostScript Fonts and ATM
Before you begin troubleshooting, you should understand the difference between PostScript
Type 1 fonts and TrueType fonts.

PostScript fonts are composed of two files:  a bitmap (screen) font and a PostScript outline
(printer) font file. Bitmap fonts are used to display the font on screen. Outline fonts are used for
printing and for display by ATM.

PostScript bitmap font icons appear in the Finder as a dog-eared page with the letter “A,” and
their filenames include a point size (e.g., Times 10, Geneva 14). In System 7.1 or later, bitmap
fonts are installed in the Fonts folder in the System Folder. In System 7.0.x, bitmap fonts are
installed in the System suitcase in the System Folder.

Adobe PostScript outline font icons appear in the Finder as a letter “A” in front of horizontal
lines (outline fonts created by other companies may have different icons). Most PostScript font
files are named using the first five characters of the font followed by the first three characters of
each style (e.g., HelveBol, CouriObl, Symbo, TimesBolIta), and do not include a point size. In
System 7.1 or later, outline fonts are installed in the Fonts folder in the System Folder. In System
7.0.x, outline fonts are installed in the Extensions folder in the System Folder.

Unlike PostScript fonts, TrueType fonts consist of only one font file, used for both display and
printing. TrueType fonts icons display in the Finder as a dog-eared page with three letter “A”s in
progressively larger sizes, and their filenames do not include a point size. In System 7.1 or later,
TrueType fonts are installed in the Fonts folder in the System Folder.
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Without ATM, the system displays PostScript fonts by scaling the bitmap font file. Resizing a
bitmap font reproduces the general shape of the font, but may cause the font to display with
extreme pixelation (i.e., jagged), depending on the size of available bitmap font files and the
requested display size.

To prevent fonts from displaying with extreme pixelation, ATM rasterizes PostScript outline
fonts (i.e., converts outline font information into a scaleable bitmap image) to enable fonts to
display smoothly at any point size. ATM supports rasterizing PostScript fonts that adhere to the
Adobe Type 1 font specification. ATM does not support rasterizing PostScript Type 3 fonts,
TrueType fonts, and PostScript fonts that do not adhere to the Adobe Type 1 font specification.

Defining the Problem
The first step in troubleshooting jagged font display is to determine the exact symptoms of the
problem. Begin isolating the problem by applying another font to the text, then comparing how
different fonts display. Does only one PostScript font display jagged, do multiple PostScript font
display jagged, or do all PostScript  fonts display jagged?

If one or more PostScript font displays jagged, but others display smoothly, the problem may be
caused by a damaged font or unavailable font files. If all your PostScript fonts display jagged,
ATM is the most likely cause: it may be damaged or unable to locate one of its support files.

After determining the exact symptoms of your font display problem, you now have more clues
to narrow down the cause of your problem, and you can begin troubleshooting your exact
symptoms.

Single or Several PostScript Fonts Display Jagged
ATM cannot display a PostScript font smoothly when the printer font file is not installed, when
the font file or the Fonts folder is damaged, when ATM has an insufficient Font Cache, when
both the TrueType and PostScript version of the font are installed, or when an earlier version of
the font file is installed. Begin troubleshooting by first reinstalling the font, then recreating the
fonts folder, next increasing the Font Cache, then removing duplicate TrueType fonts, and
finally by updating your font file.

Reinstall the Font
Make sure the PostScript font is not damaged and ATM can locate it by removing the font and
reinstalling it from the original disks.

To reinstall a PostScript font in System 7.1 or later:
1. Quit all applications.
2. Open the Fonts folder in the System Folder.
3. Choose View > Select By Name.
4. Remove the outline and bitmap font files from the Fonts folder in the System Folder.
5. Reinstall the outline and bitmap font files from the original disks into the Fonts folder in the

System Folder.

To reinstall a PostScript font in System 7.0x:
1. Quit all applications.

Troubleshooting Jagged PostScript Font Display on the Macintosh continued
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2. Remove the PostScript outline fonts from the Extensions folder in the System Folder.
3. Remove bitmap font suitcases from the System suitcase in the System Folder.
4. Reinstall PostScript outline fonts from the original disks into the Extensions folder in the

System Folder.
5. Reinstall bitmap font suitcases from the original disks into the System suitcase in the System

Folder.

Recreate the Fonts Folder
If you’re using System 7.1 or later, the Fonts folder containing your fonts may be damaged,
preventing ATM from locating the outline font file. To make sure your Fonts folder is not
damaged, remove then recreate it.

To recreate the System 7.1 or later Fonts folder:
1. Move the Fonts folder from the System Folder to the desktop, then restart the Macintosh.

After the Macintosh restarts, a new, empty Fonts folder is created in the System Folder.
2. Move font files from the old Fonts folder into the new Fonts folder in the System Folder.

Increase the Font Cache
ATM’s Font Cache is an allotment of memory that ATM uses to store the fonts it has rasterized.
When the Font Cache is too small to create or display a font, the font displays bitmapped or
does not display.

ATM’s default Font Cache size is 256K. You should increase the size of the Font Cache to 512K
or more when your documents include a multiple master typeface (e.g., Jenson, Ex Ponto,
Tekton) or more than four typefaces on a page. To change the size of the Font Cache, click the
up or down arrows for the Font Cache in the ATM control panel, then restart your Macintosh.

Remove TrueType Font Files
If both the TrueType and PostScript version of a font are installed (e.g., Helvetica), ATM may be
unable to locate the font’s outline font file.

To determine if the TrueType version of the font is installed, open the folder or suitcase contain-
ing the font, then compare files. Your PostScript bitmap font files include a number (e.g., point
size) in their filenames—those filenames without numbers are your TrueType font files. When
you view the files by icon (choose View > by Icon), TrueType fonts display as dog-eared page
with three letter “A”s. If you have both the TrueType and PostScript version of your font in-
stalled, remove the TrueType font.

Update the Font Files
ATM 3.8.x and later include an updated rasterizer for rendering fonts to the screen. To work
with ATM 3.8.x’s updated rasterizer, PostScript Type 1 fonts must adhere to the Type 1 font
specification. Some earlier Type 1 fonts do not adhere to the most recent version of the Type 1
font specification, causing them to display bitmapped on screen when ATM 3.8.x or later is
installed. Additionally, some fonts that do adhere to the PostScript Type 1 font specification may
display more bitmapped with ATM 3.8.x than with ATM 3.6.x, because of ATM 3.8.x and later’s
updated rasterizer.

Troubleshooting Jagged PostScript Font Display on the Macintosh continued
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If you’re using ATM 3.8.x or later, obtain an updated version of your font from the font’s
manufacturer to ensure it adheres to the latest Type 1 font specification.

ATM 3.6.x and earlier can create smooth display of fonts that do not adhere to the Type 1 font
specification.

All PostScript Fonts Display Jagged
When all your PostScript fonts display jagged, ATM itself is your most likely culprit. ATM
cannot display PostScript fonts when it is disabled, has an insufficient Font Cache, is damaged,
or is conflicting with another font utility. Begin troubleshooting ATM by ensuring it is turned
on, then disabling other font utilities and extensions, next reinstalling ATM, and finally increas-
ing the Font Cache.

Make Sure ATM Is Active
Make sure ATM is active by selecting On in the ATM control panel, then restarting your
Macintosh. When ATM is enabled, the message “ATM is active” displays under the Off option in
the ATM control panel.

Disable Other Font Utilities and Extensions
Other font management or rasterizing utilities (e.g., Symantec Suitcase) may prevent ATM from
loading or locating outline fonts. You can determine if a conflict with other font utilities is the
cause of your problem by disabling them and installing your fonts into the System Folder, or by
removing each utility from the System Folder (e.g., remove the Suitcase extension from the
Extensions folder), then restarting your Macintosh. For instructions on installing PostScript
fonts, see Reinstall the PostScript Font above.

If, after disabling your font utilities, your fonts still display bitmapped, disable all added exten-
sions. Other extensions may prevent ATM from loading or interfere with ATM’s ability to locate
outline font files. Use an extensions manager to disable all extensions and control panels except
ATM, or remove all extensions and control panels from the System Folder except ATM, then
restart your Macintosh.

Reinstall ATM
When ATM is damaged, it may be unable to read, rasterize, or display PostScript fonts. To make
sure ATM isn’t damaged, reinstall it after first disabling all extensions to prevent them from
interfering with the installation.

Increase the Font Cache
ATM’s Font Cache is an allotment of memory that ATM uses to store the fonts it has rasterized.
When the Font Cache is too small to create or display a font, the font displays bitmapped or
does not display.

ATM’s default Font Cache size is 256K. You should increase the size of the Font Cache to 512K
or more when your documents include a multiple master typeface (e.g., Jenson, Ex Ponto,
Tekton) or more than four typefaces on a page. To change the size of the Font Cache, click the
up or down arrows for the Font Cache in the ATM control panel, then restart your Macintosh.

Troubleshooting Jagged PostScript Font Display on the Macintosh continued
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Display Limitations
The smoothness with which ATM can display a font is limited by the resolution of your monitor.
Because the resolution of most monitors (e.g., 70 to 85 dpi) is much lower than that of most
PostScript printers (e.g., 300 dpi, 600 dpi), fonts print smoother to PostScript printers than they
display. Fonts with elaborate curved edges or delicate character strokes (e.g., Eras, Boulevard,
Bauhaus, script fonts) appear more jagged than fonts with milder curves and heavier character
strokes (e.g., Helvetica, Palatino).

To determine if your fonts display bitmapped because of their design or your monitor’s resolu-
tion, compare the smoothness of your font to similar curves of an object, or compare the font
display with ATM turned on and off. If the curves of a font character and an object display with
the same amount of jaggedness, or if the font’s jaggedness increases substantially when you turn
off ATM, then ATM is displaying the font as smoothly as possible on your monitor. You can
make the fonts display more smoothly by increasing the resolution of your monitor, or by
viewing your fonts at a higher magnification.

Compare Text to a Curved Line
1. In an application that creates curved PostScript paths (e.g., Adobe PageMaker, Adobe

Illustrator), apply a PostScript font to the “O” character.
2. Draw an ellipse or a curved path whose shape and line weight emulates the curve of the

character next to the text block.
3. Compare the jaggedness of the curves in the drawn object to that of the font character.

Compare Font Display with ATM Enabled and Disabled
1. In application that supports large point sizes (e.g., Adobe PageMaker, Adobe Illustrator 6.0),

create 150-point text and apply the PostScript font (e.g., Anna) in a new document, then
save the document.

2. Compare the smoothness of the font when ATM is enabled and disabled. To disable ATM,
select Off in the ATM control panel, then restart your Macintosh.

Increase the Resolution Setting of Your Monitor
If you’re using a monitor that supports different resolution settings, select a higher resolution
setting (e.g., select 1024 x 768) by clicking Options in the Monitors control panel.

Troubleshooting Jagged PostScript Font Display on the Macintosh continued
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PostScript Font Display with
ATM 4.0 in Windows 95

What’s Covered
Overview of PostScript Fonts and ATM
Display Limitations
Making Sure ATM is Active
Defining the Problem
Removing All Fonts and Font References
Re-adding Fonts in ATM
Troubleshooting Jagged Font Display After You’ve Removed and Reinstalled Fonts

Adobe Type Manager Deluxe (ATM) 4.0 creates smooth display of PostScript fonts at any point
size using the PostScript font’s outline (printer) font file. When ATM cannot display a PostScript
font, the font displays bitmapped (i.e., jagged) or text to which the font is applied does not
display.

There are a variety of reasons that ATM might be unable to display a PostScript font—the
outline font file may be damaged or unavailable (e.g., not installed, not in the expected loca-
tion), or ATM may be damaged or unable to locate one of its support files. To determine what’s
preventing your fonts from displaying smoothly, use the troubleshooting steps below.

Overview of PostScript Fonts and ATM
Before you begin troubleshooting, you should understand the difference between PostScript
Type 1 fonts and TrueType fonts.

PostScript Type 1 fonts are composed of two files: a Printer Font Metrics (PFM) file and a
Printer Font Binary (PFB) file. Multiple master base fonts and instances use a Multiple Master
Metrics (MMM) file instead of a PFM file, and multiple master instances use a PostScript
Printer Stub (PSS) file instead of a PFB file.

PFM and MMM files, located in the Psfonts\Pfm subdirectory, are used to display the font on
screen. PFB (or “outline”) and PSS files, located in the Psfonts directory, are used for printing
and by ATM to display fonts smoothly on screen.

Unlike PostScript fonts, TrueType fonts consist of only one font file, used for both display and
printing.

Without ATM, Windows displays PostScript fonts by scaling the PFM (or “bitmap”) file.
Resizing a bitmap font reproduces the general shape of the font, but may cause the font to
display with extreme pixelation (i.e., jagged edges), depending on the size of available bitmap
font files and the requested display size.
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To prevent fonts from displaying with extreme pixelation, ATM rasterizes (i.e., converts outline
font information into a scaleable bitmap image) PostScript PFB files, which enables the fonts to
display smoothly at any point size. ATM can rasterize PostScript Type 1 fonts that adhere to the
Adobe Type 1 font specification. ATM cannot rasterize PostScript Type 3 fonts, TrueType fonts,
and PostScript fonts that do not adhere to the Adobe Type 1 font specification.

In addition to rasterizing fonts, ATM 4.0 can further smooth on-screen font edges using anti-
aliasing (i.e., blending colors along an edge).

Display Limitations
The smoothness with which ATM can display a font is limited by the resolution of your monitor.
Because the resolution of most monitors (e.g., 70 to 85 dpi) is much lower than that of most
PostScript printers (e.g., 300 dpi, 600 dpi), fonts print smoother to PostScript printers than they
display. Fonts with elaborate curved edges or delicate character strokes (e.g., Eras, Boulevard,
Bauhaus, script fonts) appear more jagged than fonts with milder curves and heavier character
strokes (e.g., Helvetica, Palatino).

To compensate for limited monitor resolution, you can enable ATM 4.0’s Smooth Font Edges
On Screen option (i.e., anti-aliasing). When enabling the Smooth Font Edges On Screen option
improves PostScript font display, ATM is displaying the fonts as smoothly as possible on your
monitor. If enabling the Smooth Font Edges On Screen option does not smooth PostScript font
display, move to the Making Sure ATM Is Active section.

To determine if your fonts display bitmapped because of their design or your monitor’s resolu-
tion when ATM’s Smooth Font Edges On Screen option is not enabled, compare the smoothness
of your font on screen to similar curves of an object, when ATM is disabled, or when displayed
on a high-resolution monitor. If the curves of a font character and an object display with the
same amount of jaggedness, or if a font’s jaggedness increases substantially when ATM is
disabled, ATM is displaying the font as smoothly as possible on your monitor. You can enable
fonts to display smoother by increasing the resolution of your monitor, or by viewing your fonts
at a higher magnification.

Compare Text to a Curved Line
1. In an application that creates curved PostScript paths (e.g., Adobe PageMaker, Adobe

Illustrator), apply the PostScript font to the “O” character.
2. Draw an ellipse or a curved path whose shape and line weight emulates the curve of the

character next to the text block.
3. Compare the jaggedness of the curves in the drawn object to that of the font character.

Compare Font Display with ATM Enabled and Disabled
1. In application that supports large point sizes (e.g., Adobe PageMaker, Adobe Illustrator 6.0),

create 150-point text and apply the PostScript font (e.g., Anna) in a new document, then
save the document.

2. Compare the smoothness of the font when ATM is enabled and disabled. To disable ATM,
select Off in ATM, then restart Windows.

Troubleshooting Jagged PostScript Font Display with ATM 4.0 in Windows 95
continued
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Enabling ATM’s Font Smoothing
1. In ATM, click the Settings tab, then click Advanced.
2. In the Advanced Settings dialog box, select the Smooth Font Edges on Screen option, then

click OK.

Increase the Resolution Setting of Your Monitor
When using a monitor that supports different resolution settings, select a higher resolution
monitor setting (e.g., select 1024 x 768) in the Display Control Panel.

Making Sure ATM is Active
Your first step in troubleshooting jagged PostScript font display in Windows is to determine if
ATM is active. PostScript fonts added in ATM will display jagged when ATM is turned off.

To make sure ATM is active, open ATM by choosing Start > Programs > Adobe > Adobe Type
Manager Deluxe. In ATM, choose Help > About Adobe Type Manager. When ATM is active, the
About windows displays the current Dynamic Link Library (DLL) file version number in the
“DLL” line. If ATM is active, move to the Defining the Problem section.

When ATM is inactive, About windows displays “ATM System is inactive.” in the “DLL” line. To
activate ATM, do one or more of the following:

A. Turn ATM on. If ATM is set to Off, click the Settings tab, select On in the ATM System
section, exit ATM, and restart Windows. Then reopen ATM to see if it is active.

B. Make sure all the ATM files are installed. The ATM Installer installs files into the Psfonts,
Windows, and Windows\System directories. Make sure the following file is installed in the
Psfonts directory:

Atmfm.exe

Make sure the following files are installed in the Windows directory:
Atmreg.atm
Atm.ini
Make sure the following files are installed in the Windows\System directory:
Atm32.dll
Atmsys.drv

If any of these files is missing, or if some of your files have a different extension (e.g., *.ndl
instead of *.dll), exit Windows, delete the installed ATM files, and reinstall ATM from
the original installation disks.

C. Make sure ATM is referenced in the System.ini file. In addition to adding files to the Psfonts,
Windows and Windows\System directories, the ATM installer modifies the System.ini file so
that ATM is loaded when you start Windows. Make sure the System.ini contains the correct
ATM information:
1. Open the System.ini file, located in the Windows directory, in a text editor that can save

in text-only format (e.g., Windows Write).

Troubleshooting Jagged PostScript Font Display with ATM 4.0 in Windows 95
continued
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2. In the [Boot] section, modify the line:

system.drv=system.drv

to read:

system.drv=atmsys.drv

3. In the [Boot] section, add the line:

atm.system.drv=system.drv

4. Save the System.ini file in text-only format, then restart Windows.
D. Reinstall ATM from the CD-ROM. If ATM is installed correctly, it will be loaded and active

when you start Windows.

Defining the Problem
Once you’ve made sure ATM is active, your next step is to determine the extent of the problem.
Because you’ll be removing all your installed ATM fonts in the next section and you won’t have
fonts installed to test with, it’s important you define the problem completely before you begin
troubleshooting.

Begin isolating the problem by applying another font, and then comparing how different fonts
display. Does only one PostScript font display jagged, do multiple PostScript font display jagged,
or do all PostScript fonts display jagged?

When one or more PostScript font displays jagged, but others display smoothly, the problem
may be caused by a damaged font, or unavailable font files. When all your PostScript fonts
display jagged, ATM is the most likely cause; it may be damaged or unable to locate one of its
support files.

Before troubleshooting your fonts or ATM, follow the steps in the Removing All Fonts and Font
References section to remove old font information.

Removing All Fonts and Font References
Once you have determined the extent of the problem, your next step is to do some general
Windows font troubleshooting by removing all your fonts from ATM, then removing all font
references from the Win.ini file and the Atm.ini file. Before you remove fonts, you may want to
export your sets so you can reimport them after re-adding the fonts, rather than recreating the
sets. Once you’ve cleaned up the Win.ini file and the Atm.ini file, you’ll re-add your fonts a few
at a time to continue troubleshooting.

Remove All Installed ATM Fonts

To export your sets:
1. In ATM, click the Sets tab.
2. Select one or more sets to export.

Troubleshooting Jagged PostScript Font Display with ATM 4.0 in Windows 95
continued
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3. Choose File > Export.
4. In the Export dialog box, specify a filename and location for the AFS file, then click Save.

To remove your fonts:
1. In the All Font Sets pane of the Sets tab, select the fonts you want to remove, then click

Remove.
2. In the Remove Font dialog box, select Remove Fonts from All Set and Master Font List,

select Remove Font Files from Disk if you are reinstalling your fonts from the original
installation disks, then click Yes or Yes to All.

Remove Font References in the Win.ini File
1. Open the Win.ini file, located in the Windows directory, in a text editor that can save in text-

only format (e.g., NotePad, Windows Write).
2. Delete all lines that begin “softfont” (e.g., softfonts=20).
3. In Windows 95, delete all lines that refer to an MFD file (e.g.,

ADMFDFile=C:\WINDOWS\AD434AF1.MFD).
4. Save the Win.ini file in text-only format.

Remove Font References in the Atm.ini File
1. Open the Atm.ini file, located in the Windows directory, in a text editor that can save in

text-only format (e.g., Windows Write).
2. Delete any lines in the [Fonts] section (e.g., “Helvetica=C:\Psfonts\Pfm\Hv______.pfm;

C:\Psfonts\Hv______.pfb”).
3. Save the Atm.ini file in text-only format, then restart Windows.

Re-adding Fonts in ATM
Now that you’ve removed your fonts and the references to them in your system files, install fresh
copies of the fonts into ATM using the original font disks. To start, add just a few fonts.

If only some of your fonts display jagged, add just those. If all your fonts display jagged, start by
adding just five fonts. Once you have solved the problem, you can add the remaining fonts.

To re-add your fonts:
1. Click the Add Fonts tab, then select Browse for Fonts from the Source pop-up menu.
2. Navigate to the drive and directory where your fonts files are located (e.g., C:\Psfonts\Pfm,

A:\Fontdisk).
3. Select the fonts you want to add from the Source pane scroll box then click Add.

To import your sets:
1. With Browse for Fonts still selected in the Source pop-up menu, navigate to the drive and

directory where your AFS file is located. ATM lists the sets you exported in the AFS file.
2. Select the sets you want to import, then click Add.
3. Remove any duplicate fonts outside your sets by selecting them and clicking Remove.

Re-adding fonts may enable ATM to display them as expected. If your fonts do not display
correctly after re-adding them, move to the Troubleshooting Jagged Font Display After You’ve
Removed and Reinstalled Fonts section.

Troubleshooting Jagged PostScript Font Display with ATM 4.0 in Windows 95
continued
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Troubleshooting Jagged Font Display After You’ve Removed and
Reinstalled Fonts
ATM is unable to display a PostScript font smoothly on screen when:

- The font’s PFB file is not installed.
- The font file is damaged.
- ATM has an insufficient Font Cache.
- Both the TrueType and PostScript version of the font are installed.
- An earlier version of the font file is installed.
- The Atmfonts.qlc file is damaged.
- Other font utilities prevent ATM from locating a font’s outline font files.
- ATM is damaged.

Begin troubleshooting by first reinstalling the font or fonts that display jagged. Then, increase
the Font Cache, remove TrueType versions of installed PostScript fonts, and update to current
versions of your font files. If fonts still display jagged after doing those steps, continue by
deleting any Atmfonts.qlc files and disabling other font utilities. As a last resort, reinstall ATM.

Make Sure PFM and PFB Files Are Installed
ATM copies font files into the C:\Psfonts and C:\Psfonts\Pfm directories by default. Check those
directories to make sure a PFM file and a PFB file are installed for each font. For example, for
the font Helvetica, make sure the Hv______.pfb file is located in the C:\Psfonts directory and
the Hv______.pfm file is located in the C:\Psfonts\Pfm directory.

Font filename prefixes often do not resemble the font’s actual name (e.g., Akzidenz Grotesk font
files begin with GF, Centaur font files begin with NR). See the document Fntnames.pdf on the
Type On Call CD-ROM for a complete listing of Adobe font filenames.

Increase the Font Cache
ATM’s Font Cache is an allotment of memory that ATM uses to store the fonts it has rasterized.
When the Font Cache’s size is insufficient to create or display a font, the font displays bitmapped
or does not display at all.

To change the size of the Font Cache, click the Settings tab, click the up or down arrow for the
Font Cache, then restart Windows. ATM’s default Font Cache size is 256K. Increase the size of
the Font Cache to 512K or more when using a multiple master typeface (e.g., Jenson, Ex Ponto,
Tekton) or more than four typefaces in a document.

Remove TrueType Font Files

When both the TrueType and PostScript version of a font are installed (e.g., Helvetica), ATM
may be unable to locate the PostScript font’s outline font file. Make sure only the PostScript
version of the font is installed. To remove TrueType fonts installed in ATM:
1. In the All Font Sets pane of the Sets tab, select the fonts you want to remove, then click

Remove.
2. In the Remove Font dialog box, select Remove Fonts from All Sets and Master Font List,

select Remove Font Files from Disk if desired, then click Yes or Yes to All.

Troubleshooting Jagged PostScript Font Display with ATM 4.0 in Windows 95
continued
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Update the Font Files
ATM 4.0 includes an updated rasterizer for rendering smooth fonts to the screen. To work with
ATM 4.0’s updated rasterizer, PostScript Type 1 fonts must adhere to the Type 1 font specifica-
tion. Some earlier Type 1 fonts (e.g., fonts created in 1988 or earlier) do not adhere to the most
recent version of the Type 1 font specification, causing them to display bitmapped on screen
when ATM 4.0 is installed. When ATM 4.0 or later is installed, some fonts that do adhere to the
PostScript Type 1 font specification may display more bitmapped than when ATM 3.0x and
earlier is installed because of the ATM 4.0’s updated rasterizer.

When using ATM 4.0, obtain an updated version of your font from the font’s manufacturer to
ensure your font adheres to the latest Type 1 font specification.

Delete All Atmfonts.qlc Files
The Atmfonts.qlc file contains rasterization information on the last several fonts used, enabling
ATM to rasterize fonts more quickly. When the Atmfonts.qlc file becomes damaged or multiple
Atmfonts.qlc files are present on the system, ATM may be unable to rasterize fonts as expected.

When you delete the Atmfonts.qlc file, ATM creates a new one the next time you launch Win-
dows. The file is located in the Psfonts directory by default, but duplicates may exist in other
locations. You can search for and delete every Atmfonts.qlc file using the Windows Explorer.

Disable Other Font Utilities
Other font management or rasterizing utilities (e.g., FontMinder) may prevent ATM from
loading or locating a font’s outline font files. Make sure ATM is not conflicting with other font
utilities by disabling them and installing your fonts in ATM.

Reinstall ATM
When ATM is damaged it may be unable to load or display a PostScript font. To make sure ATM
isn’t damaged, reinstall it from the original disks.

Troubleshooting Jagged PostScript Font Display with ATM 4.0 in Windows 95
continued
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PostScript Font Display with
ATM 3.0x in Windows

What’s Covered
Overview of PostScript Fonts and ATM
Making Sure ATM is Active
Defining the Problem
Removing All Fonts and Font References
Re-adding Fonts in the ATM Control Panel
Troubleshooting Jagged Font Display After You’ve Removed and Reinstalled Fonts
Display Limitations

Adobe Type Manager (ATM) 3.0x creates smooth display of PostScript fonts at any point size
using the PostScript font’s outline (printer) font file. When ATM cannot display a PostScript
font, the font displays bitmapped (i.e., jagged) or text formatted with the font does not display.

A variety of causes can prevent ATM from displaying a PostScript font—the outline font file
may be damaged or unavailable (e.g., not installed, not in the expected location), or ATM may
be damaged or unable to locate one of its support files. To determine what’s preventing your
fonts from displaying smoothly, use the troubleshooting steps below.

Overview of PostScript Fonts and ATM
Before you begin troubleshooting, you should understand the difference between PostScript
Type 1 fonts and TrueType fonts.

PostScript Type 1 fonts are composed of two files: a Printer Font Metrics (PFM) file and a
Printer Font Binary (PFB) file. Multiple master base fonts and instances use a Multiple Master
Metrics (MMM) file instead of a PFM file, and a multiple master instance creates a PostScript
Printer Stub (PSS) file.

PFM and MMM files, located in the Psfonts\Pfm subdirectory, are used to display the font on
screen. PFB (or “outline”) and PSS files, located in the Psfonts directory, are used for printing
and by ATM to display fonts smoothly on screen.

Unlike PostScript fonts, TrueType fonts consist of only one font file, used for both display and
printing. You can install and remove TrueType fonts in the Fonts Control Panel.

Without ATM, Windows displays PostScript fonts by scaling the PFM file. Resizing a bitmap
font reproduces the general shape of the font, but may cause the font to display with extreme
pixelation (i.e., jagged), depending on the size of available bitmap font files and the requested
display size. TrueType fonts, on the other hand, display smoothly at any point size.

To PostScript prevent fonts from displaying with extreme pixelation, ATM rasterizes (i.e.,
converts outline font information into a scaleable bitmap image) PostScript PFB files. ATM
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supports rasterizing PostScript Type 1 fonts that adhere to the Adobe Type 1 font specification.
ATM does not support rasterizing PostScript Type 3 fonts, TrueType fonts, and PostScript fonts
that do not adhere to the Adobe Type 1 font specification.

Making Sure ATM Is Active
Your first step in troubleshooting jagged PostScript font display in Windows is to determine if
ATM is active. PostScript fonts added in ATM will display jagged when ATM is turned off.

To make sure ATM is active, open the ATM Control Panel by choosing Start > Programs > Main
(Windows 95) or by double-clicking the ATM Control Panel icon in the Main Group in Pro-
gram Manager (Windows 3.1x). When ATM is active, the ATM version (e.g., 3.02) displays in
the upper left corner of the ATM Control Panel. If ATM is active, move to the Defining the
Problem section.

When ATM is inactive, “Inactive” displays instead of the version number. To activate ATM, do
one or more of the following:
A. Select On, exit the ATM Control Panel, and restart Windows. Then reopen the ATM Control

Panel to see if ATM is active.
B. Make sure all the ATM files are installed. The ATM Installer installs files into the Windows

and the Windows\System directories. Make sure the following files are installed in the
Windows directory:

Atmcntrl.exe
Atm.ini
Make sure the following files are installed in the Windows\System subdirectory:
Atm32.dll
Atm16.dll
Atmsys.drv

If any of these files is missing, or if some of your files have a different extension (e.g., *.ndl
instead of *.dll), exit Windows, delete the installed ATM files, and reinstall ATM from the
original installation disks.

C. Make sure ATM is referenced in the System.ini file. In addition to adding files to the Win-
dows and Windows\System directories, the ATM installer modifies the System.ini file so that
ATM is loaded when you start Windows. Make sure the System.ini contains the correct ATM
information:
1. Open the System.ini file, located in the Windows directory, in a text editor that can save

in text-only format (e.g., Windows Write).
2. In the [Boot] section, modify the line:

system.drv=system.drv

to read:

system.drv=atmsys.drv

Troubleshooting Jagged PostScript Font Display with ATM 3.0x in Windows
continued
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3. In the [Boot] section, add the line:

atm.system.drv=system.drv

4. Save the System.ini file in text-only format, then restart Windows.
D. Reinstall ATM from the original installation disks. When ATM is installed correctly, it is

loaded and active when you start Windows.

Defining the Problem
Once you’ve made sure ATM is active, your next step is to determine the extent of the problem.
Because you’ll be removing all your installed ATM fonts in the next section and you won’t have
fonts installed to test with, it’s important you define the problem completely before you begin
troubleshooting.

Begin isolating the problem by applying another font, and then comparing how different fonts
display. Does only one PostScript font display jagged, do multiple PostScript font display jagged,
or do all PostScript  fonts display jagged?

If one or more PostScript font displays jagged, but others display smoothly, the problem may be
caused by a damaged font, or unavailable font files. If all your PostScript fonts display jagged,
ATM is the most likely cause; it may be damaged or unable to locate one of its support files.

Before troubleshooting your fonts or ATM, follow the steps in the Removing All Fonts and Font
References section to remove old font information.

Removing All Fonts and Font References
Once you have determined the extent of the problem, your next step is to do some general
Windows font troubleshooting by removing all your fonts from ATM, then removing all font
references from the Win.ini file and the Atm.ini file. Once you’ve cleaned up the Win.ini file and
the Atm.ini file, you’ll re-add your fonts a few at a time to continue troubleshooting.

Remove All Installed ATM Fonts
Font troubleshooting includes a clean installation of fonts. Remove your old fonts from ATM
first:
1. In the ATM Control Panel, select all the installed fonts from the Installed ATM Fonts list.
2. Click Remove.
3. In the Remove Fonts dialog box, select No Confirmation to Remove Fonts if you don’t want

the dialog box to appear for each font you remove, then click Yes or Yes to All. Do not select
Delete Fonts from Disk unless you want to delete the font files from your system.

Remove Font References in the Win.ini File
1. Open the Win.ini file, located in the Windows directory, in a text editor that can save in text-

only format (e.g., NotePad, Windows Write).
2. Delete all lines that begin “softfont” (e.g., softfonts=20).
3. In Windows 95, delete all lines that refer to an MFD file (e.g.,

ADMFDFile=C:\Windows\Ad434af1.mfd).
4. Save the Win.ini file in text-only format.

Troubleshooting Jagged PostScript Font Display with ATM 3.0x in Windows
continued
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Remove Font References in the Atm.ini File
1. Open the Atm.ini file, located in the Windows directory, in a text editor that can save in

text-only format (e.g., Windows Write).
2. Delete any lines in the [Fonts] section (e.g., “Helvetica=C:\Psfonts\Pfm\Hv______.pfm;

C:\Psfonts\Hv______.pfb”).
3. Save the Atm.ini file in text-only format, then restart Windows.

Readding Fonts in the ATM Control Panel
Now that you’ve removed your fonts and the references to them in your system files, install fresh
copies of the fonts into the ATM Control Panel using the original font disks. To start, add just a
few fonts.

If only some of your fonts display jagged, add just those. If all your fonts display jagged, start by
adding just five fonts. Once you have solved the problem, you can add the remaining fonts.

To add fonts in ATM in the ATM Control Panel:
1. In the ATM Control Panel, click Add.
2. In the Add Fonts dialog box, locate the drive and directory where your fonts are located

(e.g., C:\Psfonts\Pfm, A:\Psfonts).
3. Select the fonts you want to install from the list of available fonts, then click Add.
Re-adding fonts may enable ATM to display them as expected. If your fonts do not display
correctly after re-adding them, move to the Troubleshooting Jagged Font Display After You’ve
Removed and Reinstalled Fonts section.

Troubleshooting Jagged Font Display After You’ve Removed and
Reinstalled Fonts

ATM cannot display a PostScript font smoothly on screen when:
- the font’s PFB file is not installed
- the font file is damaged
- ATM has an insufficient Font Cache
- both the TrueType and PostScript version of the font are installed
- an earlier version of the font file is installed
- the Atmfonts.qlc file is damaged
- other font utilities prevent ATM from locating a font’s outline font files
- ATM is damaged

Begin troubleshooting by first reinstalling the font or fonts that display jagged. Then, increase
the Font Cache, remove TrueType versions of installed PostScript fonts, and update to current
versions of your font files. If fonts still display jagged after doing those steps, continue by
deleting any Atmfonts.qlc files and disabling other font utilities. As a last resort, reinstall ATM.

Make Sure PFM and PFB Files Are Installed
ATM copies font files into the C:\Psfonts and C:\Psfonts\Pfm directories by default. Check those
directories to make sure a PFM file and a PFB file are installed for each font. For example, for
the font Helvetica, make sure the Hv______.pfb file is located in the C:\Psfonts directory and
the Hv______.pfm file is located in the C:\Psfonts\Pfm directory.

Troubleshooting Jagged PostScript Font Display with ATM 3.0x in Windows
continued
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Font filename prefixes often do not resemble the font’s actual name (e.g., Akzidenz Grotesk font
files begin with GF, Centaur font files begin with NR). See the document Fntnames.pdf on the
Type On Call CD-ROM for a complete listing of Adobe font filenames.

Increase the Font Cache
ATM’s Font Cache is an allotment of memory that ATM uses to store the fonts it has rasterized.
When the Font Cache’s size is insufficient to create or display a font, the font displays bitmapped
or does not display at all.

To change the size of the Font Cache, click the up or down arrow for the Font Cache in the ATM
Control Panel, then restart Windows. ATM’s default Font Cache size is 256K. Increase the size of
the Font Cache to 512K or more when you use a multiple master typeface (e.g., Jenson, Ex
Ponto, Tekton) or more than four typefaces in a document.

Remove TrueType Font Files
When both the TrueType and PostScript version of a font are installed (e.g., Helvetica), ATM
may be unable to locate the PostScript font’s outline font file. Make sure only the PostScript
version of the font is installed. Add and remove the TrueType versions of your PostScript fonts
using the Fonts Control Panel.

Update the Font Files
ATM 3.0x and later include an updated rasterizer for rendering smooth fonts to the screen. To
work with ATM 3.0x’s updated rasterizer, PostScript Type 1 fonts must adhere to the Type 1 font
specification. Some earlier Type 1 fonts (e.g., fonts created in 1988 or earlier) do not adhere to
the most recent version of the Type 1 font specification, causing them to display bitmapped on
screen when ATM 3.0x or later is installed. When ATM 3.0x or later is installed, some fonts that
do adhere to the PostScript Type 1 font specification may display more bitmapped than when
ATM 2.6 and earlier is installed because of the ATM 3.0x and later’s updated rasterizer.

When using ATM 3.0x or later, obtain an updated version of your font from the font’s manufac-
turer to ensure your font adheres to the latest Type 1 font specification.

ATM 2.6 and earlier do not require PostScript Type 1 fonts that adhere to the Type 1 font
specification for smooth screen display.

Delete All Atmfonts.qlc Files
The Atmfonts.qlc file contains rasterization information on the last several fonts used, enabling
ATM to rasterize fonts more quickly. When the Atmfonts.qlc file becomes damaged or multiple
Atmfonts.qlc files are present on the system, ATM may be unable to rasterize fonts as expected.

When you delete the Atmfonts.qlc file, ATM creates a new one the next time you launch Win-
dows. The file is located in the Psfonts directory by default, but duplicates may exist in other
locations. You can search for and delete every Atmfonts.qlc file using the Windows Explorer
(Windows 95) or File Manager (Windows 3.1x).

Troubleshooting Jagged PostScript Font Display with ATM 3.0x in Windows
continued
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Disable Other Font Utilities
Other font management or rasterizing utilities (e.g., FontMinder) may prevent ATM from
loading or locating a font’s outline font files. Make sure ATM is not conflicting with other font
utilities by disabling them and installing your fonts in ATM.

Reinstall ATM
When ATM is damaged it may be unable to load or display a PostScript font. To make sure ATM
isn’t damaged, reinstall it from the original disks.

Display Limitations
The smoothness with which ATM can display a font is limited by the resolution of your monitor.
Because the resolution of most monitors (e.g., 70 to 85 dpi) is much lower than that of most
PostScript printers (e.g., 300 dpi, 600 dpi), fonts print smoother to PostScript printers than they
display. Fonts with elaborate curved edges or delicate character strokes (e.g., Eras, Boulevard,
Bauhaus, script fonts) appear more jagged than fonts with milder curves and heavier character
strokes (e.g., Helvetica, Palatino).

To determine if your fonts display bitmapped because of their design or your monitor’s resolu-
tion, compare the smoothness of your font on-screen to similar curves of an object, when ATM
is disabled, or when displayed on a high-resolution monitor. If the curves of a font character and
an object display with the same amount of jaggedness, or if a font’s jaggedness increases sub-
stantially when ATM is disabled, ATM is displaying the font as smoothly as possible on your
monitor. You can enable fonts to display smoother by increasing the resolution of your monitor,
or by viewing your fonts at a higher magnification.

Compare Text to a Curved Line
1. In an application that creates curved PostScript paths (e.g., Adobe PageMaker, Adobe

Illustrator), apply the PostScript font to the “O” character.
2. Draw an ellipse or a curved path whose shape and line weight emulates the curve of the

character next to the text block.
3. Compare the jaggedness of the curves in the drawn object to that of the font character.

Compare Font Display with ATM Enabled and Disabled
1. In application that supports large point sizes (e.g., Adobe PageMaker, Adobe Illustrator 6.0),

create 150-point text and apply the PostScript font (e.g., Anna) in a new document, then
save the document.

2. Compare the smoothness of the font when ATM is enabled and disabled. To disable ATM,
select Off in the ATM Control Panel, then restart Windows.

Increase the Resolution Setting of Your Monitor
When using a monitor that supports different resolution settings, select a higher resolution
monitor setting (e.g., select 1024 x 768) in the Display Control Panel.

Troubleshooting Jagged PostScript Font Display with ATM 3.0x in Windows
continued
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Unavailable in Windows NT
4.x or Earlier

Issue
After you install Adobe Type Manager (ATM) 3.0x or earlier in Windows NT 4.x or earlier, the
ATM Control Panel displays the message “Version: ATM Inactive” instead of ATM’s version
number (e.g., 3.02). The Control Panel’s Installed ATM Fonts scroll box may list installed fonts,
but those fonts do not list in application font menus.

Solutions
Upgrade to ATM Deluxe 4.0 for Windows NT.

OR: Install PostScript Type 1 fonts in Windows NT by adding them using the Fonts Control
Panel, which converts them to TrueType fonts.

DISCLAIMER: Adobe Technical Support does not support the Windows NT Fonts Control
Panel’s conversion procedure or PostScript Type 1 fonts you have converted to TrueType fonts
using the Windows NT Fonts Control Panel. Refer to the Windows NT System Guide or contact
Microsoft Windows NT Technical Support for assistance.

Additional Information
ATM 3.0x and earlier is not compatible with Windows NT 4.x and earlier. When you install
ATM in Windows NT 4.x or earlier, ATM appears to install, but the ATM Control Panel is
inactive and added fonts do not display in application font menus.

You can use PostScript Type 1 fonts in Windows NT by adding them using the Fonts Control
Panel. When you install PostScript fonts using the Fonts Control Panel, the Control Panel
converts them to TrueType fonts. Because the Fonts Control Panel is unable to convert multiple
master fonts, you cannot install multiple master fonts in Windows NT.

The Adobe End-User License Agreement permits you to convert Adobe PostScript Type 1 fonts
using the Windows NT 4.x Fonts Control Panel, as long as you obey the Scope of Use section of
the agreement. You may not sell or distribute the converted fonts.
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Doesn’t Load in Windows

Issue
When you start Windows 95 or Windows 3.1x, the Adobe Type Manager (ATM) 3.0x icon
appears with an “X” through it or does not appear at all. When you open the ATM Control
Panel, it displays the message “Inactive” instead of the ATM version number (e.g., 3.02). Win-
dows may return the message “Unable to load Atmsys.drv.”

Solutions
Do one or more of the following:

A. Edit the System.ini file to make sure the [Boot] section contains the necessary references to
the ATM driver. If you’re using a shared version of Windows with multiple copies of the
System.ini file, each user’s System.ini file must contain the necessary references. To edit the
System.ini file:
1. Open the System.ini file, located in the Windows directory, in a text editor that can save

in text-only format (e.g., WordPad, Windows Write).
2. In the [Boot] section, modify the line:

system.drv=system.drv

to:

system.drv=atmsys.drv

3. Add the following line to the end of the [Boot] section:

atm.system.drv=system.drv

4. Save the System.ini file in text-only format, then restart Windows.
B. Make sure all the ATM files are installed and decompressed in the Windows and the

Windows\System directories. If any of these files is missing, or if any has a different exten-
sion (e.g., .ndl instead of .dll), exit Windows, delete all the installed ATM files, then reinstall
ATM from the original installation disks.

ATM installs the following files in the Windows directory:
Atmcntrl.exe
Atm.ini

ATM installs the following files in the Windows\System directory:
Atm32.dll
Atm16.dll
Atmsys.drv
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C. Copy the ATM installation files from the ATM disks to your hard disk, then install ATM:
1. In Windows Explorer (Windows 95) or File Manager (Windows 3.1x), create a directory

to contain the ATM installation files (e.g., C:\Atm).
2. Copy all the files from the ATM Program Disk to the Atm directory.
3. Copy the Fontdisk file and the entire PSFonts directory from the Font Disk to the ATM

directory.
4. Make sure you have the following files in your Atm directory:

Atm.cnf
Atm16.nd_
Atm32.nd_
Atmcntrl.ex_
Atmsys.dr_
Fontdisk
Install.cnf
Install.exe
Progdisk
Readme.wri
Techref.wri
Psfonts (directory)

5. Change the video driver to standard VGA. For instructions on changing the video driver
to VGA in Windows 95, see document 300303. For instructions on changing the video
driver to VGA in Windows 3.1x, see document 300604.

6. Double-click the Install.exe file in the ATM directory and follow the on-screen instruc-
tions to install ATM.

D. Reinstall ATM in Windows 95’s Safe mode:
1. Choose Start > Shut Down.
2. In the Shut Down Windows dialog box, select Restart the Computer.
3. When the message “Starting Windows 95” appears, press the F8 key.
4. Select the Safe Mode option (#3), then press Enter.

OR: Reinstall ATM in Windows 3.1x’s standard mode with the video driver set to
standard VGA and no other applications running. To start Windows 3.1x in standard
mode, type the following command at the DOS prompt:

win/s

E. Make sure the font cache setting in the ATM Control Panel does not exceed the amount of
RAM on your system.

F. Install ATM into a directory that does not have a name substantially similar to another
directory’s name. For example, the name “Windows2” is similar to the name “Windows.”

Additional Information
The ATM installer decompresses and renames the ATM files as it installs them and adds refer-
ences to ATM in the System.ini file. If the installer cannot decompress and rename the ATM files
or edit the System.ini file, ATM will be inactive. Reinstalling ATM or manually editing the
System.ini file may enable ATM to load as expected.

ATM 3.0x Is Inactive or Doesn’t Load in Windows continued



100

T
e

c
h

n
i

c
a

l
 

S
u

p
p

o
r

t
Type On Call

Some shared versions of Windows 3.11 have multiple System.ini files. One is stored on the
network server containing the shared copy of Windows, while others are stored on each work-
station. When you install ATM, the installer updates only the System.ini file on the network
server. The ATM installer is designed for a system with only one System.ini file. You can manu-
ally update multiple copies of the System.ini file to contain the references required for ATM to
start.

ATM’s Font Cache is an allotment of memory that ATM uses to store font data. The default size
of the Font Cache is 256K.

When you try to install ATM into a directory that has a name substantially similar to another
directory’s name (e.g., “Windows2” and “Windows”), the ATM installer may be unable to install
in the expected directory.

ATM 3.0x Is Inactive or Doesn’t Load in Windows continued
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Softfonts to PostScript
Printers

What’s Covered
Installing PostScript Fonts
Using ATM to Set Up Softfonts to Download
Manually Setting Up Softfonts to Download

To print PostScript fonts, the printer requires the PosScript font’s file. Most PostScript printers
have between 15 to 40 PostScript font files installed in their ROM (i.e., resident fonts). To print a
non-resident PostScript font, you install the font’s file on your system. When printing a non-
resisident PostScript font, your printer driver locates the PostScript font’s file on your system,
then downloads the font’s file to your printer.

The method for setting up your system to download non-resident PostScript fonts, or softfonts,
depends on which printer driver you are using. When using a Microsoft PostScript printer
driver, you add softfont references to the Win.ini file. When using the Adobe PostScript printer
driver (AdobePS), you add softfont references to the Atm.ini file, since it does not read softfont
references in the Win.ini file for printing.

Installing PostScript Fonts
The Microsoft Windows PostScript printer driver (i.e., Pscript.drv), and printer drivers based on
it (e.g., Lexps.drv), read softfont references in the [PostScript,<port>] section of the Win.ini file.
When a font file is referenced as a softfont in the [PostScript,<port>] section of the Win.ini file,
the Microsoft printer driver downloads the font to the printer when you print a document using
that font. You can set up Adobe Type Manager (ATM) to automatically add font references to
the Win.ini file when you add (i.e., install) fonts, or you can add softfont references manually.

When you add fonts, the options you select in ATM and the printer drivers you have installed
determine what ATM adds to your Win.ini file. When you add fonts in ATM with an ATM
download option selected, ATM adds font file references to each [PostScript,<port>] section of
the Win.ini file that uses a separate port. If you have installed printers on different ports (e.g.,
LPT1, LPT2, FILE), regardless of whether these printers are connected to your computer, ATM
adds a reference under each port section for every active font on your system. Each line ATM
adds to your Win.ini file increases its file size. The Win.ini file has a maximum allowable file size
of 64K, but keeping it 32K or smaller enables your system to run more efficiently and may
prevent errors. When the size of the Win.ini file exceeds 32K or 64K, Windows or applications
running in Windows may behave unpredictably.

Using ATM to Set Up Softfonts to Download
You can set up ATM to automatically add softfont references to the Win.ini file. In ATM 4.0, you
can specify whether ATM adds both metrics and outline file references, only metrics references,
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or neither. ATM 3.0x adds all softfont references, including both metrics and outline file refer-
ences. When you have a Microsoft PostScript printer driver installed, ATM enables you to add
font references to the Win.ini file.

To set up ATM 4.0 to automatically add font references to the Win.ini file:
1. In ATM, click the Settings tab, then click MS PostScript Driver.
2. Select one of the following options:

- Mark as Autodownload
When this option is selected, ATM adds metrics and outline file references to the
Win.ini file for each  [PostScript,<port>] section. Select this option to make sure your
printer driver downloads fonts to the printer.

- Mark Fonts as Resident in PostScript Printer
When this option is selected, ATM adds only metrics references to the Win.ini file for
each  [PostScript,<port>] section. Select this option for printer-resident fonts.

- Mark as Not to Be Installed
When this option is selected, ATM adds no softfont references to the Win.ini file for
each  [PostScript,<port>] section and sends only font characters required for printing
to the printer. Select this option to minimize the file size of the Win.ini file.

3. Click OK.
4. Click the Add Fonts tab, select the fonts you want to add, then click Add.

To set up ATM 3.0x to automatically add font references to the Win.ini file:
1. In the ATM Control Panel, click Add.
2. In the Add Fonts dialog box, select the Autodownload for PostScript Driver option, select

the fonts you want to add, then click Add.

Manually Setting Up Softfonts to Download
You can manually add softfont references to a [PostScript,<port>] section of the Win.ini file.
For example, when adding printer-resident fonts in ATM 3.0x, you can manually add references
to font metrics files only. By manually adding only the softfont references you need, you can
minimize the file size of the Win.ini file.

Before manually adding softfont references , determine the locations and filenames of your
fonts. Font filename prefixes often do not contain the font’s actual name (e.g., Akzidenz Grotesk
font files begin with GF, Centaur font files begin with NR). See the document Fntnames.pdf on
the Adobe Type On Call CD-ROM for a complete listing of Adobe font filenames.

To manually add softfont references to the Win.ini file:
1. Make a backup copy of the Win.ini file located in the Windows directory.
2. Open the original Win.ini file in a text editor that can save in text-only format (e.g.,

WordPad, Notepad, Windows Write).
3. Type the line “softfonts=x”, where “x” is the number of font references you are adding, as the

first line in the [PostScript,<port>] section for the printer to which you are printing (i.e.,
the first line after the section header, or the first line after the line “ATM=placeholder” if
present).

4. Type softfont references for each font file in the format
“softfontx=c:\psfonts\pfm\filename,c:\psfonts\filename”, where “x” is the sequential number

Setting Up ATM to Download Softfonts to PostScript Printers continued
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of the font reference. Type each new reference on a new line, and assign the next consecutive
number to it. Do not add space characters between letter characters. For example:

[PostScript,LPT1]
softfonts=8
softfont1=c:\psfonts\pfm\gn______.pfm,c:\psfonts\gn______.pfb
softfont2=c:\psfonts\pfm\gnb_____.pfm,c:\psfonts\gnb_____.pfb
softfont3=c:\psfonts\pfm\gnbi____.pfm,c:\psfonts\gnbi____.pfb
softfont4=c:\psfonts\pfm\gni_____.pfm,c:\psfonts\gni_____.pfb
softfont5=c:\psfonts\pfm\mtr_____.pfm,c:\psfonts\mtr_____.pfb
softfont6=c:\psfonts\pfm\mtb_____.pfm,c:\psfonts\mtb_____.pfb
softfont7=c:\psfonts\pfm\mtbi____.pfm,c:\psfonts\mtbi____.pfb
softfont8=c:\psfonts\pfm\mti_____.pfm,c:\psfonts\mti_____.pfb

5. Save the Win.ini file in text-only format.
6. Restart Windows.

Setting Up ATM to Download Softfonts to PostScript Printers continued
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ATM 4.0 Does Not Print to
PostScript Printer

Issue
A PostScript font installed in ATM Deluxe 4.0 or ATM 4.0 does not print to a PostScript printer
from any application. ATM is active, and TrueType fonts print as expected.

Solutions
Do one or more of the following:

A. Remove all your installed fonts from ATM, remove font references from the Win.ini file and
the Atm.ini file, re-add the problem font in ATM, then check the size of the Win.ini file:
1. Make backup copies of the Win.ini and Atm.ini files, located in the Windows directory.
2. In ATM, export your sets (ATM Deluxe 4.0 only) and remove all installed fonts. For

instructions, see Additional Information.
3. Open the original Win.ini file in a text editor that can save in text-only format (e.g.,

Notepad, WordPad).
4. Delete any lines that begin with “softfont” (e.g., softfonts=20).
5. Delete all lines that refer to an MFD file (e.g., ADMFDFile=C:\Windows\Ad434af1\

Mfd).
6. Save the Win.ini file in text-only format.
7. Open the original Atm.ini file in a text editor that can save in text-only format (e.g.,

NotePad, WordPad).
8. Delete any lines in the [Fonts] section (e.g., “Helvetica=C:\Psfonts\Pfm\Hv______.pfm;

C:\Psfonts\Hv______.pfb”).
9. Save the Atm.ini file in text-only format.
10. Delete all Atmfonts.qlc files, then restart Windows.
11. In ATM, re-add the problem font. For instructions, see Additional Information.
12. Choose Start > Find > Files or Folders, then locate the Win.ini file in the Windows

directory. Check the size of the Win.ini file in the search results scroll box and make sure
it is smaller than 32K. If the Win.ini file is greater than 32K, make a backup of the file,
then open the original Win.ini file in a text editor and remove lines or sections you no
longer need.

B. To ensure the font is not damaged, reinstall it from the original disks:
1. In ATM, click the Add Fonts tab (ATM Deluxe 4.0) or the Fonts tab (ATM 4.0), then

select Browse for Fonts from the Source pop-up menu.
2. Navigate to the drive and directory where your fonts files are located (e.g.,

C:\Psfonts\Pfm, A:\Fontdisk).
3. Select the fonts you want to add from the scroll box, then click Add.

C. Make sure the font’s outline (PFB) font file is located in the fonts directory (e.g., C:\Psfonts):
1. In Explorer, locate ATM’s fonts directory (e.g., C:\Psfonts).
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2. Verify that the outline file for your font is installed in the fonts directory. If you are
unsure of the font’s filename prefix, see the Fntnames.pdf file in the document directory
on the Type On Call CD-ROM.

D. Make sure there is only one Win.ini file on the computer, located in the Windows directory.
Rename all Win.ini files located in directories other than the Windows directory.

E. Print using another printer driver (e.g., use the Adobe PostScript printer driver 4.1 printer
driver instead of the Microsoft PostScript 4.0 printer driver).

F. Remove any TrueType font that has the same name as the PostScript font you are printing.
G. Make sure you are using a font the driver does not list as printer-resident:

1. Make backup copies of the Win.ini and Atm.ini files, located in the Windows directory.
2. In ATM, export your sets (ATM Deluxe 4.0 only) and remove all installed fonts. For

instructions, see Additional Information.
3. Open the original Win.ini file in a text editor that can save in text-only format (e.g.,

Notepad, WordPad).
4. Delete any lines that begin with “softfont” (e.g., softfonts=20).
5. Delete all lines that refer to an MFD file (e.g., ADMFDFile=C:\Windows\Ad434af1\

Mfd).
6. Save the Win.ini file in text-only format.
7. Open the original Atm.ini file in a text editor that can save in text-only format.
8. Delete any lines in the [Fonts] section (e.g., “Helvetica=C:\Psfonts\Pfm\Hv______.pfm;

C:\Psfonts\Hv______.pfb”).
9. Save the Atm.ini file in text-only format.
10. Delete all Atmfonts.qlc files, then restart Windows.
11. Open WordPad to check which fonts display as available PostScript fonts in your font

menu (i.e., fonts that display with a printer and paper icon). If the font you’re printing
displays in the font menu, the printer driver lists the font as a printer-resident font, and
will not download it. If the font you’re printing does not display in the font menu, the
printer driver does not list the font as printer-resident, and should download it to the
printer.

Additional Information
Fonts installed in ATM may not print as expected if ATM or the printer driver is unable to locate
the font’s outline file. ATM or the printer driver may be unable to locate the font’s outline font
file when:

- the font is improperly installed.
- the Win.ini file, the Atm.ini file, or the Atmfonts.qlc file references to the font are incorrect.
- the Win.ini file is too large (i.e., larger than 32K).
- the font file is damaged.
- the font’s outline (PFB) file is not installed.
- multiple Win.ini files are installed on your system.
- an installed TrueType font has the same name as the PostScript font you’re printing.

Removing all your installed fonts, removing font references from system and ATM files, re-
adding the font, and making sure the Win.ini file is not too large may enable the font to print as
expected.

PostScript Font Installed in ATM 4.0 Does Not Print to PostScript Printer continued
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When you have Autodownload for PostScript Printer selected in ATM’s Microsoft PostScript
Driver Fonts dialog box, ATM adds a reference to the Win.ini file indicating the location of your
font files. A large number of font references can cause the Win.ini file to grow too large, which
can cause a variety of system problems. The Win.ini file has a maximum allowable size of 64K,
but Adobe recommends a smaller size, preferably 32K or smaller. The Autodownload for
PostScript Printer option is only available if you have a Microsoft PostScript printer driver
installed on your system.

If both the TrueType and PostScript version of a font are installed (e.g., Helvetica), the printer
driver may be unable to locate the PostScript font’s outline font file. Make sure only the
PostScript version of the font is installed. To remove TrueType fonts installed in ATM Deluxe
4.0:
1. In the All Font Sets scroll box of the Sets pane, select the fonts you want to remove, then

click Remove.
2. In the Remove Font dialog box, select Remove Fonts from All Sets and Master Font List,

select Remove Font Files from Disk if desired, then click Yes or Yes to All.
When a printer driver lists a PostScript font as printer-resident, it will not download that font
when you print. If the font is not actually resident at the printer, however, it will not print as
expected. Using a font that the driver does not list as printer-resident causes the driver to
download the font to the printer and print the font as expected.

If the font prints when you select a different printer driver, the original printer driver was unable
to locate the font’s outline file for downloading, or it lists the font as printer-resident. The driver
may be unable to locate the outline file if the font is damaged, if the font references in the
Win.ini are incorrect, if the driver is damaged, or if the driver is incompatible with PostScript
fonts.

Font filename prefixes often do not resemble the font’s actual name (e.g., Akzidenz Grotesk font
files begin with GF, Centaur font files begin with NR). For a complete listing of Adobe font
filenames, refer to the Filenames.pdf document on the Type On Call CD-ROM.

To export your sets in ATM Deluxe 4.0:
1. In ATM, click the Sets tab.
2. Select one or more sets to export.
3. Choose File > Export.
4. In the Export dialog box, specify a filename and location for the AFS file, then click Save.

To remove your fonts in ATM 4.0:
1. In the All Font Sets pane of the Sets tab (ATM Deluxe 4.0) or the Fonts tab (ATM 4.0), select

the fonts you want to remove, then click Remove.
2. In the Remove Font dialog box, select Remove Fonts from All Set and Master Font List,

select Remove Font Files from Disk if you are reinstalling your fonts from the original
installation disks, then click Yes or Yes to All.

PostScript Font Installed in ATM 4.0 Does Not Print to PostScript Printer continued
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To re-add your font in ATM 4.0:
1. Click the Add Fonts tab (ATM Deluxe 4.0) or the Fonts tab (ATM 4.0), then select Browse

for Fonts from the Source pop-up menu.
2. Navigate to the drive and directory where your fonts files are located (e.g., C:\Psfonts\Pfm,

A:\Fontdisk).
3. Select the fonts you want to add from the Source pane scrollbox, then click Add.

To import your sets ATM Deluxe 4.0:
1. With Browse for Fonts still selected in the Source pop-up menu, navigate to the drive and

directory where your AFS file is located. ATM lists the sets you exported in the AFS file.
2. Select the sets you want to import, then click Add.
3. Remove any duplicate fonts outside your sets by selecting them and clicking Remove.

PostScript Font Installed in ATM 4.0 Does Not Print to PostScript Printer continued
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Packages with Multiple Disks

If a font package contains too much information to fit on one disk, it includes two or more
disks. When you install fonts from a multiple-disk package in Adobe Type Manager, ATM may
return a “Cannot find file” message if it cannot locate a font file on the expected disk. To install
the fonts, you can copy the font files to a directory on your hard disk and then install them, or
you can insert the disks consecutively until ATM locates the expected font file.

To copy font files to your hard disk and then install them:
1. Create a temporary directory on your hard disk (e.g., C:\Fonttemp).
2. Copy the contents of each disk into the directory. If a disk contains a directory, copy both

the directory and its contents.
3. When adding fonts in ATM, add the fonts from the temporary directory.
4. After adding the fonts, delete the temporary directory.
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Deluxe

Adobe Type Manager (ATM) 4.0 Deluxe includes an Uninstall option in its Settings pane.
However, when you are unable to access the Uninstall option (e.g., ATM won’t start), you can
remove ATM manually by removing ATM entries from the System.ini file and the Windows 95
Registry, deleting the ATM files, and removing softfont references from the Win.ini file. The
Win.ini file contains softfont references for printers that use a Microsoft Windows PostScript
printer driver, which you need to remove before you re-add fonts in ATM.

Before removing ATM, start Windows 95 in Safe Mode so that Windows doesn’t load ATM. To
start in Safe Mode, press the F8 key when the message, “Starting Windows 95” appears, then
select Safe Mode from the startup menu.

To remove references to ATM from the System.ini file:
1. Make a backup copy of the System.ini file, which is located in the Windows directory.
2. Open the original System.ini file in a text editor that can save in text-only format (e.g.,

Notepad, WordPad).
3. In the [Boot] section, edit the system.drv=atmsys.drv line to read:
system.drv=system.drv
4. Delete the line:
atm.system.drv=system.drv
5. Save the System.ini file as text-only.

To remove references to ATM in the Registry:
1. Choose Start > Run.
2. Type “regedit” in the Open text box and click OK.
3. Make a backup copy of the Registry by choosing Registry > Export Registry File, choosing a

location and name for the backup file in the Export Registry File dialog box, then clicking
Save.

4. Open the Hkey_Local_Machine \Software\Adobe key (i.e., directory), select the Adobe Type
Manager key, then press the Delete key to delete it.

5. Exit the Registry Editor, which automatically saves your changes to the Registry.

To delete ATM system files:

NOTE: The following files may be in directories other than those listed. Choose Start > Find >
Files or Folders and search for files named “atm*.*” to locate files stored in other directories.

1. Delete the following files from the Windows directory:
Atm.ini
Atmreg.atm
Atm.cnf

2. Delete the following files from the Windows\System directory:
Atm32.dll
Atmsys.drv
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3. Delete the following files from the Psfonts directory:
Atmfm.exe
Atmsubst.atm
Atmfont.qlc
Atm[xxx].hlp (where [xxx] indicates the localized language)
Atm[xxx].gid (where [xxx] indicates the localized language)
Atm[xxx].cnt (where [xxx] indicates the localized language)
Atm[xxx].fts (where [xxx] indicates the localized language)

4. Delete any ATM Font Set (AFS) files (i.e., files with an .afs extension) from your hard drive.
AFS files can be stored in any directory.

To remove softfont references from the Win.ini file:
1. Make a backup copy of the Win.ini file, which is located in the Windows directory.
2. Open the original Win.ini file in a text editor that saves in text-only format (e.g., Notepad,

WordPad).
3. Delete any line that begins with the word “softfont” from each [PostScript,<port>] section

(e.g., [PostScript, FILE], [PostScript, LPT1]).
4. Save the Win.ini file as text-only and restart Windows.

Manually Removing ATM 4.0 Deluxe continued



111

T
e

c
h

n
i c

a
l  

S
u

p
p

o
r

t
Type On Call Removing Adobe Type

Manager 3.0x, 2.6 or 2.5

To remove Adobe Type Manager (ATM) 3.0x, 2.6 or 2.5 from Windows 3.x, Windows 95, or
Windows running under OS/2, remove all fonts installed in the ATM Control Panel, remove
softfont references from the Win.ini file, remove references to ATM from the System.ini file, and
remove ATM system files.

The Win.ini file contains softfont references for printers that use a Microsoft Windows
PostScript printer driver, which may not all be removed by ATM when you remove installed
fonts from ATM.

To remove fonts installed in the ATM Control Panel:
1. In the ATM Control Panel, select all the fonts in the Installed ATM Fonts list.
2. Click Remove.
3. Exit ATM.

To remove softfont references not removed by ATM from the Win.ini file:
1. Make a backup copy of the Win.ini file, located in the Windows directory.
2. Open the original Win.ini file in a text editor that saves in text-only format (e.g., Windows

Write, Notepad, Wordpad).
3. Delete any line that begins with the word “softfont” from each [PostScript,<port>] section

(e.g., [PostScript, FILE], [PostScript, LPT1]).
4. Save the Win.ini file as text-only and restart Windows.

To remove references to ATM in the System.ini file:
1. Make a backup copy of the System.ini file located in the Windows directory.
2. Open the original System.ini file in a text editor that can save in text-only format (e.g.,

Windows Write, Notepad, Wordpad).
3. In the [Boot] section, edit the system.drv=atmsys.drv line to read:

system.drv=system.drv

OR: When MoreFonts is installed, edit the mf.system.drv=atmsys.drv line to read as follows:

mf.system.drv=system.drv

OR: When TrueEffects is installed, edit the tx.system.drv=atmsys.drv line to read as follows:

tx.system.drv=system.drv

OR: When you are using an HP Vectra, edit the system.drv=atmsys.drv line to read as
follows:

system.drv=hpsys.drv
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4. Delete the line “atm.system.drv=system.drv.”
5. Save the System.ini file as text-only and restart Windows.

To remove ATM system files:
1. Delete the following files from the Windows directory:

Atmcntrl.exe
Atm.ini
Atm_read.wri
Techref.wri

2. Delete the following files from the Windows\System directory:
Atm32.dll
Atm16.dll
Atmsys.drv
Atm.saf
Atm.bak
Atm.dll

Removing Adobe Type Manager 3.0x, 2.6 or 2.5 continued
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General Information

Multiple master fonts are customizable PostScript fonts. The multiple master font format
describes a typeface’s characteristics using linear design axes, which include weight, width,
optical size, and style (i.e., slab, serif). Each design axis has a linear range. For example, Myriad’s
weight axis range is 1 to 830, and its width axis range is 1 to 700.

Multiple master fonts include a number of primary font instances, preconfigured at differing
intersections of their design axes. For example, Myriad includes 15 primary instances, ranging
from 215 LT 300 CN (Light Condensed) to 830 BL 700 SE (Black SemiExtended). You use the
Font Creator utility to create custom instances.

Multiple master font files, which are larger than single master fonts, require a minimum of 3 MB
of printer memory (RAM). PostScript Level 1 printers that don’t have the minimum of 3 MB of
RAM (e.g., Personal LaserWriter NT, Hewlett-Packard LaserJet with PostScript Level 1 cartridge)
are unable to print multiple master fonts.

Adobe multiple master fonts include:

ITC Avant Garde Gothic
Caflisch Script
Conga Brava
Cronos
Ex Ponto
ITC Garamond
Graphite
Jenson
Jimbo
Kepler
Mezz
Minion
Minion Expert
Myriad
Nueva
Ocean Sans
Penumbra
Sanvit
Tekton
Viva

Multiple Master Font Names
All multiple master fonts have MM after the typeface name, with the numeric values of their
weight and width added to short axis abbreviations (e.g., MinioMM_578 BD 465 CN 11 OP).
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Weight Axis (wt)
XL: ExtraLight

LT: Light

RG: Regular

SB: Semibold

BD: Bold

BL: Black

Width Axis (wd)
XC: ExtraCondensed

CN: Condensed

SC: SemiCondense

NO: Norma

SE: SemiExtended

EX: Extended

XE: ExtraExtended

Optical Size Axis (op)
OP: Optical size (from 6 to 72)

Optical Size
The optical size axis enables you to generate fonts that are optically adjusted for use at specific
point sizes. As the optical size increases, the space between the characters (letter fit) tightens, the
space within the characters (counters) becomes smaller, the serifs become finer, the overall
weight becomes lighter, and the x-height gradually decreases in size. Jenson, Minion, Minion
Expert, and Sanvito support optical scaling.
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Master Typefaces General
Information

In traditional metal typefounding, each style and size of a typeface was cut by hand. Subtle
adjustments to letter proportion, weight, contrast, and spacing were made to optimize readabil-
ity in every point size. Digital type technologies generally scale type using mathematical formu-
las that do not allow for variations at different sizes for enhanced readability. Most digital type is
optimized for use at 12 point text size. For optimal readability, smaller type sizes require addi-
tional space between characters, and larger sizes require less space.

Multiple master typefaces that include the optical size axis enable you to generate fonts that are
optically adjusted for use at specific point sizes, where smaller text is clear and easy to read, and
larger sizes are refined and elegant. As the optical size increases in a multiple master typeface, the
space between the characters decreases, the space within the characters (counters) becomes
smaller, the serifs become finer, the overall weight becomes lighter, and the x-height gradually
decreases in size.

When specifying the optical size axis for a multiple master typeface, begin by specifying the
same value as the text’s point size. For example, for 10-point text, specify 10 points for the
optical size; for 96-point text, specify the closest optical size value, which is usually 72. Unlike
other multiple master axes, the optical size axis is non-linear, which causes noticeable changes to
the shape of characters depending on the text’s point size. For example, a change to the optical
size by 2 points for 10-point text is more noticeable than for 72-point text, and the difference in
character shape is noticeable for 9-point text with an optical size axis value greater than 9 points.
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Information

Font Creator is a utility that creates and removes custom multiple master font instances. Font
Creator does not modify single master fonts. Font Creator is included with Multiple Master font
packages, Adobe Type Manager (ATM) 3.x, and Type On Call 4.0 and later.

Font Creator for Windows is incorporated into ATM 3.0x. When one or more multiple master
fonts are installed on the computer, clicking the Create button in the ATM Control Panel
accesses Font Creator utility. The Create button is dimmed when no multiple master fonts are
installed.

Font Creator for the Macintosh is included as a separate application with ATM 3.8.2 and earlier,
Type On Call 4.0 and later, and Multiple Master font packages. ATM 3.9 incorporates Font
Creator into the ATM control panel. When one or more multiple master fonts are installed on
the Macintosh, clicking the Create MM Instances button in the ATM 3.9 control panel accesses
Font Creator. When no multiple master fonts are installed, launching Font Creator or clicking
Create MM Instances in the ATM 3.9 control panel causes the error “Please install some Mul-
tiple Master fonts on your system and try again.” to appear.

The multiple master fonts Adobe Sans MM and Adobe Serif MM cannot be used with the Font
Creator utility.
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fonts found” Appears When
Starting Windows

Issue
When you start Windows, the alert, “Old multiple master fonts found. Please install new ones.”
appears.

Solutions
If you’re using ATM 2.6, delete the Atm.ini file, then reinstall ATM.

OR: Do one or more of the following:

A. Use ATM 3.01 or later.

B. Delete the Atm.ini file, then restart Windows.

Additional Information
The alert, “Old Multiple Master fonts found. Please install new ones.” occurs when the
[MMFonts] section of the Atm.ini file lists multiple master fonts that are incompatible with the
currently installed version of ATM. ATM 2.6 requires the AdobeSansxMM and AdobeSerifMM
fonts, and ATM 3.0x requires the AdobeSanMM and AdobeSerMM fonts.

When you install ATM 3.01 or later, it automatically removes invalid multiple master font
references from the [MMFonts] section of the Atm.ini file. After you reinstall ATM, or after you
delete the Atm.ini file and restart Windows, ATM creates a new Atm.ini file containing the
appropriate multiple master font information.
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Calculating Characters per
Pica

You can calculate characters per pica (cpp) for Type 1 fonts, also called PostScript fonts, to help
calculate the page count for books and periodicals. For example, a document that has 8.7532
cpp, 20 picas per line, and 100,000 characters requires approximately 571 lines. You can multiply
the required number of lines by the line height to calculate column-inches and page count. You
can calculate only an approximate cpp value, however, since variables such as the application or
printer driver you are using affect the cpp value.

To calculate approximate cpp:
1. Open the font's AFM file in a text editor that can save in text-only format (e.g., WordPad,

Notepad).
2. Locate the character values that follow the StartCharMetrics line. For example, the letter "A"

appears as:

C 65 ; WX 481; N A ; B -22 0 491 704 ;

3. Add the 3- or 4-digit WX (i.e., width of the x-axis) values for all the uppercase and lower-
case letters (i.e., A to Z and a to z), then divide the total by 52 to determine the average letter
width value. The resulting value is T.

4. Close the font's AFM file.
5. Determine the point size (e.g., 10, 12) for which you want to calculate cpp. The point size

value is p.
6. Multiply T by p. The resulting value is Tp.
7. Enter Tp in the following equation:

340,722 ÷ Tp = cpp

The number 340,722 represents the results of the equation:

12 ÷ [((T ÷ 26.5) x p) ÷  1000]

This equation represents the algebraic equivalents for:
- In the PostScript page description language, one point is equivalent to 99.62% of a tradi-

tional typographer's point, where the digital point is 1/72" and the traditional printer's
point is 1/72.29".

- The sum of the widths of all lowercase characters from a to z are divided by 26.5 to account
for punctuation variances for cpp output.

- Since a pica is 12 points, the cpp value is expressed in units of 12. Therefore, the total width
of all lowercase characters, divided by 26.5 and multiplied by the point size, is normalized to
units of 12.
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